-
Nu ook geen problemen meer, maar het probleem doet zich nog wel voor op een andere site van een klant (maxmusic.nl). In IE7 zelfde fout. Toen in FF gekeken, witte pagina. Even gecaptured met Live HTTP Header plugin:
-----------------------
http://maxmusic.nl/
GET / HTTP/1.1
Host: maxmusic.nl
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: nl,en-us;q=0.7,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache
HTTP/1.x 200 OK
http://maxmusic.nl/favicon.ico
GET /favicon.ico HTTP/1.1
Host: maxmusic.nl
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Accept: image/png,*/*;q=0.5
Accept-Language: nl,en-us;q=0.7,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
HTTP/1.x 404 Not Found
Date: Sat, 13 Jan 2007 15:11:07 GMT
Server: Apache
Keep-Alive: timeout=5, max=499
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1
------------------
Kan iemand hier iets raars aan zien? Hij vraagt om de pagina OK, favicon kan ie niet vinden (is er niet) dus 404, maar voor de rest stopt hij gewoon dus.
Na wat navraag gedaan te hebben: de problemen treden op nadat de klanten de website hebben aangepast.
Klant heeft site aangepast, ik hou jullie op de hoogte of daar het probleem nog steeds is.
Update: even getelnet:
[root@themis root]# telnet openhost.nl 80
Trying 217.170.21.221...
Connected to openhost.nl.
Escape character is '^]'.
GET / HTTP/1.1
Host:openhost.nl
Ik krijg hier gewoon response in html vorm. Nu op de probleemsite:
[root@themis root]# telnet maxmusic.nl 80
Trying 217.170.21.221...
Connected to maxmusic.nl.
Escape character is '^]'.
GET / HTTP/1.1
Host:maxmusic.nl
Connection closed by foreign host.
------
Het ligt ook niet aan de ftp clients van de klanten, een nieuw gemaakte account in DA heeft het ook (met de default pagina voor de nieuwe klant)
-
IE6
test: http://janborn.nl no problemo
origineel http://janborn.nl/index2.html dood (geen bron inderdaad)
Dom natuurlijk, ook geen bron, de bron van de 404 was dit :).
-
Ik zou beginnen met in IE die error pages uit te zetten bij options. Zolang dat aan staat (en dat is standaard) zie je alleen 'Page cannot be displayed', als je dat uit zet komt de error van de webserver er (if any). Dan heb je al iets meer duidelijkheid
-
Dan nog steeds een 404/not found.
-
Even over die janborn pagina, de klant heeft deze veranderd dus dat gaat even niet meer op . Probeer maxmusic.nl.
Verder ben ik nu (dank Exsilia voor de thulp) de schijf op errors aan het checken.
-
Ik raad je aan om je settings van apache na te lopen.
En dan met name 'MaxClients', 'StartServers', 'MaxServers' etc.
Ik heb ook de ervaring, dat als die settings niet goed staan, die 'fouten' optreden. Apache reageert dan gewoon niet meer.
Wat staat er in de apache logs?
-
Maxclients: 550
StartServers: 8
Maxservers: niet in config
Ik heb nog eens de error_log getailed en weer getelnet:
[Sun Jan 14 10:50:05 2007] [notice] child pid 809 exit signal Segmentation fault (11)
Na wat gegoogle zou opnieuw compilen van apache en php misschien helpen... Straks even doen
---Update:
Opnieuw compilen van apache en php haalt niks uit :( Wat kan het nou zijn?
-
sorry, maar hier doet hij het ook niet.. IE7 & Multikabel
-
--- Final Update:
Opgelost! Bleek dat er wss in het config script van de cli versie van php nog een optie stond waardoor in apache de php module wordt geladen. We gebruiken suPHP dus dat is niet nodig en gaf blijkbaar problemen.
Bedankt iedereen