Likes Likes:  0
Resultaten 1 tot 11 van de 11
Geen
  1. #1
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    geregistreerd gebruiker
    478 Berichten
    Ingeschreven
    24/11/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Thread Starter

    Software RAID-1 Debian, stopping MD1 array failed (busy)

    Beste,

    Ik gebruik software raid onder debian (SATA HD's) en heb de onderstaande
    partities. Tijdens het rebooten van het systeem krijg ik: stopping MD1 array...failed(busy)
    (hier staan alle partities op behalve /boot). Heeft iemand een idee waar dit door komt of hoe dit op te lossen is? (Hij is overigens niet aan het syncen, zie mdstat inhoudt)

    mars:/# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/mapper/vg00-root
    20G 101M 19G 1% /
    tmpfs 443M 0 443M 0% /dev/shm
    /dev/md0 471M 16M 431M 4% /boot
    /dev/mapper/vg00-home
    228G 33M 217G 1% /home
    /dev/mapper/vg00-tmp 1008M 33M 925M 4% /tmp
    /dev/mapper/vg00-usr 12G 163M 12G 2% /usr
    /dev/mapper/vg00-var 30G 93M 28G 1% /var

    Inhoud mdstat
    tmpfs 10M 72K 1Personalities : [raid1]
    md1 : active raid1 sda2[0] sdb2[1]
    312070592 blocks [2/2] [UU]

    md0 : active raid1 sda1[0] sdb1[1]
    497856 blocks [2/2] [UU]
    0M 1% /dev

    Tevens lijkt hij niet te willen booten als ik sdb eruit trek (GRUB komt niet op) echter
    /boot staat op md0, wat doe ik hier fout?

    Groeten,

    Sander
    Laatst gewijzigd door bami82; 27/12/06 om 19:22.

  2. #2
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    Ik gebruik software raid onder debian (SATA HD's) en heb de onderstaande
    partities. Tijdens het rebooten van het systeem krijg ik: stopping MD1 array...failed(busy)
    Toevallig kwam ik het zelfde tegen bij het installeren van Debian 'Etch'. Ik moet er nog even naar kijken, maar volgens mij heeft het er mee te maken dat de partitie niet goed wordt 'ge-umount'. LVM geeft aan dat de LV's nog in gebruik zijn. Handmatig unmounten voor het rebooten/shutdownen zorgt dan voor minder problemen (minder LV's die in gebruik zijn, dus ik ga er vanuit dat daar het probleem zit)

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    Tevens lijkt hij niet te willen booten als ik sdb eruit trek (GRUB komt niet op) echter
    /boot staat op md0, wat doe ik hier fout?
    Ow... dat is goed te doen (even voorbeeldje eigen howto):



    Openen van de grub shell met "grub --no-floppy":
    Code:
        GNU GRUB  version 0.95  (640K lower / 3072K upper memory)
    
     [ Minimal BASH-like line editing is supported.  For the first word, TAB
       lists possible command completions.  Anywhere else TAB lists the possible
       completions of a device/filename. ]
    
    grub>
    Selecteren /boot/grub/menu.lst partitie van /dev/hda / (hd0):
    Code:
    grub> root (hd0,1)
     Filesystem type is ext2fs, partition type 0xfd
    Grub installeren in de MBR van /dev/hda / (hd0):
    Code:
    grub> setup (hd0)
     Checking if "/boot/grub/stage1" exists... yes
     Checking if "/boot/grub/stage2" exists... yes
     Checking if "/boot/grub/e2fs_stage1_5" exists... yes
     Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
    succeeded
     Running "install /boot/grub/stage1 (hd0) (hd0)1+16 p (hd0,1)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
    Done.
    Omdat bij het wegvallen van /dev/hda /dev/hdb de referentie (hd0) krijgt, moet ook daar grub worden geïnstalleerd in de MBR. Omdat grub automatisch (hd..) detecteerd, moeten we (hd0) omleiden naar /dev/hdc):
    Code:
    grub> device (hd0) /dev/hdc
    En wederom de partitie waarop /boot/grub/menu.lst staat aangeven, maar dit maal omgeleid naar /dev/hdc:
    Code:
    grub> root (hd0,1)
     Filesystem type is ext2fs, partition type 0xfd
    En nu grub installeren in de MBR van (hd0) omgeleid naar /dev/hdc:
    Code:
    grub> setup (hd0)
     Checking if "/boot/grub/stage1" exists... yes
     Checking if "/boot/grub/stage2" exists... yes
     Checking if "/boot/grub/e2fs_stage1_5" exists... yes
     Running "embed /boot/grub/e2fs_stage1_5 (hd0)"...  16 sectors are embedded.
    succeeded
     Running "install /boot/grub/stage1 (hd0) (hd0)1+16 p (hd0,1)/boot/grub/stage2 /boot/grub/menu.lst"... succeeded
    Done.
    Nog even afsluiten en testen maar!
    Code:
    grub> quit
    Laatst gewijzigd door ®on; 27/12/06 om 21:30.

  3. #3
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    geregistreerd gebruiker
    478 Berichten
    Ingeschreven
    24/11/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Thread Starter
    Bedankt voor je reactie. Hmm ik zal het wel verkeerd doen maar dit werkt bij mij niet

    Code:
    grub> root (hd0,1)
     Filesystem type unknown, partition type 0xfd
    
    grub> setup (hd0)
    
    Error 17: Cannot mount selected partition
    
    grub>

  4. #4
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    Bedankt voor je reactie. Hmm ik zal het wel verkeerd doen maar dit werkt bij mij niet

    Code:
    grub> root (hd0,1)
     Filesystem type unknown, partition type 0xfd
    Hier gaat het iig al fout, "type unknown" zou niet mogen voorkomen.

    Dat wat achter "root" komt, is de hdd/partitie die "/boot/grub/menu.lst" bevat (In jou geval dus "/dev/sda1" en "/dev/sdb1".

    /dev/sda1 is "hd0,0" en niet "hd0,1" (waarschijnlijk bij jou een swap partitie).

    Probeer het dus eens met:
    Code:
    grub> root (hd0,0)
    Op de GRUB-prompt kun je ook TAB gebruiken om hdd's en patities te selecteren ( doe maar eens root (hd<TAB> ) en ook dit kan handig zijn:
    Code:
    grub> find /boot/grub/menu.lst
    Overigens, bovenstaande is slechts een extractie uit:
    http://tldp.org/HOWTO/html_single/So...D-HOWTO/#ss7.3
    http://www.linuxsa.org.au/pipermail/...ly/058254.html

  5. #5
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    geregistreerd gebruiker
    478 Berichten
    Ingeschreven
    24/11/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Thread Starter
    Ok heel erg bedankt, het werkt.

  6. #6
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Mooi zo

  7. #7
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    Ik gebruik software raid onder debian (SATA HD's) en heb de onderstaande
    partities. Tijdens het rebooten van het systeem krijg ik: stopping MD1 array...failed(busy)
    Heb je hier trouwens al een oplossing voor gevonden?

    Citaat Oorspronkelijk geplaatst door vaplu Bekijk Berichten
    Heb je hier trouwens al een oplossing voor gevonden?
    Ik heb er nog eens naar gekeken, waarschijnlijk heeft het er mee te maken dat jouw root (/) partitie op een LVM volume staat die weer op een RAID partitie staat.

    Waarschijnlijk lukt het LVM niet om "/dev/mapper/vg00-root" af te sluiten.

    Zie ook (maar helaas zonder reactie):
    http://www.unixadmintalk.com/f59/can...utdown-133966/

    Ik heb geen idee hoe dit netjes opgelost kan worden zodat ook mdadm zijn RAID devices netjes kan afsluiten.

    Iemand anders een idee?

    - - - -

    :S ... dat automerge is niet mijn ding ...
    Laatst gewijzigd door vaplu; 02/01/07 om 15:10. Reden: Automerged Doublepost

  8. #8
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    geregistreerd gebruiker
    478 Berichten
    Ingeschreven
    24/11/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Thread Starter
    /root staat inderdaad op een LVM volume en die staat ook weer op een RAID partitie. Ik heb nog geen oplossing gevonden.

  9. #9
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    /root staat inderdaad op een LVM volume en die staat ook weer op een RAID partitie. Ik heb nog geen oplossing gevonden.
    Ik vraag me af of er wel een oplossing bestaat ... Wanneer kun/mag je de root partitie (/) umounten tijdens het afsluiten?

  10. #10
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    geregistreerd gebruiker
    478 Berichten
    Ingeschreven
    24/11/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Thread Starter
    Las net het volgende:

    + It is perfectly normal for mdadm to report the array with the root
    + filesystem to be busy on shutdown. The reason for this is that the root
    + filesystem must be mounted to be able to stop the array (or otherwise
    + /sbin/mdadm does not exist), but to stop the array, the root filesystem
    + cannot be mounted. Catch 22. The kernel actually stops the array just before
    + halting, so it's all well.

  11. #11
    Software RAID-1 Debian, stopping MD1 array failed (busy)
    Rien ne va plus
    332 Berichten
    Ingeschreven
    11/06/03

    Locatie
    Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: .
    Ondernemingsnummer: .

    Citaat Oorspronkelijk geplaatst door bami82 Bekijk Berichten
    Las net het volgende:

    + It is perfectly normal for mdadm to report the array with the root
    + filesystem to be busy on shutdown. The reason for this is that the root
    + filesystem must be mounted to be able to stop the array (or otherwise
    + /sbin/mdadm does not exist), but to stop the array, the root filesystem
    + cannot be mounted. Catch 22. The kernel actually stops the array just before
    + halting, so it's all well.
    Aah thnx

    En dit alles was natuurlijk ook hier te lezen:
    Code:
    zcat /usr/share/doc/mdadm/FAQ.gz
    Ik betrap mij zelf er nog te vaak op dat ik naar google grijp in plaats van naar: /usr/doc

    Toch fijn om een draadje af te kunnen sluiten

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics