Likes Likes:  0
Resultaten 1 tot 7 van de 7
Geen
  1. #1
    Access_log word niet gevuld
    a.k.a. Opa-Bullcat-
    1.182 Berichten
    Ingeschreven
    08/04/05

    Locatie
    Haarlem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34223894
    Ondernemingsnummer: nvt

    Thread Starter

    Access_log word niet gevuld

    Goedemiddag,

    Wat kan de reden zijn dat de access_log van httpd niet word weggeschreven, de date en time stamps verranderen wel, maar van enige tekst erin is geen sprake.
    de root is de owner en heeft als enige schrijf rechten erin, iemand een idee ?

    Hans
    Ps. de error_log word dus wel netjes gevuld.

  2. #2
    Access_log word niet gevuld
    geregistreerd gebruiker
    5.163 Berichten
    Ingeschreven
    04/06/05

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Voor u gelezen in httpd.conf

    #
    # ErrorLog: The location of the error log file.
    # If you do not specify an ErrorLog directive within a <VirtualHost>
    # container, error messages relating to that virtual host will be
    # logged here. If you *do* define an error logfile for a <VirtualHost>
    # container, that host's errors will be logged there and not here.
    #

  3. #3
    Access_log word niet gevuld
    a.k.a. Opa-Bullcat-
    1.182 Berichten
    Ingeschreven
    08/04/05

    Locatie
    Haarlem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34223894
    Ondernemingsnummer: nvt

    Thread Starter
    Voor u gelezen in mijn posting :
    Hans
    Ps. de error_log word dus wel netjes gevuld.

    het gaat op de acces_log dus en die staat in httpd.conf wel degelijk aan

    en dit is een gedeelte eruit

    ErrorLog /var/log/httpd/error_log
    LogLevel warn

    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    LogFormat "%{Referer}i -> %U" referer
    LogFormat "%{User-agent}i" agent
    LogFormat "%b" bytes

    CustomLog /var/log/httpd/access_log combined

    dus ja zeg het maar, er zijn wel access_log bestanden, maar leeg

    ik zit ondertussen ook al te googlen op inet, maar lees wel problemoo solved, maar niet hoe
    Laatst gewijzigd door Bullcat; 25/10/06 om 16:58.

  4. #4
    Access_log word niet gevuld
    geregistreerd gebruiker
    5.163 Berichten
    Ingeschreven
    04/06/05

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt



    #
    # The location and format of the access logfile (Common Logfile Format).
    # If you do not define any access logfiles within a <VirtualHost>
    # container, they will be logged here. Contrariwise, if you *do*
    # define per-<VirtualHost> access logfiles, transactions will be
    # logged therein and *not* in this file.
    #

  5. #5
    Access_log word niet gevuld
    a.k.a. Opa-Bullcat-
    1.182 Berichten
    Ingeschreven
    08/04/05

    Locatie
    Haarlem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34223894
    Ondernemingsnummer: nvt

    Thread Starter
    Ok je hebt gelijk, ondertussen gevonden, het werdt samen geprakt in homedir.log

    alleen ben ik niet zo tevreden met de opbouw van die log. m.a.w. je kunt er niet zoveel mee

    534 "GET /~johan/Themes/classic/images/dutch/home.gif HTTP/1.1"
    252 "GET /~johan/Themes/classic/images/dutch/help.gif HTTP/1.1"

    de tijd en ip adres ervoor zou uiteraard wel wat prettiger werken, als er weer eens iemand denkt dat hij het nodig vind om rare zaken uit te vreten op de server, herb je daar toevalig ook een oplossing voor

    dit staat nu bij virtualHost
    CustomLog /var/log/httpd/homedir.log homedir

    Hans

    Ps. ondertussen ergens iets over logformat gelezen : LogFormat "%b \"%r\"" homedir

    maar wilde toch nog even reageren, misschien voor een ander ook leuk

  6. #6
    Access_log word niet gevuld
    geregistreerd gebruiker
    5.163 Berichten
    Ingeschreven
    04/06/05

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Je moet even in je httpd.conf kijken. Daar staan een aantal logformats die je standaard aan kan roepen.

  7. #7
    Access_log word niet gevuld
    a.k.a. Opa-Bullcat-
    1.182 Berichten
    Ingeschreven
    08/04/05

    Locatie
    Haarlem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34223894
    Ondernemingsnummer: nvt

    Thread Starter
    Ja heb ik inderdaad gedaan, gewoon die van combined naar home dire gecopieerd
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" homedir

    httpd restart = geen resultaat
    httpd stop/start = geen resultaat
    reboot, he he eindelijk een uitpluisbare log file

    Maar het werkt dus, even op de andere ook aan gaan passen, het is trouwens wel wazig dat /etc/init.d/httpd restart , geen aangepaste log files laat zien, maar ik denk dat de file nog in gebruik was om de 1 of andere manier.

    Nog even een toevoeging van mijn kant, heb het nu werkend.

    zet bij je virtual gedeelte het volgende neer, en de log word aangemaakt tijdens een restart.
    CustomLog /var/log/httpd/homedir.cmb.log combined
    Laatst gewijzigd door Bullcat; 25/10/06 om 21:23. Reden: Automerged Doublepost

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics