Likes Likes:  0
Resultaten 1 tot 15 van de 44
Pagina 1 van de 3 1 2 3 LaatsteLaatste
  1. #1
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    clamav problemen na update via update script

    We hadden de EOL melding van ClamAv (zie http://www.clamav.net/lang/en/2009/1...ol-clamav-094/) niet gelezen en we liepen al jaren achter met het update van clamav.
    Echter sinds de 15de hebben we dus problemen met onze mail ontvangen en versturen. Precies zoals beschreven in de EOL aanmelding.
    Gebruikers van het systeem krijgen een foutmelding in outlook (express):
    Taak xxxxxx- Verzenden... rapporteert fout (0x800CCC6A): Er is een interne fout opgetreden op de server voor uitgaande e-mail (SMTP). Als u dit bericht blijft ontvangen, neemt u contact op met de serverbeheerder of internetprovider (ISP). De reactie van de server was: 451 Temporary local problem - please try later
    Dat was op te lossen door het bestand daily.cvd weg te gooien en dan clamd opnieuw op te sturen, maar ja dat willen we natuurlijk niet echt.
    Daarom zijn we de update begonnen naar de laatste versie ClamAv. Dat viel nog niet mee, maar via het updatescript van http://www.web4host.net lukte het uiteindelijk wel.
    Echter na herstart bleken de gebruikers nog steeds dezelfde foutmelding te krijgen.
    In het exim/mainlog krijgen we de volgende meldingen:
    2010-04-17 18:04:08 1O3AV5-00071t-U5 malware acl condition: clamd: unable to connect to UNIX socket /tmp/clamd (No such file or directory)
    2010-04-17 18:04:08 1O3AV5-00071t-U5 H=(domein) [IP] F=<> temporarily rejected after DATA
    2010-04-17 18:04:45 1O3AVg-000720-MM malware acl condition: clamd: unable to connect to UNIX socket /tmp/clamd (No such file or directory)
    2010-04-17 18:04:45 1O3AVg-000720-MM H=domein [IP] F=<bounce@leisure-nh.net> temporarily rejected after DATA
    2010-04-17 18:04:46 1O3AVi-000721-2t malware acl condition: clamd: unable to connect to UNIX socket /tmp/clamd (No such file or directory)
    2010-04-17 18:04:46 1O3AVi-000721-2t H=domein [IP] F=<gebruiker@domein.nl> temporarily rejected after DATA
    2010-04-17 18:04:48 1O3AVk-000725-Ck malware acl condition: clamd: unable to connect to UNIX socket /tmp/clamd (No such file or directory)
    2010-04-17 18:04:48 1O3AVk-000725-Ck H=(domein.nl) [IP] F=<gebruiker@domein.nl> temporarily rejected after DATA
    De melding van temporarily rejected after DATA is niet correct natuurlijk en moet volgens wat ik ervan kan vinden te maken hebben met het feit dat CLAMD niet draait (maar dat is wel het geval op dat moment).
    ook de melding clamd: unable to connect to socket is niet correct en waarschijnlijk veroorzaker van het probleem vermoeden wij.

    Als we gaan kijken naar de whereis en which van clamd en de versies van de updates dan krijgen we dit:
    [root@server updatescript]# freshclam
    ClamAV update process started at Sat Apr 17 17:31:36 2010
    main.cld is up to date (version: 52, sigs: 704727, f-level: 44, builder: sven)
    daily.cvd is up to date (version: 10755, sigs: 52428, f-level: 51, builder: guitar)
    bytecode.cvd is up to date (version: 8, sigs: 1, f-level: 51, builder: nervous)
    [root@server updatescript]# whereis clamd
    clamd: /etc/clamd.conf /usr/local/bin/clamd /usr/local/sbin/clamd
    [root@server updatescript]# which clamd
    /usr/local/sbin/clamd
    [root@server updatescript]#
    In de Exim.conf hebben we de volgende items toegevoegd (maar ook stuk voor stuk uitgezet door de #):
    av_scanner = clamd:127.0.0.1 3310
    # primary_hostname =

    acl_smtp_rcpt = check_recipient
    acl_smtp_data = check_message

    deny message = This message contains malformed MIME ($demime_reason)
    demime = *
    condition = ${if >{$demime_errorlevel}{2}{1}{0}}
    deny message = This message contains a virus or other harmful content ($malware_name)
    demime = *
    malware = *
    deny message = This message contains an attachment of a type which we do not accept (.$found_extension)
    demime = bat:comifrf:scr:vbs
    warn message = X-Antivirus-Scanner: Clean mail though you should still use an Antivirus
    Maar wat we ook proberen, het probleem blijft bestaan. er komt geen mail in en er gaat geen mail uit. Heeft iemand een idee wat we nu het beste kunnen doen om de fouten weg te krijgen?

  2. #2
    clamav problemen na update via update script
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Heb je al een killall -9 clamd geprobeerd en daarna alles opnieuw gestart?

  3. #3
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    killall

    zojuist de killall gedaan, en een herstart, maar geen effect. probleem blijft ontstaan.
    Nog andere ideeën?

  4. #4
    clamav problemen na update via update script
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    Het zit toch echt in die hoek. Loop nogmaals je exim config na of je niet nog steeds de verkeerde config gebruikt richting clamav...
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  5. #5
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    clamav

    Ik denk wel dat we het daar moeten zoeken, maar hoe moet ik exim.conf in stellen voor de juiste clamav?
    als ik nogmaals ga kijken naar de which clamd dan krijg ik:/usr/local/bin/clamd
    als ik dan in de clamd.conf kijk zie ik :
    LocalSocket /usr/local/sbin
    en in de exim.conf gebruik ik nu (net aangepast voor de herstart):
    av_scanner = clamd:/usr/local/sbin 3310

    waar haalt hij dan vandaan dat hij clamd op /tmp moet zoeken?

  6. #6
    clamav problemen na update via update script
    geregistreerd gebruiker
    3.709 Berichten
    Ingeschreven
    22/05/05

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    24 Berichten zijn liked


    Naam: Jeroen

    Ik heb zojuist clamav ook even geupdate (niet dat ik < 0.95 draaide ). Ik had precies hetzelfde als jou, wat ik heb gedaan:

    av_scanner = clamd:/tmp/clamd
    vervangen door:
    av_scanner = clamd:127.0.0.1 3310

    service clamd restart
    rm -f /tmp/clamd
    service exim restart

    En toen werkte het weer.

  7. #7
    clamav problemen na update via update script
    geregistreerd gebruiker
    189 Berichten
    Ingeschreven
    30/11/07

    Locatie
    Noordwijk

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    We hebben dit probleem gisteren ook met een aantal debian servers gehad. Bij ons had het te maken met de virus definities. Hij gaf de melding dat de oude virus definities niet meer ondersteund werden en dat clamav geupdate moest worden.

    apt-get update && apt-get install clamav-daemon

    Na dit gedaan te hebben starte clamd weer op werkte alles weer als van ouds.

  8. #8
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    clamd

    Ik ben er van overtuigd dat clamd wel is geupdate, maar er staat ergens dus een foute verwijzing naar /tmp/clamd en dat kan ik niet achterhalen.
    zowel de exim.conf als clamd.conf lijken in orde.

  9. #9
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Heeft iemand een idee hoe ik de clamav scanning uit kan zetten anders?
    Als we dat veranderen in exim.conf en exim herstarten blijft de foutmelding naar boven komen. Kan het nog ergens met dovecot te maken hebben?

  10. #10
    clamav problemen na update via update script
    geregistreerd gebruiker
    40 Berichten
    Ingeschreven
    23/07/09

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Er is enig geschuif geweest met de socket van clamd. Je moet de /tmp/clamd dus wijzigen in wat het nu is geworden. Ik doe een gok en stel voor dat je begint met kijken naar /var/run/clamav/clamd.sock

  11. #11
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Oliver, twee vraagjes dan. Is dat niet de info die ik krijg bij which clamd?
    [root@server updatescript]# which clamd
    /usr/local/sbin/clamd
    En waar zou ik die wijziging door moeten voeren. Ik heb de exim.conf daarop al aangepast en de clamd.conf. Waar kan / moet dat dan nog meer wellicht?

  12. #12
    clamav problemen na update via update script
    geregistreerd gebruiker
    40 Berichten
    Ingeschreven
    23/07/09

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door terrabel Bekijk Berichten
    Oliver, twee vraagjes dan. Is dat niet de info die ik krijg bij which clamd?

    En waar zou ik die wijziging door moeten voeren. Ik heb de exim.conf daarop al aangepast en de clamd.conf. Waar kan / moet dat dan nog meer wellicht?
    Nope, dat is je binary, vergelijk:
    Code:
    $ file /usr/local/sbin/clamd 
    /usr/local/sbin/clamd: ELF 64-bit LSB executable, x86-64, version 1 (...)
    met:
    Code:
    $ file /var/run/clamav/clamd.sock 
    /var/run/clamav/clamd.sock: socket
    Voor exim gebruik je gewoon:
    Code:
    av_scanner = clamd:/var/run/clamav/clamd.sock
    LET OP: Dit is mijn situatie. Je moet natuurlijk zelf controleren waar jouw clamd-socket staat en hoe die precies heet!

  13. #13
    clamav problemen na update via update script
    geregistreerd gebruiker
    320 Berichten
    Ingeschreven
    28/08/08

    Locatie
    België

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0479023909

    hier (debian)

    Code:
    av_scanner = clamd:/var/run/clamav/clamd.ctl

  14. #14
    clamav problemen na update via update script
    geregistreerd gebruiker
    74 Berichten
    Ingeschreven
    20/11/03

    Locatie
    bladel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb even naar alles clamv.* gezocht en krijg dan geen .sock
    /etc/clamd.conf
    /usr/local/updatescript/clamav-0.96/docs/man/clamd.8
    /usr/local/updatescript/clamav-0.96/docs/man/clamd.8.in
    /usr/local/updatescript/clamav-0.96/docs/man/clamd.conf.5
    /usr/local/updatescript/clamav-0.96/docs/man/clamd.conf.5.in
    /usr/local/updatescript/clamav-0.96/win32/res/clamd.rc
    /usr/local/updatescript/clamav-0.96/win32/clamd.vcproj
    /usr/local/updatescript/clamav-0.96/clamd/clamd.c
    /usr/local/updatescript/clamav-0.96/clamd/clamd.o
    /usr/local/updatescript/clamav-0.96/clamd/.deps/clamd.Po
    /usr/local/share/man/man8/clamd.8
    /usr/local/share/man/man5/clamd.conf.5

  15. #15
    clamav problemen na update via update script
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    netstat -anp |grep clamd

    Geen file socket meer, maar wel een over tcp
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

Pagina 1 van de 3 1 2 3 LaatsteLaatste

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics