Een van mijn script geeft continu na een aantal uur de volgende error:
Er staat geen cronjob ingesteld op het betreffende domein, en als ik zelf vaak refresh dan krijg ik de error niet. Pas als ik hem even niet bezoek heb ik de error weer. Ik moet vervolgens de hosts flushen, of mysql opnieuw opstarten.Code:Warning: mysql_connect() [function.mysql-connect]: Host '---ipadres---' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'
Het gaat hier om het maken van verbinding met een andere server:
Direct na het verbinden en het ophalen van de gegevens wordt de connectie meteen weer verbroken door: mysql_close():Code:$remote_dbcn = mysql_connect($remote_conf['db_host'],$remote_conf['db_user'],$remote_conf['db_pass']);
Wat kan het probleem zijn? Het volgende http://developer.spikesource.com/wik...nection_errors
heb ik al gevonden, dit is in elk geval goede uitleg voor iemand die bovenstaand probleem niet snapt. Uiteraard is een oplossing de max connect errors hoger zetten. Liever los ik het anders op.
Wat ik momenteel ook al doe is het volgende:
om de connect heen, echter kan hij wel altijd de database poort bereiken. Ik bouw nu nog even in dat hij een mailtje stuurt zodra de connectie niet gemaakt kan worden, dit bepaald in elk geval het tijdstip dat de connectie niet lukt.Code:if(@fsockopen('---ipadres---', '3306', $errno, $errstr, 5)) { }
Ik hoop dat iemand dit al vaker mee heeft gemaakt en hier een oplossing voor heeft bedacht.
Alvast bedankt.

Likes:


Quote
