Likes Likes:  0
Resultaten 1 tot 7 van de 7
  1. #1
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    21/06/11

    Locatie
    Bredene

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0888.159.318

    Thread Starter

    move_uploaded_file failed to open stream permission denied : beste oplossing ?

    Beste,
    Ik gebruik directadmin op server debian 5.0 / shared webhosting server.

    Wanneer ik wil move_uploaded_file krijg ik "failed to open stream permission denied "
    Op dit opgelost te krijgen moet ik de doelmap op 777 zetten.

    Wat is de oorzaak ?
    Is de goup/user waarin PHP uitvoert <> de directadmin user ?

    Zijn er andere elegantere oplossingen dan de doelmappen voor uploads op 777 te plaatsen ?

    Alvast bedankt voor jullie tips
    Mvg
    Kristof

  2. #2
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    moderator
    4.752 Berichten
    Ingeschreven
    21/02/09

    Locatie
    Noord-Holland

    Post Thanks / Like
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    185 Berichten zijn liked


    Naam: D. Koop
    Bedrijf: Yourwebhoster.eu
    Functie: baas
    URL: yourwebhoster.eu
    KvK nummer: 32165429
    View danielkoop's profile on LinkedIn

    kijk eens naar mod_ruid
    Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  3. #3
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    Hostingvisions
    1.042 Berichten
    Ingeschreven
    18/01/05

    Locatie
    Katwijk

    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    13 Berichten zijn liked


    Bedrijf: Hostingvisions
    Functie: Eigenaar
    Registrar SIDN: Nee
    KvK nummer: 27313947

    Of suPHP. Keuze zat

  4. #4
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    HOSTING - VPS - DEDICATED
    116 Berichten
    Ingeschreven
    03/08/11

    Locatie
    Naaldwijk

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Marc
    Bedrijf: Wijtec
    URL: http://www.wijtec.nl
    Registrar SIDN: nee
    KvK nummer: 27360605
    Ondernemingsnummer: nvt

    Als het goed is zou je die files gewoon in je home dir moeten kunnnen plaatsen (zonder 777) of een andere naam in /tmp. open_basedir wil ook nog wel eens roet in het eten gooien.
    Check ook ff de upload_tmp_dir in php.ini

  5. #5
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Park The Hosting Manager - your friend in hosting software

  6. #6
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    ek-webservices.nl
    17 Berichten
    Ingeschreven
    29/09/10

    Locatie
    Den Haag

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 27259820
    Ondernemingsnummer: nvt

    Bestanden chmod 600 en mappen als chmod 700 ipv 777 zou moeten werken.

  7. #7
    move_uploaded_file failed to open stream permission denied : beste oplossing ?
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Ja, maar daarmee verhelp je alleen de kwaal en maak je het werkelijke probleem alleen maar groter.
    Namelijk, te veel rechten.

    Iedereen op het systeem kan nu de bestanden lezen overschrijven, dit wil je echt niet!
    Iedere website op het systeem mag nu de bestanden aanpassen en kwaadaardige code invoeren.

    En, wat ik nog niet eerder heb gehoord.
    Je hoeft maar één lekke applicatie te hebben, bijvoorbeeld de mailserver of iets en de hacker kan je website aanpassen.
    Je heeft geeft immers iedere gebruiker toegang om alles te doen.

    Het eerste artikel http://www.pfz.nl/wiki/apache-veilig...iker-uitvoeren
    Beschrijft verschillende maatregelen die je kan nemen.

    Een artikel dat ik nog was vergeten te melden, http://www.pfz.nl/wiki/safe-mode/
    Met de nodige achtergrondinformatie over dit probleem.
    Park The Hosting Manager - your friend in hosting software

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics