Likes Likes:  0
Resultaten 1 tot 9 van de 9
Geen
  1. #1
    htaccess laat <?= door
    geregistreerd gebruiker
    1.352 Berichten
    Ingeschreven
    15/05/07

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    47 Berichten zijn liked


    Bedrijf: YolkNet Internetservices
    Functie: CEO
    URL: www.yolknet.nl
    Registrar SIDN: nee
    KvK nummer: 27281066
    Ondernemingsnummer: nvt

    Thread Starter

    htaccess laat <?= door

    Als een bezoeker surft naar http://www.domein.nl/%3C?= (of http://www.domein.nl/<?=) dan zou er een error-pagina moeten verschijnen. In plaats daarvan wordt eerst index.php geladen en wordt de bezoeker vanaf daar doorgestuurd naar de error-pagina. Dit levert een "302 redirect" op en dat is voor de ranking in Google niet wenselijk.
    Hoe kan het dat de code wordt uitgevoerd op index.php en niet meteen een error-pagina verschijnt? Het adres voldoet toch niet aan de laatste ReWriteRule "RewriteRule ^([a-z0-9-]+)/?$ index.php?pid1=$1 [L]"?

    Code:
    RewriteEngine on
    
    #	De basis van alle links
    RewriteBase /
    
    #	Stuur bezoekers van de oude pagina's door naar de juiste nieuwe pagina's
    Redirect 301 /tips.html http://www.domein.nl/tips
    Redirect 301 /locatie.html http://www.domein.nl/welke-omgeving
    Redirect 301 /bedrijf.html http://www.domein.nl/leuke-activiteiten
    Redirect 301 /theater.html http://www.domein.nl/benodigdheden/entertainment
    Redirect 301 /contact.html http://www.domein.nl/contact
    Redirect 301 /sitemap.html http://www.domein.nl/sitemap
    
    #	De naam van de standaardpagina
    DirectoryIndex index.php
    
    #	Zorg dat er altijd 'www.' voor het internetadres komt
    RewriteCond %{HTTP_HOST} ^domein\.nl [NC]
    RewriteRule ^(.*)$ http://www.domein.nl/$1 [L,R=301]
    
    #	De error-pagina's
    ErrorDocument 404 http://www.domein.nl/error/404.html
    ErrorDocument 401 http://www.domein.nl/error/401.html
    ErrorDocument 403 http://www.domein.nl/error/403.html
    
    #	Niet in elke directory een indexbestand zetten om zogenaamde "open dirs" te vermijden
    #	Bezoekers krijgen een 403-melding (toegang verboden), de pagina die hierboven bij "Foutmeldingen" staat
    Options All -Indexes
    
    #	Herschrijf een adres niet als het bestand (file) of map (directory) op de server bestaat
    RewriteCond %{REQUEST_FILENAME} -d [OR]
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule .? - [L]
    
    #	Herschrijf de pagina's
    #	Een vraagteken geeft aan dat het voorafgaande teken 0 of 1 keer mag voorkomen (dus wel of geen slash worden beiden geaccepteerd)
    RewriteRule ^sitemap.html$ index.php?pid1=sitemap [L]
    RewriteRule ^sitemap.xml$ sitemap.php [L]
    RewriteRule ^sitemap/?$ index.php?pid1=sitemap [L]
    
    RewriteRule ^([a-z0-9-]+)/([a-z0-9-]+)/([a-z0-9-]+)/([a-z0-9-]+)/?$ index.php?pid1=$1&pid2=$2&pid3=$3&pid4=$4 [L]
    RewriteRule ^([a-z0-9-]+)/([a-z0-9-]+)/([a-z0-9-]+)/?$ index.php?pid1=$1&pid2=$2&pid3=$3 [L]
    RewriteRule ^([a-z0-9-]+)/([a-z0-9-]+.*)/?$ index.php?pid1=$1&pid2=$2 [L]
    RewriteRule ^([a-z0-9-]+)/?$ index.php?pid1=$1 [L]
    YolkNet Internetservices - www.yolknet.nl

  2. #2
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    158 Berichten
    Ingeschreven
    29/12/09

    Locatie
    limburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0832998782

    Het adres voldoet toch niet aan de laatste ReWriteRule "RewriteRule ^([a-z0-9-]+)/?$ index.php?pid1=$1 [L]"?
    het voldoet inderdaad *NIET* dus is er geen standaardregel waarnaar geluisterd moet worden, dus gaat hij defaulten op de index tonen.
    je zou een rewriterule moeten zetten die net *WEL* matcht en laten redirecten naar de errorpagina.

    de regels zijn net: als er geen match is, default actie gebruiken (index.html of .php of ... tonen),
    als er wel een match is: regel uitvoeren

  3. #3
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    1.352 Berichten
    Ingeschreven
    15/05/07

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    47 Berichten zijn liked


    Bedrijf: YolkNet Internetservices
    Functie: CEO
    URL: www.yolknet.nl
    Registrar SIDN: nee
    KvK nummer: 27281066
    Ondernemingsnummer: nvt

    Thread Starter
    Dus dan zou ik deze regels moeten toevoegen bedoel je?

    Redirect 301 ^/%3C?=$ http://www.domein.nl/error/404.html [L]
    Redirect 301 ^/<?=$ http://www.domein.nl/error/404.html [L]
    YolkNet Internetservices - www.yolknet.nl

  4. #4
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    4.175 Berichten
    Ingeschreven
    09/12/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    76 Berichten zijn liked


    Naam: Ramon Fincken
    Bedrijf: Klarned Managed Hosting / Halvar.io
    Functie: CEO
    URL: www.klarned.is
    Registrar SIDN: Nee
    KvK nummer: 30262182
    TrustCloud: ramonfincken
    View ramonfincken's profile on LinkedIn

    iig niet met een 301 maar met een 404 of 403 of een andere 50x code. Want je verbied of denied iets. Niet dat je zegt " hey deze pagina staat nu hier ( 301 of 302 )
    my 2 cents
    Klarned Managed hosting Hosting, optimalisatie & debugging door WP Core developers

  5. #5
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    158 Berichten
    Ingeschreven
    29/12/09

    Locatie
    limburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0832998782

    idd zoals Ramon zegt, je wil niet zeggen 'die pagina staat niet hier, maar hier', dus geen redirect codes.
    als je het, zoals je hierboven zegt, naar je 404 wil sturen, gewoon een rewriterule voor maken ipv een redirect rule.

    je moet wat hebben ala RewriteRule ^<?=$ http://www.domein.nl/error/404.html [L] (merk op dat dit dus geen werkend voorbeeld is)

    overigens: waarom zou het niet gewoon in je index.php mogen behandeld worden?

  6. #6
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    1.352 Berichten
    Ingeschreven
    15/05/07

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    47 Berichten zijn liked


    Bedrijf: YolkNet Internetservices
    Functie: CEO
    URL: www.yolknet.nl
    Registrar SIDN: nee
    KvK nummer: 27281066
    Ondernemingsnummer: nvt

    Thread Starter
    Een tooltje van de opdrachtgever heeft "ontdekt" dat er een 302 redirect zit op de url http://www.vrijgezellen-feesten.nl/%3C?=
    Dus ik moet het script nalopen waar dit adres wordt genoemd (het is <?=, dus iets verkeerds in de php-code), maar ik denk dat het ook verstandig is om tot die tijd in de htaccess een regel over op te nemen. Ik weet alleen niet op wat voor manier. De pagina bestaat niet
    YolkNet Internetservices - www.yolknet.nl

  7. #7
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    4.175 Berichten
    Ingeschreven
    09/12/05

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    76 Berichten zijn liked


    Naam: Ramon Fincken
    Bedrijf: Klarned Managed Hosting / Halvar.io
    Functie: CEO
    URL: www.klarned.is
    Registrar SIDN: Nee
    KvK nummer: 30262182
    TrustCloud: ramonfincken
    View ramonfincken's profile on LinkedIn

    Waarom wil je dit afvangen trouwens?

    Bang voor GET request injection? Zoja, dan moet je dat in je script afvangen en mogelijk in je firewall, maar niet in je htaccess.
    Klarned Managed hosting Hosting, optimalisatie & debugging door WP Core developers

  8. #8
    htaccess laat &lt;?= door
    HOSTING - VPS - DEDICATED
    116 Berichten
    Ingeschreven
    03/08/11

    Locatie
    Naaldwijk

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Marc
    Bedrijf: Wijtec
    URL: http://www.wijtec.nl
    Registrar SIDN: nee
    KvK nummer: 27360605
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door dinges2007 Bekijk Berichten
    Dus dan zou ik deze regels moeten toevoegen bedoel je?

    Redirect 301 ^/%3C?=$ http://www.domein.nl/error/404.html [L]
    Redirect 301 ^/<?=$ http://www.domein.nl/error/404.html [L]
    Zou je 404 van moeten maken, en waarom matchen op iets, neem aan als iets op de laatste regel komt dit allemaal errors zijn?
    anders gaat het tooltje zeggen dat >?= ook niet goed werkt ed

  9. #9
    htaccess laat &lt;?= door
    geregistreerd gebruiker
    1.352 Berichten
    Ingeschreven
    15/05/07

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    47 Berichten zijn liked


    Bedrijf: YolkNet Internetservices
    Functie: CEO
    URL: www.yolknet.nl
    Registrar SIDN: nee
    KvK nummer: 27281066
    Ondernemingsnummer: nvt

    Thread Starter
    We zijn 7 weken verder Wijtec en het probleem is inmiddels opgelost
    YolkNet Internetservices - www.yolknet.nl

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics