Thanks!
Thanks!
Kan het aan mij liggen dat de modus met MaxRequestsPerChild op 1 niet werkt?
Het lijkt alsof de child niet afsluit na 1 request en dat daardoor de 2e request via de child faalt omdat cap_set faalt.
Iemand hier ervaring mee?

Hmmm, dat is ergens lang geleden stuk gegaan (in versie 0.9.1 om precies te zijn) en je bent de eerste die het mist. Ligt dus niet aan jou ;-)
Mod_ruid2 dropte de rechten net ff wat te vroeg en dat zou in deze revisie opgelost moeten zijn http://mod-ruid.svn.sourceforge.net/....c?revision=41 en uiteraard komt deze fix ook in de toekomstige 0.9.8 versie, alleen laat die nog even op zich wachten. Ik ben bezig om ook userdir support op orde te krijgen in mod_ruid2. Maar dat is voor nu nog even work in progress.
Veel plezier er mee...
[Tue May 29 22:17:54 2012] [error] mod_ruid2 CRITICAL ERROR ruid_setup:cap_set_proc failed
[Tue May 29 22:17:54 2012] [error] mod_ruid2 CRITICAL ERROR ruid_uiiii>ruid_set_perm:cap_set_proc failed before setuid
[Tue May 29 22:17:55 2012] [error] mod_ruid2 CRITICAL ERROR ruid_uiiii>ruid_set_perm:cap_set_proc failed before setuid
Lijkt het probleem niet opgelost te hebben helaas
Groet,
Tim

In dat geval zal je meer moeten vertellen over wanneer deze fout in je logs komt. Aard van de request en eventueel van toepassing zijnde rewites, gebruikte config ed. Welke versie meld mod_ruid2 trouwens in de error_log?
Ik kan de fout met rev 41 nl. niet meer reproduceren en tast dus op dit moment even in het duister over de oorzaak.
Laatst gewijzigd door mind; 29/05/12 om 23:34.
[Tue May 29 22:16:57 2012] [notice] mod_ruid2/0.9.8b1 enabled
Ik heb het gevoel alsof de child na de eerste (en wat tevens de laatste) request zou moeten zijn niet afsluit, maar nog een request afhandeld. Aangezien hij zijn capabilities dan gedropt heeft lukt dat niet meer. Tis een relatief oude installatie met een oude plesk waar dit als quickfix even tussen moet draaien.
Als je traces, dumps, wat dan ook nodig hebt kan ik die wel aanleveren.
Alvast bedankt voor de input
Er valt me nog even iets in. In een oude handleiding staat nog dit om in de httpd.conf te zetten:
Maar in nieuwere vhost templates staat als group "access", die door DA tegenwoordig gebruikt wordt.Code:RUidGid apache apache
Moet dan in de httpd.conf dit niet gewijzigd worden in:<IfModule mod_ruid2.c>
RMode config
RUidGid |USER| |GROUP|
RGroups apache access
</IfModule>
Is er trouwens een mogelijkheid om te testen of mod_ruid goed werkt? Laatst bij een SMF forum moest ik perse de Settings.php op 777 zetten terwijl dat normaal toch niet meer zou moeten hoeven, toch?Code:RUidGid apache access
Ben niet zo thuis in programmeren, maar ik zie hier ook "Ifmodule mod_ruid2.c", maar in httpd.conf staat mod_ruid2.so klopt dat dan wel?
Laatst gewijzigd door Blacky; 31/05/12 om 03:23.
.c klopt:
Zelf test ik altijd even met exec('whoami') wat er gebeurd. Kan je natuurlijk even uit de disabled_functions halen.The module name argument is the file name of the module, at the time it was compiled. For example, mod_rewrite.c.
Als test of het allemaal goed werkt kan je ook een test.php maken met iets als
En dan kijken of hij data.txt heeft aangemaakt & welke eigenaar hij heeft.PHP Code:<?php
$fp = fopen('data.txt', 'w');
fwrite($fp, '1');
fwrite($fp, '23');
fclose($fp);
// the content of 'data.txt' is now 123 and not 23!
?>

Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs
Lees hier de webhostingtalk.nl forum regels en voorwaarden!
Wel netjes afsluiten met ?> uiteraard![]()

Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs
Lees hier de webhostingtalk.nl forum regels en voorwaarden!
Is dat niet meer? Ah kijk, was me nog niet bekend. Netter lijkt het me wel inderdaad.Een beetje oftopic, maar die ?> is geheel niet nodig aan het einde van het bestand
Bedankt voor de reply's. De test werkt, dus toch in orde.![]()
Heeft te maken met: http://www.directadmin.com/features.php?id=961