Likes Likes:  0
Resultaten 1 tot 3 van de 3
Geen
  1. #1
    [php] Operation not permitted
    Custom User Title
    524 Berichten
    Ingeschreven
    27/09/06

    Locatie
    Ede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: Ja
    Ondernemingsnummer: nvt

    Thread Starter

    [php] Operation not permitted

    ey,

    Ik heb een scriptje in /var/www/. De directory /home/username/ bestaat al. Toch blijf ik maffe errors krijgen:

    Code:
    <?php
    chown('/home/'.$args['username'].'/','root'); // Geeft: 'Operation not permitted 
    chown('/home/'.$args['username'],'root'); // Geeft: 'Operation not permitted 
    mkdir('/home/'.$args['username'].'/public_html',0600); // Geeft: permission denied 
    mkdir('/home/'.$args['username'].'/public_html/',0600); // Geeft: Operation not permitted 
    mkdir('/home/'.$args['username'].'/public_html',0777); // geeft: 'permission denied 
    ?>
    Het script draait als root, en ik snap er helemaal niets meer van...

    iemand enig idee hoe ik een dir kan aanmaken in in /home/username/ ?

  2. #2
    [php] Operation not permitted
    aktieve deelnemer
    2.782 Berichten
    Ingeschreven
    10/05/02

    Locatie
    Noordwest Holland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 37093085
    Ondernemingsnummer: nvt

    Safe mode staat aan / uit?
    Wat geeft:
    PHP Code:
    echo posix_getuid(); 

  3. #3
    [php] Operation not permitted
    Custom User Title
    524 Berichten
    Ingeschreven
    27/09/06

    Locatie
    Ede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: Ja
    Ondernemingsnummer: nvt

    Thread Starter
    Safe mode staat uit. Er zijn geen openbasedir restricties. En het script draait als root.

    Het blijkt dus dat php het nodig vind dat de user expliciete schrijfrechten nodig heeft. Waardoor het pas werkte toen ik die map (/home/username/) chmodde met 777.

    /bin/mkdir is kennelijk duidelijk slimmer dan dat. Want die had door dat root het probeerde, en die negeerde gewoon de user/schrijfrechten, en deed het zonder verder problemen.

    Problem solved dus.

    Het blijkt dus dat php het nodig vind dat de user expliciete schrijfrechten nodig heeft. Waardoor het pas werkte toen ik die map (/home/username/) chmodde met 777.

    /bin/mkdir is kennelijk slimmer dan dat. Want die had door dat root het probeerde, en die negeerde gewoon de user/schrijfrechten, en deed het zonder verder problemen.

    Problem solved dus.
    Laatst gewijzigd door Freakingme; 17/06/07 om 18:17. Reden: Automerged Dubbelpost

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics