Likes Likes:  0
Resultaten 1 tot 4 van de 4
Geen

Onderwerp: PMM troubles

  1. #1
    PMM troubles
    master of disaster
    19 Berichten
    Ingeschreven
    11/02/04

    Locatie
    Wageningen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24360180
    Ondernemingsnummer: nvt

    Thread Starter

    PMM troubles

    Wij hebben het volgende probleem met twee Plesk servers.

    A: FreeBSD met Plesk 7.1

    B: Debian Linux met Plesk 8.0.1 (clean & fresh installatie)

    Het draaien van PMM om alle data van A naar B te krijgen geeft de volgende error:

    rror during dump retrieval

    Error during dump file retrieving.
    Remote agent failed with the following stderr messages: 10:35:05 INFO FileFinder: tar resolved to /usr/bin/tar
    10:35:05 INFO New connection: mysql shell connection. db psa, user admin, host localhost
    10:35:05 TRACE SQL: SELECT ip_address, type FROM IP_Addresses
    10:35:05 TRACE SQL: SELECT c.login, p.ip_address FROM clients c LEFT JOIN Repository r ON c.pool_id = r.rep_id LEFT JOIN IP_Addresses p ON r.component_id = p.id
    10:35:05 TRACE SQL: SELECT d.displayName, p.ip_address FROM domains d, IP_Addresses p, hosting h WHERE p.id = h.ip_address_id AND h.dom_id = d.id
    10:35:05 TRACE SQL: SELECT d.displayName, p.ip_address FROM domains d, IP_Addresses p, forwarding f WHERE p.id = f.ip_address_id AND f.dom_id = d.id
    10:35:05 TRACE SQL: SELECT displayName FROM domains WHERE htype = 'none'
    ERROR 1267 (HY000) at line 1: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='
    10:35:05 TRACE SQL: SELECT d.displayName, c.login FROM clients c LEFT JOIN domains d ON d.cl_id = c.id
    10:35:05 INFO ------------------------------------------------------------
    10:35:05 INFO FILE storage initialized.
    10:35:05 INFO Base directory: /usr/local/psa/migration/supervisor.14236/
    10:35:05 INFO Gzip bundles: yes
    10:35:05 INFO Bundle split size: 2147483647
    10:35:05 INFO ------------------------------------------------------------
    10:35:05 TRACE SQL: SELECT * FROM clients WHERE login = 'xyzklant'
    ERROR 1267 (HY000) at line 1: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='
    Can't use an undefined value as a HASH reference at /usr/local/psa/migration/supervisor.14236/PleskX.pl line 597.
    Deze error kun je terugvinden op mysql.org e.d. en verwijst naar een check van "show variables". Dit heb ik gedaan en ziet er goed uit (alles latin1 behalve system).

    Iemand een idee?

    PS. Topic ook geopenend op het SWSoft forum, http://forum.swsoft.com/showthread.p...threadid=34643

  2. #2
    PMM troubles
    Security is the way
    666 Berichten
    Ingeschreven
    09/03/05

    Locatie
    /home/Unixboy

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ?
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    zet dit in je my.cnf

    [mysqld]
    default-character-set=utf8

  3. #3
    PMM troubles
    master of disaster
    19 Berichten
    Ingeschreven
    11/02/04

    Locatie
    Wageningen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24360180
    Ondernemingsnummer: nvt

    Thread Starter
    Die had ik al eens geprobeerd, zowel voor de client als de serverconfig.

    Helaas exact dezelfde error!

  4. #4
    PMM troubles
    geregistreerd gebruiker
    49 Berichten
    Ingeschreven
    31/01/04

    Locatie
    Belgium

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: BE0861.130.267

    Een beetje laat, maar beter laat dan nooit!

    Maak op de oude server een dump van de psa-database, zoek & vervang "latin1" door "utf8" en doe vervolgens een restore van het nieuwe sql bestand.

    Niet ideaal, maar het werkte wel bij mij.

    Vriendelijke groeten,
    Bart
    Laatst gewijzigd door bdc; 30/08/06 om 02:02.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics