Likes Likes:  0
Resultaten 1 tot 6 van de 6
Geen
  1. #1
    Error bij Domein restore in Plesk 8.1
    geregistreerd gebruiker
    282 Berichten
    Ingeschreven
    30/04/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 17160052
    Ondernemingsnummer: nvt

    Thread Starter

    Error bij Domein restore in Plesk 8.1

    Hallo,

    Wanneer een domain-owner een domein wil restoren in Plesk 8.1.1 , krijgt hij de volgende melding :

    Code:
    Traceback (most recent call last):
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 115, in doActivityRunner
    newState = self.doActivity()
    File "/usr/local/psa/admin/share/supervisor/processor.py", line 792, in doActivity
    cmd.spawn(os.environ.has_key("PLESKRESTORE_MODE"))
    File "/usr/local/psa/admin/lib/python/subproc.py", line 238, in spawn
    proc.run()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 193, in run
    BaseSubprocess.run(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 177, in run
    self.wait()
    File "/usr/local/psa/admin/lib/python/subproc.py", line 197, in wait
    BaseSubprocess.wait(self)
    File "/usr/local/psa/admin/lib/python/subproc.py", line 187, in wait
    raise NonzeroExitException(self, os.WEXITSTATUS(status))
    NonzeroExitException: was finished with exit code 1
    Als admin gaat het wel goed.

    Wat kan hier mis zijn ?

  2. #2
    Error bij Domein restore in Plesk 8.1
    Meneer de Directeur
    12.253 Berichten
    Ingeschreven
    11/05/04

    Locatie
    Valkenswaard / Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 17186890

    Is de backup gemaakt op dezelfde server als waar de restore plaatsvind?

  3. #3
    Error bij Domein restore in Plesk 8.1
    geregistreerd gebruiker
    282 Berichten
    Ingeschreven
    30/04/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 17160052
    Ondernemingsnummer: nvt

    Thread Starter
    Ja,

    Eerst niet (server is van 7.5.4 naar 8.1.1 gegaan), maar om alles te kunnen testen en uitsluiten gaat het nu om een backup die ik 5 minuten eerder maak op dezelfde server.

    Dus de vraag is DENK ik : wat veroorzaakt die NonZeroExitException.

  4. #4
    Error bij Domein restore in Plesk 8.1
    geregistreerd gebruiker
    961 Berichten
    Ingeschreven
    02/05/04

    Locatie
    Montreal, Canada

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: nvt
    Ondernemingsnummer: 873411853

    Kijk of:

    /var/lib/psa/dumps

    psaadm (user) en psaadm (group) als eigenaar heeft.

    Error is nietzeggend, maar dit hielp ooit toen we dergelijk probleem hadden.

    EDIT: meer info vind je hier: http://forum.swsoft.com/showthread.p...5&pagenumber=1

  5. #5
    Error bij Domein restore in Plesk 8.1
    Meneer de Directeur
    12.253 Berichten
    Ingeschreven
    11/05/04

    Locatie
    Valkenswaard / Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 17186890

    Probeer het eens commandline te doen?

  6. #6
    Error bij Domein restore in Plesk 8.1
    geregistreerd gebruiker
    282 Berichten
    Ingeschreven
    30/04/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 17160052
    Ondernemingsnummer: nvt

    Thread Starter
    Ok ik heb hier een uitreksel uit de restore-log ... Het heeft te maken met het feit dat hij de socket op moment x wel vind .. maar daarna niet meer. Echter, ik kan er nog niet veel wijs uit .. iemand tip ?

    Code:
    2007-06-07 16:49:02,709 INFO Packet succesfully validated.
    2007-06-07 16:49:02,720 INFO Executing <subprocess[16006] '/usr/local/psa/admin/sbin/deployer' '--session-path=/srv/backup/psa/tmp/restore_1_4' '--deploy-dump' '--backup-user=xxxxxx.nl' '--backup-user-type=domain-admin' '--socket-path=/usr/local/psa/tmp/backup-extractor.15997'>
    2007-06-07 16:49:03,000 INFO Incoming packet:
    <?xml version='1.0' encoding='UTF-8'?>
    <action>
      <get-status/>
    </action>
    
    2007-06-07 16:49:03,000 INFO Packet succesfully validated.
    2007-06-07 16:49:03,002 INFO Outgoing packet:
    <?xml version="1.0" encoding="UTF-8"?><action-response action-internal-name="RestoreDeploymentState">
        <working>
            <starting></starting>
        </working>
    </action-response>
    
    2007-06-07 16:49:03,002 INFO Packet succesfully validated.
    2007-06-07 16:49:07,049 INFO Subprocess <subprocess[16006] '/usr/local/psa/admin/sbin/deployer' '--session-path=/srv/backup/psa/tmp/restore_1_4' '--deploy-dump' '--backup-user=xxxxxx.nl' '--backup-user-type=domain-admin' '--socket-path=/usr/local/psa/tmp/backup-extractor.15997'> was finished with exit code 1
    == STDOUT ====================
    
    == STDERR ====================
    Uncaught std::exception: UnixClientSocket::UnixClientSocket, connect: No such file or directory
    
    2007-06-07 16:49:13,439 INFO Incoming packet:
    <?xml version='1.0' encoding='UTF-8'?>
    <action>
      <get-status/>
    </action>
    
    2007-06-07 16:49:13,439 INFO Packet succesfully validated.
    2007-06-07 16:49:13,440 INFO Outgoing packet:
    <?xml version="1.0" encoding="UTF-8"?><action-response action-internal-name="FinishedState">
        <finished status="error">
            <message code="Error in RestoreDeploymentState.doActivity()">
                <context></context>
                <file></file>
                <line></line>
                <text>Traceback (most recent call last):
      File &quot;/usr/local/psa/admin/share/supervisor/processor.py&quot;, line 115, in doActivityRunner
        newState = self.doActivity()
      File &quot;/usr/local/psa/admin/share/supervisor/processor.py&quot;, line 792, in doActivity
        cmd.spawn(os.environ.has_key(&quot;PLESKRESTORE_MODE&quot;))
      File &quot;/usr/local/psa/admin/lib/python/subproc.py&quot;, line 238, in spawn
        proc.run()
      File &quot;/usr/local/psa/admin/lib/python/subproc.py&quot;, line 193, in run
        BaseSubprocess.run(self)
      File &quot;/usr/local/psa/admin/lib/python/subproc.py&quot;, line 177, in run
        self.wait()
      File &quot;/usr/local/psa/admin/lib/python/subproc.py&quot;, line 197, in wait
        BaseSubprocess.wait(self)
      File &quot;/usr/local/psa/admin/lib/python/subproc.py&quot;, line 187, in wait
        raise NonzeroExitException(self, os.WEXITSTATUS(status))
    NonzeroExitException:  was finished with exit code 1
    </text>
            </message>
        </finished>
    </action-response>

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics