Likes Likes:  0
Resultaten 1 tot 15 van de 17
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen
  1. #1
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Server instellingen voor CDOSYS

    Hallo,

    Heeft iemand hier ervaring met mail versturen via een ASP-script met de
    server component (?) CDOSYS? Op
    http://www.powerasp.com/content/new/...ail_cdosys.asp staan drie
    methodes maar geen enkele variant wil een mailtje bij mij of iemand van het
    domein waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis gaat
    omdat er op de server in IIS iets moet worden ingesteld maar ik weet niet
    wat en de hostingpartij (AS Hosting) beweert dat alles goed staat ingesteld.
    Ik denk dat ze er gewoon geen verstand van hebben maar ja, dat heb ik ook
    niet dus ik kan het niet bewijzen.

    Alvast bedankt,
    Sabine




  2. #2
    Daniel Tryba
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    Sabine <werk@ditweghalensabine.nl> wrote:
    > geen enkele variant wil een mailtje bij mij of iemand van het domein
    > waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis gaat
    > omdat er op de server in IIS iets moet worden ingesteld maar ik weet
    > niet wat en de hostingpartij (AS Hosting) beweert dat alles goed staat
    > ingesteld. Ik denk dat ze er gewoon geen verstand van hebben maar ja,
    > dat heb ik ook niet dus ik kan het niet bewijzen.


    Je impliceerd dat het wel werkt naar niet locale gebruikers, als er dus
    een probleem is zit dat in jou smtp daemon (zeker als methode 3 niet
    functioneerd). Aan de hand van logs zou je kunnen achterhalen wat het
    probleem zou kunnen zijn... moet je natuurlijk aan bij de logs kunnen
    komen.

    BTW een tip: als je niets van smtp begrijpt, begin er niet zelf mee te
    rotzooien. Foutief geconfigde smtpdaemons leiden tot spam.


  3. #3
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    "Daniel Tryba" <partmapsswen@invalid.tryba.nl> wrote in message
    news:42b8281c$0$31314$c5fe704e@news6.xs4all.nl...
    > Sabine <werk@ditweghalensabine.nl> wrote:
    >> geen enkele variant wil een mailtje bij mij of iemand van het domein
    >> waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis gaat
    >> omdat er op de server in IIS iets moet worden ingesteld maar ik weet
    >> niet wat en de hostingpartij (AS Hosting) beweert dat alles goed staat
    >> ingesteld. Ik denk dat ze er gewoon geen verstand van hebben maar ja,
    >> dat heb ik ook niet dus ik kan het niet bewijzen.

    >
    > Je impliceerd dat het wel werkt naar niet locale gebruikers, als er dus
    > een probleem is zit dat in jou smtp daemon (zeker als methode 3 niet
    > functioneerd). Aan de hand van logs zou je kunnen achterhalen wat het
    > probleem zou kunnen zijn... moet je natuurlijk aan bij de logs kunnen
    > komen.


    Nee, het werkt helemaal niet, ook niet naar locale gebruikers, geen enkele
    mail komt aan.

    > BTW een tip: als je niets van smtp begrijpt, begin er niet zelf mee te
    > rotzooien. Foutief geconfigde smtpdaemons leiden tot spam.


    Voor de duidelijkheid: het is voor een website met een simpel
    Windows-hosting-account waar ik alleen naar kan ftp-en en verder niks. Ik
    weet niet heel veel van SMTP maar volgens mij kan ik ook helemaal niks er
    aan rotzooien met zo'n account.
    Ik zou alleen graag willen weten welke vragen ik die hosting jongens kan
    stellen om te verifieren of alles inderdaad goed staat ingesteld. Er treden
    namelijk vrijwel geen errors op met de geteste scripts waaruit ik afleid dat
    het niet aan het script ligt maar misschien is die aanname fout.

    Tnx,
    Sabine



  4. #4
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    "Daniel Tryba" <partmapsswen@invalid.tryba.nl> wrote in message
    news:42b8281c$0$31314$c5fe704e@news6.xs4all.nl...
    > Sabine <werk@ditweghalensabine.nl> wrote:


    -- snip --
    > Aan de hand van logs zou je kunnen achterhalen wat het
    > probleem zou kunnen zijn... moet je natuurlijk aan bij de logs kunnen
    > komen.


    Kan ik dus niet bij en ik heb die hosters ook al gevraagd of ze ze wilden
    bekijken voor me maar daar werd niet op gereageerd...



  5. #5
    Jan Reilink
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    Sabine wrote:
    > "Daniel Tryba" <partmapsswen@invalid.tryba.nl> wrote in message
    > news:42b8281c$0$31314$c5fe704e@news6.xs4all.nl...
    >
    >>Sabine <werk@ditweghalensabine.nl> wrote:
    >>
    >>>geen enkele variant wil een mailtje bij mij of iemand van het domein
    >>>waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis gaat
    >>>omdat er op de server in IIS iets moet worden ingesteld maar ik weet
    >>>niet wat en de hostingpartij (AS Hosting) beweert dat alles goed staat
    >>>ingesteld. Ik denk dat ze er gewoon geen verstand van hebben maar ja,
    >>>dat heb ik ook niet dus ik kan het niet bewijzen.

    >>
    >>Je impliceerd dat het wel werkt naar niet locale gebruikers, als er dus
    >>een probleem is zit dat in jou smtp daemon (zeker als methode 3 niet
    >>functioneerd). Aan de hand van logs zou je kunnen achterhalen wat het
    >>probleem zou kunnen zijn... moet je natuurlijk aan bij de logs kunnen
    >>komen.

    >
    >
    > Nee, het werkt helemaal niet, ook niet naar locale gebruikers, geen enkele
    > mail komt aan.
    >


    Begin eens met een simpel (ASP) scriptje, dat een mail stuurt. De 3
    waardes zijn:
    from -> jouw emailadres
    to -> jouw emailadres, of ander emailadres. In ieder geval iets dat je
    kan ontvangen
    body -> bijv. alleen "test"

    Gaat dit wel goed?
    Werkt een CDONTS (de "voorganger" van CDOSYS om het zo maar te noemen)
    script wel?

    >>BTW een tip: als je niets van smtp begrijpt, begin er niet zelf mee te
    >>rotzooien. Foutief geconfigde smtpdaemons leiden tot spam.

    >
    >
    > Voor de duidelijkheid: het is voor een website met een simpel
    > Windows-hosting-account waar ik alleen naar kan ftp-en en verder niks. Ik
    > weet niet heel veel van SMTP maar volgens mij kan ik ook helemaal niks er
    > aan rotzooien met zo'n account.
    > Ik zou alleen graag willen weten welke vragen ik die hosting jongens kan
    > stellen om te verifieren of alles inderdaad goed staat ingesteld. Er treden
    > namelijk vrijwel geen errors op met de geteste scripts waaruit ik afleid dat
    > het niet aan het script ligt maar misschien is die aanname fout.
    >


    "vrijwel geen errors" != "geen errors". Wat zijn de errors?

    Zie voor meer (technische) informatie over CDOSYS:
    http://msdn.microsoft.com/library/de...col/cdosys.asp

    --
    Met vriendelijke groet / Best regards,
    Jan Reilink, VEVIDA Nederland BV

    Postbus 329, 9700 AH GRONINGEN, +31(0)50 - 5492234

  6. #6
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    "Jan Reilink" <janreilink@vevida.nl> wrote in message
    news:42b87d66$0$21225$e4fe514c@dreader27.news.xs4a ll.nl...
    > Begin eens met een simpel (ASP) scriptje, dat een mail stuurt. De 3
    > waardes zijn:
    > from -> jouw emailadres
    > to -> jouw emailadres, of ander emailadres. In ieder geval iets dat je kan
    > ontvangen
    > body -> bijv. alleen "test"
    > Gaat dit wel goed?


    Zo ben ik inderdaad begonnen en toen dat niet werkte heb ik de helpdesk
    gecontacteerd.

    > Werkt een CDONTS (de "voorganger" van CDOSYS om het zo maar te noemen)
    > script wel?


    Nee dus, daar begon ik mee want zo'n script had ik nog liggen maar de
    helpdesk meldde me dat ik CDOSYS moest gebruiken.

    >> Er treden namelijk vrijwel geen errors op met de geteste scripts waaruit
    >> ik afleid dat het niet aan het script ligt maar misschien is die aanname
    >> fout.
    >>

    >
    > "vrijwel geen errors" != "geen errors". Wat zijn de errors?


    Ja, nee, ik heb inmiddels zoveel geprobeerd dat ik niet meer precies weet
    wanneer welke fout optrad. Niet alle van de drie opties kreeg ik error-vrij
    maar in de meeste gevallen had het te maken had met typfoutjes van mij. Er
    waren dus verschillende varianten die wel error-vrij waren, dat probeerde ik
    een beeetje te kort door de bocht duidelijk te maken.

    > Zie voor meer (technische) informatie over CDOSYS:
    > http://msdn.microsoft.com/library/de...col/cdosys.asp


    Dank voor deze link! Ik ga de info eens bestuderen en hopelijk heb ik dan
    een paar argumenten tegen de helpdesk.

    Tnx,
    Sabine



  7. #7
    sturkie
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    > Heeft iemand hier ervaring met mail versturen via een ASP-script met de
    > server component (?) CDOSYS? Op
    > http://www.powerasp.com/content/new/...ail_cdosys.asp staan drie
    > methodes maar geen enkele variant wil een mailtje bij mij of iemand van
    > het domein waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis
    > gaat omdat er op de server in IIS iets moet worden ingesteld maar ik weet
    > niet wat en de hostingpartij (AS Hosting) beweert dat alles goed staat
    > ingesteld. Ik denk dat ze er gewoon geen verstand van hebben maar ja, dat
    > heb ik ook niet dus ik kan het niet bewijzen.


    Je kan cdo via pickup laten werken als de smtp service draait en natuurlijk
    de server DNS kan gebruiken of een smart host kent. En anders gewoon via de
    smtp server van asohosting.

    Je kan nog beter php gebruiken heb je geen COM nodig al is CDO wel handig.
    Maar als je een smtp adres hebt hoeft asohosting verder niks voor je te doen
    zie voorbeelden daarvan.



  8. #8
    sturkie
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    > Kan ik dus niet bij en ik heb die hosters ook al gevraagd of ze ze wilden
    > bekijken voor me maar daar werd niet op gereageerd...


    Zet bij je internetopties de gebruiksvriendelijke foutmeldingen uit dan
    krijg je netjes een foutmelding te zien van je ASP pagina?



  9. #9
    _help_
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS


    "Sabine" <werk@DITWEGHALENsabine.nl> schreef in bericht
    news:42b81f9d$0$814$3a628fcd@textreader.nntp.hccne t.nl...
    > Hallo,
    >
    > Heeft iemand hier ervaring met mail versturen via een ASP-script met de
    > server component (?) CDOSYS? Op
    > http://www.powerasp.com/content/new/...ail_cdosys.asp staan drie
    > methodes maar geen enkele variant wil een mailtje bij mij of iemand van
    > het domein waarvandaan wordt gestuurd afleveren. Nu vermoed ik dat het mis
    > gaat omdat er op de server in IIS iets moet worden ingesteld maar ik weet
    > niet wat en de hostingpartij (AS Hosting) beweert dat alles goed staat
    > ingesteld. Ik denk dat ze er gewoon geen verstand van hebben maar ja, dat
    > heb ik ook niet dus ik kan het niet bewijzen.
    >
    > Alvast bedankt,
    > Sabine
    >


    je moet wel weten welke server (software) er wordt gebruikt door uw hostheer

    indien de server : WinNT of Win2000
    gebruik dan "CDONTS.NewMail"

    indien de server : Win2003
    gebruik dan "CDO.Message"

    voorbeeldjes:

    te gebruiken op server WinNT of Win2000
    -------------------------------------------

    Dim objCDO
    Set objCDO = Server.CreateObject("CDONTS.NewMail")
    objCDO.To = strTo
    objCDO.Cc = strCc
    objCDO.Bcc = strBcc
    objCDO.From = strFrom
    objCDO.Subject = strSubject
    objCDO.Body = strBody
    objCDO.Send
    Set objCDO = Nothing


    te gebruiken op server 2003
    ----------------------------

    Dim objCDO
    Set objCDO = Server.CreateObject("CDO.Message")
    objCDO.To = strTo
    objCDO.Cc = strCc
    objCDO.Bcc = strBcc
    objCDO.From = strFrom
    objCDO.Subject = strSubject
    objCDO.TextBody = strBody
    objCDO.Send
    Set objCDO = Nothing


    natuurlijk op voorhand de strings "strTo" en de "strCc" en ...enz...
    declareren




  10. #10
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    "sturkie" <nomail@hotmail.com> wrote in message
    news:42b9a2de$0$35802$e4fe514c@news.xs4all.nl...
    >> Kan ik dus niet bij en ik heb die hosters ook al gevraagd of ze ze wilden
    >> bekijken voor me maar daar werd niet op gereageerd...

    >
    > Zet bij je internetopties de gebruiksvriendelijke foutmeldingen uit dan
    > krijg je netjes een foutmelding te zien van je ASP pagina?


    Dit had ik al ingesteld. Ik zie dus ook de ASP foutmeldingen wel maar er
    zijn ook script-varianten geweest die geen foutmelding gaven en toch geen
    mail afleverden. Daar concludeer ik uit dat het op de server niet goed gaat
    maar ik kan dus niet zien wat...



  11. #11
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    > je moet wel weten welke server (software) er wordt gebruikt door uw
    > hostheer
    >
    > indien de server : WinNT of Win2000
    > gebruik dan "CDONTS.NewMail"
    >
    > indien de server : Win2003
    > gebruik dan "CDO.Message"


    -- knip script --

    Hmmm, de helpdesk zei mij dat CDONTS niet werd ondersteund op het Win2003
    platform van hun server en dat ik om die reden CDOSYS moest gebruiken maar
    ik ga deze variant van jou toch even proberen.

    Tnx!
    Sabine



  12. #12
    Sabine
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS

    > indien de server : Win2003
    > gebruik dan "CDO.Message"
    >

    -- knip script voor NT/2000 --

    > te gebruiken op server 2003
    > ----------------------------
    >
    > Dim objCDO
    > Set objCDO = Server.CreateObject("CDO.Message")
    > objCDO.To = strTo
    > objCDO.Cc = strCc
    > objCDO.Bcc = strBcc
    > objCDO.From = strFrom
    > objCDO.Subject = strSubject
    > objCDO.TextBody = strBody
    > objCDO.Send
    > Set objCDO = Nothing
    >


    Mijn versie:

    Dim sTo
    Dim sFrom
    Dim sSubject
    Dim sTextBody

    sTo = "mijn eigen e-mailadres"
    sFrom = "ander geldig e-mailadres"
    sSubject = "test donderdag om 10:20"
    sTextBody = "Script uit nieuwsgroep"


    Dim objCDO
    Set objCDO = Server.CreateObject("CDO.Message")
    objCDO.To = sTo
    objCDO.From = sFrom
    objCDO.Subject = sSubject
    objCDO.TextBody = sTextBody
    objCDO.Send
    Set objCDO = Nothing

    Helaas werkt niet. Levert volgende foutmelding op:

    CDO.Message.1 error '80040220'

    The "SendUsing" configuration value is invalid.

    /sendmail.asp, line 22

    En op regel 22 staat 'objCDO.Send'

    Maar toch bedankt voor het meedenken!

    Sabine



  13. #13
    _help_
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS


    "Sabine" <werk@DITWEGHALENsabine.nl> schreef in bericht
    news:42ba6fb5$0$808$3a628fcd@textreader.nntp.hccne t.nl...
    >> je moet wel weten welke server (software) er wordt gebruikt door uw
    >> hostheer
    >>
    >> indien de server : WinNT of Win2000
    >> gebruik dan "CDONTS.NewMail"
    >>
    >> indien de server : Win2003
    >> gebruik dan "CDO.Message"

    >
    > -- knip script --
    >
    > Hmmm, de helpdesk zei mij dat CDONTS niet werd ondersteund op het Win2003
    > platform van hun server en dat ik om die reden CDOSYS moest gebruiken maar
    > ik ga deze variant van jou toch even proberen.


    klopt, CDONTS niet gebruiken wanneer de server win2003 is
    zoals ik vermeld had:
    >> indien de server : WinNT of Win2000, gebruik dan "CDONTS.NewMail"
    >> indien de server : Win2003, gebruik dan "CDO.Message"




  14. #14
    _help_
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS


    "Sabine" <werk@DITWEGHALENsabine.nl> schreef in bericht
    news:42ba72e9$0$808$3a628fcd@textreader.nntp.hccne t.nl...
    >> indien de server : Win2003
    >> gebruik dan "CDO.Message"
    >>

    > -- knip script voor NT/2000 --
    >
    >> te gebruiken op server 2003
    >> ----------------------------
    >>
    >> Dim objCDO
    >> Set objCDO = Server.CreateObject("CDO.Message")
    >> objCDO.To = strTo
    >> objCDO.Cc = strCc
    >> objCDO.Bcc = strBcc
    >> objCDO.From = strFrom
    >> objCDO.Subject = strSubject
    >> objCDO.TextBody = strBody
    >> objCDO.Send
    >> Set objCDO = Nothing
    >>

    >
    > Mijn versie:
    >
    > Dim sTo
    > Dim sFrom
    > Dim sSubject
    > Dim sTextBody
    >
    > sTo = "mijn eigen e-mailadres"
    > sFrom = "ander geldig e-mailadres"
    > sSubject = "test donderdag om 10:20"
    > sTextBody = "Script uit nieuwsgroep"
    >
    >
    > Dim objCDO
    > Set objCDO = Server.CreateObject("CDO.Message")
    > objCDO.To = sTo
    > objCDO.From = sFrom
    > objCDO.Subject = sSubject
    > objCDO.TextBody = sTextBody
    > objCDO.Send
    > Set objCDO = Nothing
    >
    > Helaas werkt niet. Levert volgende foutmelding op:
    >
    > CDO.Message.1 error '80040220'
    >
    > The "SendUsing" configuration value is invalid.
    >
    > /sendmail.asp, line 22
    >
    > En op regel 22 staat 'objCDO.Send'
    >
    > Maar toch bedankt voor het meedenken!
    >
    > Sabine
    >


    Sabinneke, Sabinneke,
    googelen hé mijn kind
    http://www.google.be/search?biw=995&...g_en%7Clang_nl



  15. #15
    _help_
    Server instellingen voor CDOSYS
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Server instellingen voor CDOSYS


    <knip>
    > CDO.Message.1 error '80040220'
    > The "SendUsing" configuration value is invalid.

    </knip>

    kijk eens hier :
    http://support.microsoft.com/default...b;en-us;322338

    This error occurs if the following conditions exist: . Your computer is
    running Microsoft Windows 2000 Server.
    . Either Outlook 2002 or Microsoft SharePoint Portal Server 2001 is
    installed on your computer.
    . Microsoft Exchange 2000 Server is not installed.
    . You are using CDOSYS to send mail, possibly using an Active Server
    Pages (ASP) page.
    . You do not use the CDO.Configuration object to set a smart host or
    port in your code.
    . The process that is running CDOSYS is running as an account that is
    not an administrator account. For example, if the process is running as an
    ASP page, the protection level is set to medium or high, which causes the
    code to run under the credentials of the IWAM_COMPUTERNAME account.




Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics