Regelmatig krijg ik de foutmelding bad file descriptors
Nu wilde ik maxfiles verhogen. Maar wat is de goede waarde?
Maakt het niet uit of moet ik veelvouden van 1024 nemen?
mvg
--
posted by:
news.kools-online.com
http://www.kools-online.com
Likes: 0
Regelmatig krijg ik de foutmelding bad file descriptors
Nu wilde ik maxfiles verhogen. Maar wat is de goede waarde?
Maakt het niet uit of moet ik veelvouden van 1024 nemen?
mvg
--
posted by:
news.kools-online.com
http://www.kools-online.com
johnny_bravo <johnny_bravo@kools-online.com.invalid> wrote:
> Regelmatig krijg ik de foutmelding bad file descriptors
Wie zegt dat?
> Nu wilde ik maxfiles verhogen. Maar wat is de goede waarde?
Een goede waar is het maximum wat je nodigt denkt te hebben.
> Maakt het niet uit of moet ik veelvouden van 1024 nemen?
Dat maakt niets uit in het algemeen, maar dat kan natuurlijk heel goed
afhankelijk zijn van het gebruikte OS!
Maar wat is de instelling maxfiles uberhaupt? Is dat iets van mysql of
de webserver of van het OS?
--
Daniel Tryba
On Mon, 1 Nov 2004 13:23:19 +0000 (UTC), Daniel Tryba
<news_nl.internet.www.server-side@canopus.nl> wrote:
>johnny_bravo <johnny_bravo@kools-online.com.invalid> wrote:
>> Regelmatig krijg ik de foutmelding bad file descriptors
>
>Wie zegt dat?
de errorlog
>
>> Nu wilde ik maxfiles verhogen. Maar wat is de goede waarde?
>
>Een goede waar is het maximum wat je nodigt denkt te hebben.
>
>> Maakt het niet uit of moet ik veelvouden van 1024 nemen?
>
>Dat maakt niets uit in het algemeen, maar dat kan natuurlijk heel goed
>afhankelijk zijn van het gebruikte OS!
>
>Maar wat is de instelling maxfiles uberhaupt? Is dat iets van mysql of
>de webserver of van het OS?
OS
OS : OpenBSD
PHP : 4.3.4
MySQL : 4.0.18
kern.maxvnodes = 1310
kern.maxproc = 532
kern.maxfiles = 1772
kern.argmax = 262144
huidige conf.
Maar ik heb de oorzaak al gevonden denk ik.
Ik had portal e107 geinstalleerd en van toen kreeg ik die foutmeldingen.
En vanmiddag wilde ik mysql restarten omdat er weer een querry error was.
Bleek shutdown niet te werken en moeten killen met kill -9.
Proberen op te starten met mysql_safe bleek die 0 bytes te zijn!
Afijn terug gekopieerd uit de source en het werkte weer.
Gelijk e107 gedropt natuurlijk.
mvg
--
posted by:
news.kools-online.com
http://www.kools-online.com
johnny_bravo <johnny_bravo@kools-online.com.invalid> wrote:
> Ik had portal e107 geinstalleerd en van toen kreeg ik die foutmeldingen.
> En vanmiddag wilde ik mysql restarten omdat er weer een querry error was.
> Bleek shutdown niet te werken en moeten killen met kill -9.
> Proberen op te starten met mysql_safe bleek die 0 bytes te zijn!
> Afijn terug gekopieerd uit de source en het werkte weer.
> Gelijk e107 gedropt natuurlijk.
Er is natuurlijk geen verband tussen een file van 0 bytes en e107,
tenzij er iets heel erg fout is met je setup. Tenzij de file permissies
voor mysql beschrijfbaar is voor de user waaronder e107 (en dus je
webserver?) draaid had die file dus nooit 0 bytes mogen zijn, wellicht
dat het duidt op filesystem corruptie (en dus eventueel een hardware
probleem).
--
Daniel Tryba
On Mon, 1 Nov 2004 22:29:52 +0000 (UTC), Daniel Tryba
<news_nl.internet.www.server-side@canopus.nl> wrote:
>johnny_bravo <johnny_bravo@kools-online.com.invalid> wrote:
>> Ik had portal e107 geinstalleerd en van toen kreeg ik die foutmeldingen.
>> En vanmiddag wilde ik mysql restarten omdat er weer een querry error was.
>> Bleek shutdown niet te werken en moeten killen met kill -9.
>> Proberen op te starten met mysql_safe bleek die 0 bytes te zijn!
>> Afijn terug gekopieerd uit de source en het werkte weer.
>> Gelijk e107 gedropt natuurlijk.
>
>Er is natuurlijk geen verband tussen een file van 0 bytes en e107,
>tenzij er iets heel erg fout is met je setup. Tenzij de file permissies
>voor mysql beschrijfbaar is voor de user waaronder e107 (en dus je
>webserver?) draaid had die file dus nooit 0 bytes mogen zijn, wellicht
>dat het duidt op filesystem corruptie (en dus eventueel een hardware
>probleem).
mysqld_safe:
rwxr-xr-x 1 root wheel 10761 Nov 1 18:55 mysqld_safe
De db draait onder mysqluser
drwx------ 2 mysqlusr wheel 512 Mar 22 2004 test, bv.
mvg
--
posted by:
news.kools-online.com
http://www.kools-online.com