Herinneren jullie je die error 404 meldingen omdat Google URL's afbrak
door een "/" te presenteren als een "/ " (slash plus spatie)? Dit heb ik
opgelost door het volgende in mijn .htaccess op te nemen:
# redirect /%20 /
RewriteCond %{REQUEST_URI} /\ (.*)$
RewriteRule ^\ (.*)$ http://%{HTTP_HOST}/$1 [R=permanent,L]
RewriteCond %{REQUEST_URI} (.*)/\ (.+)$
RewriteRule (.*)/\ (.+)$ http://%{HTTP_HOST}/$1/$2 [R=permanent,L]
Maar nu leidt de nieuwe Google opmaak weer tot andere
error404-meldingen. Wat dacht je van een request voor:
http://www.datatrain.be/training_<b>iseries</b>_ile_<b>rpg</b>_.htm
Kennelijk had er iemand op Google gezocht naar iseries en rpg. En
vervolgens 'doorgeklikt' naar de URL inclusief de <b> en </b>. Welke
onzinnige browser deed dat? Welnu:
MSIE 5.01; Windows 95; IDv5a-b5; IDv5a-b1; freeserve_IE4
Ik heb mijn error404-script inmiddels zodanig aangepast dat de <b>,
</b>, %3Cb%3E en %3C/b%3E uit de request gesloopt wordt en de surfer
alsnog de goede URL voorgeschoteld krijgt.
Jan - die zat te twijfelen of dit in NIWO dan wel in NIWS-S moest
--
Look, Ma. No tables - http://enbio.steenbergen-stichting.nl/

Likes:

Quote