Likes Likes:  0
Resultaten 1 tot 3 van de 3
Geen

Onderwerp: foutmelding in PHP

  1. #1
    BEDI
    foutmelding in PHP
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    foutmelding in PHP

    Hallo allemaal,

    Op mijn website krijg ik de volgende melding:


    Warning: main() [function.main]: open_basedir restriction in effect.
    File(../globals.inc.php) is not within the allowed path(s): (.) in
    /www/htdocs/newsletter/admin/index.php on line 9

    Warning: main(../globals.inc.php) [function.main]: failed to create stream:
    Operation not permitted in /www/htdocs/2004/newsletter/admin/index.php on
    line 9

    Fatal error: main() [function.main]: Failed opening required
    '../globals.inc.php' (include_path='.:/usr/local/lib/php') in
    /www/htdocs/2004/newsletter/admin/index.php on line 9


    Weet iemand wat dit in houd en hoe het is op te lossen?


    --

    Groetjes....

    (p.s. wil je me mailen, haal dan "_nospam" weg voor mijn e-mailadres)





  2. #2
    Ronald Klip
    foutmelding in PHP
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: foutmelding in PHP

    BEDI schreef:
    >
    > Op mijn website krijg ik de volgende melding:
    >
    > Warning: main() [function.main]: open_basedir restriction in effect.
    > File(../globals.inc.php) is not within the allowed path(s): (.) in
    > /www/htdocs/newsletter/admin/index.php on line 9


    Hier gaat het fout. De andere meldingen zijn hoogst waarschijnlijk een
    gevolg van de eerste.
    De melding komt erop neer dat in php.ini of httpd.conf is ingesteld dat
    scripts alleen andere scripts mogen aanroepen als die in dezelfde
    directory staan. Doorgaans is dat een security-instelling.

    > Warning: main(../globals.inc.php) [function.main]: failed to create stream:
    > Operation not permitted in /www/htdocs/2004/newsletter/admin/index.php on
    > line 9
    >
    > Fatal error: main() [function.main]: Failed opening required
    > '../globals.inc.php' (include_path='.:/usr/local/lib/php') in
    > /www/htdocs/2004/newsletter/admin/index.php on line 9
    >
    > Weet iemand wat dit in houd en hoe het is op te lossen?


    Iemand die toegang heeft tot php.ini zal die instelling moeten wijzigen.
    Als de server van jou is, kun je dat zelf doen; anders zal je het aan je
    provider moeten vragen.
    Makkelijker is waarschijnlijk om globals.inc.php te verplaatsen naar de
    directory waar je script staat, en je index.php aan te passen voor die
    nieuwe locatie.

    --
    groet, Ronald

  3. #3
    BEDI
    foutmelding in PHP
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: foutmelding in PHP


    "Ronald Klip" <ronald@bladibla.njet> schreef in bericht
    news:MPG.18a363b11a1f04ee989aa5@nl-news.euro.net...
    > BEDI schreef:
    > >
    > > Op mijn website krijg ik de volgende melding:
    > >
    > > Warning: main() [function.main]: open_basedir restriction in effect.
    > > File(../globals.inc.php) is not within the allowed path(s): (.) in
    > > /www/htdocs/newsletter/admin/index.php on line 9

    >
    > Hier gaat het fout. De andere meldingen zijn hoogst waarschijnlijk een
    > gevolg van de eerste.
    > De melding komt erop neer dat in php.ini of httpd.conf is ingesteld dat
    > scripts alleen andere scripts mogen aanroepen als die in dezelfde
    > directory staan. Doorgaans is dat een security-instelling.
    >
    > > Warning: main(../globals.inc.php) [function.main]: failed to create

    stream:
    > > Operation not permitted in /www/htdocs/2004/newsletter/admin/index.php

    on
    > > line 9
    > >
    > > Fatal error: main() [function.main]: Failed opening required
    > > '../globals.inc.php' (include_path='.:/usr/local/lib/php') in
    > > /www/htdocs/2004/newsletter/admin/index.php on line 9
    > >
    > > Weet iemand wat dit in houd en hoe het is op te lossen?

    >
    > Iemand die toegang heeft tot php.ini zal die instelling moeten wijzigen.
    > Als de server van jou is, kun je dat zelf doen; anders zal je het aan je
    > provider moeten vragen.
    > Makkelijker is waarschijnlijk om globals.inc.php te verplaatsen naar de
    > directory waar je script staat, en je index.php aan te passen voor die
    > nieuwe locatie.
    >
    > --
    > groet, Ronald


    dankje, probleem opgelost!



Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics