libphp7.so undefined symbol: curl_mime_name

Onderwerp: libphp7.so undefined symbol: curl_mime_name

  1. libphp7.so undefined symbol: curl_mime_name

    MauriceO said:

    libphp7.so undefined symbol: curl_mime_name

    Na een update van PHP start Apache niet meer

    httpd[23207]: httpd: Syntax error on line 50 of /etc/httpd/conf/httpd.conf: Syntax error on line 4 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/libphp7.so into server: /usr/lib/apache/libphp7.so: undefined symbol: curl_mime_name

    Regel 50 van /etc/httpd/conf/httpd.conf
    Include /etc/httpd/conf/extra/httpd-phpmodules.conf

    Regel 4 van /etc/httpd/conf/extra/httpd-phpmodules.conf
    LoadModule php7_module /usr/lib/apache/libphp7.so


    Heb al een nieuwe build van apache en php gedaan en rewrite conf. Dezelfde melding blijft.

    Iemand een idee hoe dit op te lossen?

    php 7.4.33
    apache 2.4.54
    centos 7
  2. libphp7.so undefined symbol: curl_mime_name

    dennis0162 said:
    Regel 4 van /etc/httpd/conf/extra/httpd-phpmodules.conf
    LoadModule php7_module /usr/lib/apache/libphp7.so

    Klinkt alsof je httpd en/of PHP via apt-get geïnstalleerd hebt?


    Kan je de volledige /etc/httpd/conf/extra/httpd-phpmodules.conf eens posten?



    LoadModule mpm_event_module /usr/lib/apache/mod_mpm_event.so
  3. libphp7.so undefined symbol: curl_mime_name

    MauriceO said:
    Alles via Custombuild gedaan.
    apt-get is voor Ubuntu, ik heb CentOS.



    cat /etc/httpd/conf/extra/httpd-phpmodules.conf
    PHP Code: [Bekijk]
    LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    Mutex posixsem
    LoadModule mpm_prefork_module 
    /usr/lib/apache/mod_mpm_prefork.so
    LoadModule php7_module 
    /usr/lib/apache/libphp7.so

  4. libphp7.so undefined symbol: curl_mime_name

    MauriceO said:
    Het is inmiddels opgelost.

    Van mod_php naar php-fpm omgezet, build php opnieuw, en rewrite_confs Hierna doet Apache het weer.