Auto renew van Let's Encrypt SSL certificaten werkt niet

Onderwerp: Auto renew van Let's Encrypt SSL certificaten werkt niet

  1. Auto renew van Let's Encrypt SSL certificaten werkt niet

    Pepperfield said:

    Auto renew van Let's Encrypt SSL certificaten werkt niet

    Hi,

    Het automatisch vernieuwen van Let's Encrypt certificaten werkt bij ons niet meer in combinatie met DirectAdmin. Handmatig een certificaat aanmaken via DirectAdmin werkt prima.

    In de logging kunnen we geen hints vinden. Het mechanisme lijkt spontaan gestopt te zijn.

    Enig idee wat er mis kan zijn?

    Gr,
    Pepperfield
     
  2. webmediaede's Avatar

    webmediaede said:
    Wat is de melding die je krijgt als de renew mislukt?
     
  3. Auto renew van Let's Encrypt SSL certificaten werkt niet

    Pepperfield said:
    Citaat Oorspronkelijk geplaatst door webmediaede Bekijk Berichten
    Wat is de melding die je krijgt als de renew mislukt?
    Het is auto renew, dus het zou automatisch moeten gaan. In de logging van DirectAdmin vindt ik dit terug:

    Can't connect to ssl!
    -> A failure in the SSL library occurred, usually a protocol error.
    -> error:00000001:lib(0):func(0)eason(1)
     
  4. Auto renew van Let's Encrypt SSL certificaten werkt niet

    ju5t said:
    Code: [Bekijk]
    /usr/local/directadmin/scripts/letsencrypt.sh renew 'domein.nl' 4096 /usr/local/directadmin/data/users/username/domains/domein.nl.san_config /var/www/html
    Dit is het commando wat DirectAdmin voor je start. Je kunt dit terug vinden in /var/log/directadmin/system.log. Wat is daar de output van?
     
  5. Auto renew van Let's Encrypt SSL certificaten werkt niet

    Pepperfield said:
    Citaat Oorspronkelijk geplaatst door ju5t Bekijk Berichten
    [code]
    Dit is het commando wat DirectAdmin voor je start. Je kunt dit terug vinden in /var/log/directadmin/system.log. Wat is daar de output van?
    In de system.log kom ik alleen dit tegen:

    /usr/local/directadmin/scripts/letsencrypt.sh request 'domeinnaam' ...

    Dat lijken handmatige certificaataanvragen. Ik vermoed dat de logging niet ver genoeg teruggaat om een renewal te vinden.

    Ik zal de logging monitoren op /usr/local/directadmin/scripts/letsencrypt.sh renew en de uitkomst hier posten.
     
  6. Auto renew van Let's Encrypt SSL certificaten werkt niet

    ju5t said:
    In die logging staat niet zoveel volgens mij. Je moet het commando even met de hand draaien om te kijken wat daar uit komt.
     
  7. Auto renew van Let's Encrypt SSL certificaten werkt niet

    dreamhost_nl said:
    Ook niks veranderd aan de open poorten in je firewall? De cronjob draait gewoon nog (is niet per ongeluk verwijderd)?
    DreamHost.nl Web hosting - cPanel hosting om bij weg te dromen.
     
  8. Auto renew van Let's Encrypt SSL certificaten werkt niet

    Pepperfield said:
    Opgelost. Het was een foutje aan de zijde van DirectAdmin. Met hulp van DirectAdmin probleem gevonden en opgelost.
     
  9. Domenico's Avatar

    Domenico said:
    Citaat Oorspronkelijk geplaatst door Pepperfield Bekijk Berichten
    Opgelost. Het was een foutje aan de zijde van DirectAdmin. Met hulp van DirectAdmin probleem gevonden en opgelost.
    En wat was nu de oorzaak? En de oplossing?
     
  10. Auto renew van Let's Encrypt SSL certificaten werkt niet

    Pepperfield said:
    De auto-renew wordt getriggerd door een bepaald bestand (san_config) in het account van de website op de server. Dit bestand ontbrak bij een aantal accounts. Met als gevolg dat de auto-renew faalde.

    We hebben een script geschreven waarmee we alle accounts hebben gecontroleerd op de aanwezigheid van dit bestand. Daarmee hebben we een relatief klein aantal accounts gevonden waar het bestand nog ontbrak. Dat hebben we gefixt.

    Waarom san_config in deze accounts ontbrak, is nog steeds een raadsel.