Resultaten 1 tot 4 van de 4
  1. #1
    Vakantieberichten worden niet verzonden
    geregistreerd gebruiker
    456 Berichten
    Ingeschreven
    22/03/07

    Locatie
    Soerendonk

    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    5 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Vakantieberichten worden niet verzonden

    Goedendag,

    Op een Directadmin server hebben wij het volgende probleem.
    Hij zou vakantieberichten moeten versturen, maar dit doet hij niet.

    Als we dan een keer ./build exim_conf doet werkt het ongeveer 1 dag, daarna valt het weer stil.

    Iemand enig idee?
    Ik test het met diverse afzenders

    Log:

    2019-01-04 14:49:58 1gfPrK-0005d9-Fj <= xxxxx@gmail.com H=mail-qt1-f180.google.com [209.85.160.180] P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=4435 DKIM=gmail.com id=CAKN=5h7UUUD1s7=jr0m1L_wSrwM76_GGPL1TMk==+4W9jX 1gCg@mail.gmail.com T="yredfsd" from <xxxxx@gmail.com> for test@klantmail.nl
    2019-01-04 14:49:59 1gfPrK-0005d9-Fj => test <test@klantmail.nl> F=<xxxxxx@gmail.com> R=virtual_user T=dovecot_lmtp_udp S=4653 C="250 2.0.0 <test@klantmail.nl> B+NrOoZkL1z7UgAA1SLCaw Saved"
    2019-01-04 14:49:59 1gfPrL-0005dF-2C <= <> R=1gfPrK-0005d9-Fj U=mail P=local S=605 T="Autoreply: yredfsd" from <> for xxxxx@gmail.com



  2. #2
    Vakantieberichten worden niet verzonden
    Server Freak
    3.589 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas
    KvK nummer: 04069370

    Je zegt dat het na een config rebuild werkt. Pak die config eens apart en ook wanneer het niet meer werkt. Check vervolgens met diff de verschillen. Toevallig een map custom in je custombuild map welke outdated is?

  3. #3
    Vakantieberichten worden niet verzonden
    moderator
    4.646 Berichten
    Ingeschreven
    21/02/09

    Locatie
    Noord-Holland

    Post Thanks / Like
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    185 Berichten zijn liked


    Naam: D. Koop
    Bedrijf: Yourwebhoster.eu
    Functie: baas
    URL: yourwebhoster.eu
    KvK nummer: 32165429
    View danielkoop's profile on LinkedIn

    Citaat Oorspronkelijk geplaatst door Spyder01 Bekijk Berichten
    Je zegt dat het na een config rebuild werkt. Pak die config eens apart en ook wanneer het niet meer werkt. Check vervolgens met diff de verschillen. Toevallig een map custom in je custombuild map welke outdated is?
    Als custom outdated is dan zou het moeten blijven werken, ook na een dag lijkt me. Maar het kan geen kwaad om even te kijken of om Exim bij te werken (inclusief pl). Overigens zou ik in de logs kijken of er toevallig een wijziging is gemaakt. Overigens is het wel goed om te weten dat een vakantie bericht alleen als reactie op het eerste bericht wordt gestuurd en dat daarna gewacht wordt op de ingestelde Reply Frequency.

    Verder kan je kijken in /usr/local/directadmin/scripts/custom of daar wellicht ook iets gedaan wordt met Exim. Mogelijk is er een script die invloed heeft op Exim en pas getriggerd wordt na een aanpassing in de logs.

    Mocht je er niet uit komen, stuur dan even een bericht. Dan kijk ik er naar.
    Laatst gewijzigd door Yourwebhoster; 05/01/19 om 11:11.
    Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  4. #4
    Vakantieberichten worden niet verzonden
    geregistreerd gebruiker
    456 Berichten
    Ingeschreven
    22/03/07

    Locatie
    Soerendonk

    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    5 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Vanochtend werkte de vakantie reply weer niet, dus ik heb van de exim.conf een backup gemaakt en daarna weer eens .build exim_conf gedaan.
    Direct daarna werkte hij weer, maar een “diff exim.conf.bak exim.conf” geeft geen verschillen. Als ik de backup file terugzet blijft het hierna ook gewoon werken.
    Het lijkt mij dus niet in de config te zitten, wat doet .build exim_conf nog meer? Alleen het herstarten van exim?

    In de /usr/local/directadmin/scripts/custom map staan een paar scriptjes, maar die doen enkel iets met mysql en niets met exim.

    Exim is ook al bijgewerkt, maar dat heeft geen verschil gemaakt.

    Uit de /var/log/exim/mainlog kan ik dit halen als ik een testbericht verstuur op het moment dat ik geen reactie meer krijg (domeinen en ip adress zijn natuurlijk aangepast):

    2019-01-10 09:07:53 1ghVNZ-0007Vy-K8 <= mijnemail@<onsdomein>.nl H=delivery.cloudorb.com [IP-Adress] P=esmtps X=TLSv1.2HE-RSA-AES128-GCM-SHA256:128 CV=no S=4773 id=f60cc9f73de946a2948e8ae53501325f@<onsdomein>.nl T="test 5" from <mijnemail@<onsdomein>.nl> for test@<klantdomein>.nl
    2019-01-10 09:07:53 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1ghVNZ-0007Vy-K8
    2019-01-10 09:07:53 1ghVNZ-0007Vy-K8 => test <test@<klantdomein>.nl> F=<mijnemail@<onsdomein>.nl> R=virtual_user T=dovecot_lmtp_udp S=5024 C="250 2.0.0 <test@<klantdomein>.nl> EIrMOVn9NlwebwAA1SLCaw Saved"
    2019-01-10 09:07:54 cwd=/ 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1ghVNZ-0007Vy-K8
    2019-01-10 09:07:54 1ghVNa-0007W6-0p / is not allowed to send as it contains a value from /var/spool/exim/blocked_script_paths
    2019-01-10 09:07:54 1ghVNa-0007W6-0p <= <> R=1ghVNZ-0007Vy-K8 U=mail P=local S=544 T="Autoreply: "test 5"" from <> for mijnemail@<onsdomein>.nl
    2019-01-10 09:07:54 1ghVNa-0007W6-0p => blackhole (non-SMTP ACL discarded recipients)
    2019-01-10 09:07:54 1ghVNa-0007W6-0p Completed
    2019-01-10 09:07:54 1ghVNZ-0007Vy-K8 == test@<klantdomein>.nl R=uservacation T=uservacation defer (0): Failed to send message from uservacation transport (1)

    Dit stukje valt me hieruit op:
    / is not allowed to send as it contains a value from /var/spool/exim/blocked_script_paths

    Deze staat idd ook in dat bestand als /:1529594554, maar wat betekend dit? Kan ik dit gewoon weghalen? En het verklaart nog niet waarom het wel een dagje werkt en daarna niet meer toch?

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2018 Webhostingtalk.nl.
Web Statistics