Beste,
Ik heb het volgende probleem sinds een korte tijd draai ik een lanparty site op joomla alleen sinds 2 nachten klapt mysql verbinding weg
Afgelope nacht herhaalde hij dit weet ik hoevaak er voor:Code:131015 20:08:21 [Warning] IP address '119.161.148.78' could not be resolved: getnameinfo() returned error (code: -3). 131015 20:08:21 [Warning] IP address '119.161.148.78' could not be resolved: getnameinfo() returned error (code: -3). 131015 20:08:22 [Warning] IP address '119.161.148.78' could not be resolved: getnameinfo() returned error (code: -3). 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_categories.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_comments.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_img_comments.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_img_votes.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_img_votes_statistics.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_user.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_votes.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_phocagallery_votes_statistics.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_plugins.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_poll_data.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_poll_date.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_poll_menu.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_polls.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rd_sitemap_rel_viewset_has_view.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rd_sitemap_view.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rd_sitemap_viewset.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsbanners_ad.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsbanners_adcat.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsgallery2_acl.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsgallery2_comments.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsgallery2_config.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsgallery2_files.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_rsgallery2_galleries.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_sections.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_session.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_stats_agents.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_templates_menu.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_users.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_weblinks.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_xmap.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_xmap_ext.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_xmap_items.frm' (errno: 24) 131016 0:11:21 [ERROR] /usr/local/mysql/bin/mysqld: Can't open file: './nodlan_website/jos_xmap_sitemap.frm' (errno: 24) 131016 6:35:28 [ERROR] Error in accept: Too many open files 131016 6:39:44 [ERROR] Error in accept: Too many open files 131016 6:44:00 [ERROR] Error in accept: Too many open files 131016 6:48:16 [ERROR] Error in accept: Too many open files 131016 6:52:32 [ERROR] Error in accept: Too many open files
[Warning] IP address '119.161.148.78' could not be resolved: getnameinfo() returned error (code: -3).
En de hele nacht door:
[ERROR] Error in accept: Too many open files
Nu heb ik op internet gelezen dat To many open files dit het oplosde:
open_files_limit=99000
Nu heb ik dit in /etc/my.cnf gezet ( Ik heb het idee dat hij deze niet als cnf gebruikt kan het mis hebben )
Ik heb mysql ook geupdate naar 5.6.14 vervolgens krijg ik dit in de err log:
2013-10-16 07:28:05 7ffa5490b700 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2013-10-16 07:28:05 7ffa5490b700 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2013-10-16 07:28:05 7ffa5490b700 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
en
2013-10-16 07:27:48 7ffa5490b700 InnoDB: Error: Fetch of persistent statistics requested for table "nodlan_website"."jos_xmap_items" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2013-10-16 07:27:48 7ffa5490b700 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
Van het één krijg ik het ander zou iemand mij kunnen helpen deze website draait voor onze inschrijvingen en moet zo snel mogelijk opgelost worden na een reboot van mysql server werkt het weer...

Likes:


Quote