Likes Likes:  0
Resultaten 1 tot 13 van de 13
Geen
  1. #1
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter

    Phpmyadmin error 500

    Als ik naar phpmyadmin wil gaan, geeft Firefox alleen een blanco pagina, IE geeft error 500.

    In /var/log/httpd/error.log is niets over phpmyadmin te vinden, in /var/log/httpd/domains/domein-error.log ook niet.
    Dus phpmyadmin maar verwijderd uit /var/www/html en opnieuw geinstalleerd via build script, maar zelfde euvel.
    Rechten staan hetzelfde als op de andere servers waar het wel werkt.

    Mod_ruid2 0.9.7 is geinstalleerd, maar als ik die uitzet in http.conf blijft het probleem bestaan.
    64-bits Centos 5.x server met php 5.2.17 (dat wilde de klant) en mysql 5.1.63.

    Alles draait op zich goed, Roundcube is ook gewoon te beanderen, zowel extern als via het DA paneel.
    Alleen phpmyadmin doet vervelend.

  2. #2
    Phpmyadmin error 500
    Dennis.
    3.867 Berichten
    Ingeschreven
    11/07/06

    Locatie
    Oosterhout

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    262 Berichten zijn liked


    Naam: Dennis
    Registrar SIDN: JA
    KvK nummer: 20144338

    Haal even de disable_functions regel weg uit je php.ini dan zou het moeten werken.
    Waarschijnlijk heb je ./build secure_php uitgevoerd.
    Laatst gewijzigd door dennis0162; 31/05/12 om 20:38.

  3. #3
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Had ik ook al geprobeerd alleen niet vermeld en uiteraard apache herstart, maar dat mocht toen ook niet helpen.
    Ik had zelf trouwens geen secure_php laten draaien, doe ik altijd handmatig aanpassen.

    Duh.. nu meen ik of ik gek wordt. Probeer ik het nu nog eens en nu werkt het opeens wel.

    Moet er wel bij zeggen dat php opnieuw gerebuild was omdat apc segfaults gaf dus heb die hele apc er uit geknikkerd en voor de zekerheid php gerebuild.
    Dit stond in dat regeltje:
    exec,system,passthru,shell_exec,escapeshellarg,esc apeshellcmd,proc_close,proc_open,dl,popen,virtual, ini_set

    Heb het weer teruggezet, maar dan wel zonder ini_set anders komt het error 500 probleem weer terug.
    Wel vreemd, want je zou ook zo de eigen php.ini moeten kunnen verbieden.

    Is in elk geval opgelost, thanks!

  4. #4
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.180 Berichten
    Ingeschreven
    21/08/06

    Locatie
    Noord Brabant

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    3 Berichten zijn liked


    Naam: Niels
    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Ik heb in PMA de error_reporting op E_ALL ^ E_NOTICE ^ E_WARNING staan. Probeer dat eens, en je kan de functie gewoon verbieden.

  5. #5
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Lijkt me sterk want error_reporting heeft toch alleen met het rapporteren van een error te maken, niet met het aan of uitschakelen van funkties? Dus dan zie je misschien de error niet meer maar werkt het nog steeds niet.

    Ik hou het liefst zo standaard mogelijk wat die configs van PMA betreft.

  6. #6
    Phpmyadmin error 500
    geregistreerd gebruiker
    108 Berichten
    Ingeschreven
    28/12/05

    Locatie
    Lansingerland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    5 Berichten zijn liked


    Naam: Marco van den Akker
    Bedrijf: 123Cloud BV
    Functie: Sales
    Registrar SIDN: ja
    KvK nummer: 27247267
    Ondernemingsnummer: nvt

    Heb je PHP via Custombuild in CLI draaien ? Wellicht dat er dubbele waardes actief zijn ?

  7. #7
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.180 Berichten
    Ingeschreven
    21/08/06

    Locatie
    Noord Brabant

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    3 Berichten zijn liked


    Naam: Niels
    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    In mijn geval stopte PMA met werken, zelfs met een warning (ini_set disabled). En de errors worden nog steeds gelogd, op de notice's en warnings na.

  8. #8
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Heb je PHP via Custombuild in CLI draaien ?
    Ja dat klopt, met mod_ruid2 geinstalleerd erbij. Heb niets aan de PMA config gewijzigd dus ik zou niet weten waar die dubbele waardes dan zouden moeten staan. Er staat maar 1 php.ini op het systeem en da's in /usr/local/lib waar hij ook hoort, nergens anders.

    @Niels:
    Dit staat in de php.ini over error reporting:
    Code:
    error_reporting = E_ALL & ~E_DEPRECATED
    In config.inc.php van PMA staat nergens een error_reporting setting.

  9. #9
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Ben het net even gaan testen op andere servers met DA, php in cli en de nieuwste mod_ruid2. Zelfde euvel overal.
    Zo gauw de ini_set in de php.ini erbij komt, dan komt er ook een error 500 bij het aanroepen van http://www.domein.nl/phpmyadmin dus het ligt niet aan dat ene systeem.
    Zonder de ini_set is het geen probleem.

    Met ini_set in de php.ini komt er niets in de httpd error log niet de /domains/domain.nl.error.log maar wel in de gewone /domains/domein.nl.log:
    84.26.xx.xx - - [05/Jun/2012:14:49:46 +0200] "GET /phpmyadmin/ HTTP/1.1" 500 261 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET4.0C; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)"
    Alleen error 500 te zien. Ik heb wel display_errors = Off staan in de php.ini maar de log_errors staat aan.
    Laatst gewijzigd door Blacky; 05/06/12 om 15:09.

  10. #10
    Phpmyadmin error 500
    Bizway.nl
    1.435 Berichten
    Ingeschreven
    18/01/10

    Locatie
    Bodegraven

    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    92 Berichten zijn liked


    Naam: Bart Lageweg
    Bedrijf: Bizway BV
    Registrar SIDN: ja
    ISPConnect: Lid
    KvK nummer: 28086287
    View nl.linkedin.com/in/bartlageweg's profile on LinkedIn

    Als je toch bezig bent, ik kom net achter een ander geintje.
    Phpmyadmin draait niet op Safari, tot je $cfg['AllowThirdPartyFraming'] = 1;
    in de config.php zet (laatste versie)
    Op zoek naar hostingpartijen die zich willen laten overnemen (met desgewenst aanblijven)

  11. #11
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Nja, ik ben niet bezig, verwonderde me alleen maar erover dat er een error 500 kwam als de ini_set in de php.ini gezegd werd bij de disable_functions optie.
    V.w.b. ondersteuning van Safari moet phpMyadmin die optie zelf maar standaard aan zetten, ik hou het zo standaard mogelijk, of er moet een van de klanten klagen.

    Maar wel handig om te weten uiteraard.

  12. #12
    Phpmyadmin error 500
    geregistreerd gebruiker
    561 Berichten
    Ingeschreven
    10/06/06

    Locatie
    Emmeloord

    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    21 Berichten zijn liked


    Naam: Arie

    Citaat Oorspronkelijk geplaatst door Bart L Bekijk Berichten
    Als je toch bezig bent, ik kom net achter een ander geintje.
    Phpmyadmin draait niet op Safari, tot je $cfg['AllowThirdPartyFraming'] = 1;
    in de config.php zet (laatste versie)
    Echter:

    Setting this to true allows a page located on a different domain to call phpMyAdmin inside a frame, and is a potential security hole allowing cross-frame scripting attacks.
    Is dat wel handig in te schakelen? Ik laat 'm voorlopig wel even mooi uit staan.

  13. #13
    Phpmyadmin error 500
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Hmz..... Ik laat hem ook wel uit.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics