Resultaten 1 tot 8 van de 8
Geen
  1. #1
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter

    AWStats - Premature end of script headers: awstats.pl

    Het probleem wordt hoogstwaarschijnlijk veroorzaakt door de plugin van AWStats die voorheen geinstalleerd stond, echter heb ik deze verwijderd, de native AWStats geinstalleerd en vervolgens alle configs opnieuw laten builden, maar ik blijf onderstaande errors krijgen:

    [Fri Aug 26 11:24:29 2011] [error] [client] (13)Permission denied: exec of '/home/<user>/domains/<domain>/public_html/awstats/awstats.pl' failed
    [Fri Aug 26 11:24:29 2011] [error] [client] Premature end of script headers: awstats.pl

    Een tijdelijke chmod 777 op het bestand awstats.pl lost het probleem ook niet op en CGI staat aan voor de gebruiker, iemand nog tips waar ik het dan moet zoeken? Alvast bedankt.

    Apache is overigens voorzien van de mod_ruid2 module dus het draait onder de juiste user.
    Laatst gewijzigd door Boyke; 26/08/11 om 11:34. Reden: mod_ruid2 info toegevoegd

  2. #2
    AWStats - Premature end of script headers: awstats.pl
    administrator
    21.459 Berichten
    Ingeschreven
    17/12/01

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    71 Post(s)
    Tagged
    0 Thread(s)
    590 Berichten zijn liked


    Naam: Domenico Consoli
    Bedrijf: Webhostingtalk.nl
    Functie: Oprichter
    URL: webhostingtalk.nl
    Registrar SIDN: Ja
    KvK nummer: 51327317
    TrustCloud: domenico
    View domenicoconsoli's profile on LinkedIn

    Is dit probleem inmiddels opgelost?

  3. #3
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Nee, maar awstats openen via DA of via /awstats/index.html werkt wel... erg vreemd.

    Bij DA zelf konden ze ook niet direct zeggen waar het aan ligt.

  4. #4
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Het probleem lijkt niet alleen met AWStats samen te hangen:

    (13)Permission denied: exec of '<path>/cgi-bin/email.cgi' failed, referer: <website>/demo.html
    Premature end of script headers: email.cgi, referer: <website>/demo.html
    File does not exist: <path>/500.shtml, referer: <website>/demo.html

    Als ik het script op de commandline uitvoer (onder de juiste user) dan werkt het wel.

    SELinux staat uit, mod_ruid2 staat erop, 755/777/754 mag ook niet baten...

  5. #5
    AWStats - Premature end of script headers: awstats.pl
    Service/Support = Heilig
    845 Berichten
    Ingeschreven
    18/08/07

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    42 Berichten zijn liked


    Naam: Maikel
    Bedrijf: Vertixo B.V.
    URL: www.vertixo.com
    Registrar SIDN: JA
    KvK nummer: 53940628
    TrustCloud: vertixo
    View vertixo's profile on LinkedIn

    Toevallig vandaag ook dit probleem gehad, niet zo zeer met awstats maar wel met cgi. Hier is het opgelost door de user rechten opnieuw in te stellen op de hele map cgi-bin met chown, wazig want het stond al goed maar toen werkte het wel...

  6. #6
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Bij mij is het ook CGI in zijn algemeenheid, helaas mocht de chown niet baten.

  7. #7
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Niemand anders met dit probleem?

  8. #8
    AWStats - Premature end of script headers: awstats.pl
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    De oplossing was zoals gewoonlijk "dichterbij" dan ik dacht:

    ls -lah /usr/bin/perl
    -rwx---r-x 2 root apache 19K Sep 28 14:53 /usr/bin/perl

    chmod 755 /usr/bin/perl

    Sinds wanneer perl die rechten standaard krijgt is mij een raadsel...

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics