Ik heb hierjuist mijn directadmin server geïnstalleerd maar de php functie rar_open werkt niet. Iemand die weet hoe je dit installeert?
Ik heb reeds gegoogled maar ik vind maar geen oplossing.
Likes: 0
Ik heb hierjuist mijn directadmin server geïnstalleerd maar de php functie rar_open werkt niet. Iemand die weet hoe je dit installeert?
Ik heb reeds gegoogled maar ik vind maar geen oplossing.
Je moet in de actieve php.ini bij de extensies rar.so toevoegen (check of je die wel op je server hebt staan, zo niet, zorg dat je hem krijgt). Checken welke ini gebruikt wordt, kun je doen door een phpinfo bestandje aan te maken.
Daarna apache herstarten en checken of hij er in staat d.m.v.
Code:php -i | grep rar
En hoe installeer je dan de extensie. Ik heb al gezocht in de apt-get maar niets gevonden. Via google dit dan gevonden: pecl -v install rar
maar dan krijg ik error.
Had ik ook geprobeerd maar kreeg deze error:
directadmin:/home/rpr/rar-2.0.0# phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
Cannot find autoconf. Please check your autoconf installation and the
$PHP_AUTOCONF environment variable. Then, rerun this script.
Ook eens gehad... kijk eens hoe je /tmp gemount is en anders even mounten met exec (en daarna terug remounten naar noexec natuurlijk)
# mount -o remount,exec /tmp
en daarna
# mount -o remount,noexec /tmp
Niet geschoten is altijd mis en anders moet je even verder zoeken
yum install autoconf al geprobeerd?
Heb nu de debian variant gebruikt want ik gebruik debian.
En dan werkt de installatie. Maar als ik de extensie toevoeg aan php.ini en apache herstart krijg ik volgende fout.
Code:PHP Warning: PHP Startup: Unable to load dynamic library './rar.so' - ./rar.so: cannot open shared object file: No such file or directory in Unknown on line 0 [Mon Aug 09 13:33:37 2010] [notice] Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8g DAV/2 PHP/5.2.13 configured -- resuming normal operations
De melding spreekt toch voor zich? rar.so wordt niet gevonden in het correcte path. Waar staat deze nu dan?
DreamHost.nl Web hosting - cPanel hosting om bij weg te dromen.

Inderdaad een duidelijke melding. Zoek even die rar.so op en verander je extension path in je ini file naar waar de file staat.
Als je de extensie via PECL hebt geinstalleerd hoef je niets in je php.ini te plaatsen?
