Likes Likes:  0
Resultaten 1 tot 15 van de 15
  1. #1
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    270 Berichten
    Ingeschreven
    01/06/06

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvr

    Thread Starter

    mysqldump: Got error: 2002

    Na de update van de afgelopen dagen worden databases niet meegenomen in de backups.

    Ik krijg de volgende melding in DA:
    Code:
    User admin has been backed up.
    
    Error while backing up database zprd_1x5
    Error while backing up database zprd_1x5: The sql file is 0 bytes in size: /home/tmp/admin/zprd/backup/zprd_1x5.sql
    mysqldump error output: mysqldump: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) when trying to connect
    
    Error while backing up database zprd_ad0
    Error while backing up database zprd_ad0: The sql file is 0 bytes in size: /home/tmp/admin/zprd/backup/zprd_ad0.sql
    mysqldump error output: mysqldump: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) when trying to connect
    
    User radio has been backed up.
    Op DA forum ben ik een aantal topics tegen gekomen maar voor mij niet echt duidelijk. Een DA user heeft opgelost door de my.cnf bestand te wijzigen maar wat precies staat er niet bij.

    Iemand die weet hoe ik dit kan oplossen?

    bvd

  2. #2
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Probeer het volgende eens:
    Code:
    [client]
    socket=/var/run/mysqld/mysqld.sock
    Toevoegen in my.cnf

    En dan DirectAdmin (+MySQL) restarten.

  3. #3
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    270 Berichten
    Ingeschreven
    01/06/06

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvr

    Thread Starter
    Citaat Oorspronkelijk geplaatst door xaban Bekijk Berichten
    Probeer het volgende eens:
    Code:
    [client]
    socket=/var/run/mysqld/mysqld.sock
    Toevoegen in my.cnf

    En dan DirectAdmin (+MySQL) restarten.
    DA opnieuw gestart. MySQL start niet meer. Via console ook niet.

    srv:~# /etc/init.d/mysqld start
    Starting mysqld: [ OK ]
    srv:~#
    2010:01:07-19:19:01: directadmin restarted
    2010:01:07-19:19:01: mysqld started
    2010:01:07-19:19:11: mysqld restarted
    2010:01:07-19:20:01: mysqld started
    2010:01:07-19:20:11: mysqld restarted
    2010:01:07-19:21:01: mysqld started
    2010:01:07-19:21:11: mysqld restarted
    2010:01:07-19:22:01: mysqld started
    2010:01:07-19:22:11: mysqld restarted

  4. #4
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    270 Berichten
    Ingeschreven
    01/06/06

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvr

    Thread Starter
    Iemand anders?

  5. #5
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Staan je rechten goed op de database? Is de eigenaar MYSQL?

  6. #6
    mysqldump: Got error: 2002
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Kijk sowieso even of hij wel bestaat:

    whereis mysqld.sock
    Staat er niet meer in de logs van MySQL?

  7. #7
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    En maak de CLIENT regel overigens even als volgt:

    [client]
    port = 3306
    socket = /var/lib/mysql/mysql.sock

  8. #8
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    270 Berichten
    Ingeschreven
    01/06/06

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvr

    Thread Starter
    Bedankt alle. Randy heeft het gefixt .

  9. #9
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    6.041 Berichten
    Ingeschreven
    23/10/04

    Locatie
    Amersfoort

    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    171 Berichten zijn liked


    Functie: Freelance IT Professional
    URL: localhost
    View randytenhave's profile on LinkedIn

    Even een uitleg voor de mensen die via Google hier komen. Het was een Debian machine. Met apt-get is er een package geïnstalleerd die MySQL en Apache als dependacy had. Daar ging het dus mis.
    Bij Debian/Ubuntu kun je geen exclude packages opgeven. Installeer je packages, geef dan altijd de -f switch mee als je apt-get gebruikt. Zo start er een simulatie. Zie je *iets* van php, mysql of apache, dan stoppen.

    Voorbeeld: apt-get -f install cacti
    Dan zul je zien dat die php, apache en mysql wil meeïnstalleren. En dat gaat DA niet fijn vinden. Ram je klakkeloos op 'y', dan kost het je een Whopper® .
    MultiMaak - Voor persoonlijke cadeau's en relatiegeschenken!

  10. #10
    mysqldump: Got error: 2002
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Citaat Oorspronkelijk geplaatst door Randy Bekijk Berichten
    En dat gaat DA niet fijn vinden. Ram je klakkeloos op 'y', dan kost het je een Whopper® .
    Als u denkt dat experts duur zijn, wacht dan maar af tot u ziet wat amateurs u kosten!
    Kon het niet laten Randy

  11. #11
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Randy: Zonder de -f optie, zie je dat toch ook, wat apt-get allemaal met zich meeneemt?

    Wat was de oplossing? Wat heb je moeten doen?

  12. #12
    mysqldump: Got error: 2002
    Registered User
    1.610 Berichten
    Ingeschreven
    14/12/06

    Locatie
    Utrecht, Haarlem

    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: MS
    Bedrijf: XSXN
    Registrar SIDN: nee
    KvK nummer: 30212937
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door xaban Bekijk Berichten
    Randy: Zonder de -f optie, zie je dat toch ook, wat apt-get allemaal met zich meeneemt?

    Wat was de oplossing? Wat heb je moeten doen?
    Klopt, die melding krijg je altijd. Ik weet niet precies wat de optie -f doet, maar deze staat in ieder geval hiervoor:
    Code:
    -f      Probeer door te gaan als de integriteitstest faalt
    Wat betreft de oplossing, mysql en apache dient niet te worden gebuild met apt-get. Dan gaat DA het niet fijn vinden. Volgens mij heeft Randy deze packages ge-removed en een rebuild gedaan met custombuild. Correct me if I am wrong.

  13. #13
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    6.041 Berichten
    Ingeschreven
    23/10/04

    Locatie
    Amersfoort

    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    171 Berichten zijn liked


    Functie: Freelance IT Professional
    URL: localhost
    View randytenhave's profile on LinkedIn

    Citaat Oorspronkelijk geplaatst door Serveo Bekijk Berichten
    Klopt, die melding krijg je altijd. Ik weet niet precies wat de optie -f doet, maar deze staat in ieder geval hiervoor:
    Code:
    -f      Probeer door te gaan als de integriteitstest faalt
    Wat betreft de oplossing, mysql en apache dient niet te worden gebuild met apt-get. Dan gaat DA het niet fijn vinden. Volgens mij heeft Randy deze packages ge-removed en een rebuild gedaan met custombuild. Correct me if I am wrong.
    CB gaat je ook niet mer helpen dan. In dit geval een deel van de initiële set-up opnieuw moeten doen (MySQL gedeelte).
    Beetje OT, maar voor de gebruikers van CentOS5: Er staan enkele pakketjes voor u klaar straks.
    MultiMaak - Voor persoonlijke cadeau's en relatiegeschenken!

  14. #14
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    -f, --fix-broken
    Fix; attempt to correct a system with broken dependencies in place. This option, when used with install/remove, can omit any packages to permit APT to deduce a likely solution. Any Package
    that are specified must completely correct the problem. The option is sometimes necessary when running APT for the first time; APT itself does not allow broken package dependencies to exist
    on a system. It is possible that a system´s dependency structure can be so corrupt as to require manual intervention (which usually means using dselect(8) or dpkg --remove to eliminate some
    of the offending packages). Use of this option together with -m may produce an error in some situations. Configuration Item: APT::Get::Fix-Broken.
    Maar zonder de -f optie zie je ook wat apt-get allemaal met zich meeneemt...

  15. #15
    mysqldump: Got error: 2002
    geregistreerd gebruiker
    6.041 Berichten
    Ingeschreven
    23/10/04

    Locatie
    Amersfoort

    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    171 Berichten zijn liked


    Functie: Freelance IT Professional
    URL: localhost
    View randytenhave's profile on LinkedIn

    -f moet -s zijn... mijn fout. Foei, en ik ben nog wel UCP.
    MultiMaak - Voor persoonlijke cadeau's en relatiegeschenken!

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics