Likes Likes:  0
Resultaten 1 tot 14 van de 14
Geen
  1. #1
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter

    query met te veel resultaten = error 500

    Ik stel vast dat wanneer een query meer dan ongeveer 6500 records teruggeeft, ik een error 500 krijg.

    Gaat hier om een up-to-date da-server (mysql, suphp, apache)

    Een out-of-memory issue?
    Al veel gegoogled, gespeeld met my.cnf en php.ini, maar ik geraak er niet uit.

    Server heeft een gemiddelde load < 0.1 (2 cpu's), dus 't is niet dat ik ergens tegen hardware limieten ofzo kom.

    Iemand suggesties? Welke waarden kan ik verhogen om toch query's te kunnen laten draaien die zo'n 10000 records teruggeven?

  2. #2
    query met te veel resultaten = error 500
    Meneer de Directeur
    12.253 Berichten
    Ingeschreven
    11/05/04

    Locatie
    Valkenswaard / Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 17186890

    Is het eventueel mogelijk om de query te posten?

  3. #3
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Dank je wel voor je snelle antwoord!

    Gaat om een simpele:
    $query = "SELECT * FROM contacten ORDER by naam, voornaam ASC";

    Deze ging perfect tot er zo'n 6500 records in de database zaten. Plots doet ie 't nie meer en krijg ik een error 500... Verander ik de query zodat ie minder resultaten geeft; probleem opgelost.

  4. #4
    query met te veel resultaten = error 500
    Meneer de Directeur
    12.253 Berichten
    Ingeschreven
    11/05/04

    Locatie
    Valkenswaard / Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 17186890

    Op zo'n query vastlopen is wel heel vreemd, het zal iig niet liggen dat de query niet optimaal is

  5. #5
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    1.674 Berichten
    Ingeschreven
    15/02/04

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Geen max. tijd van je php/apache process?

  6. #6
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    96 Berichten
    Ingeschreven
    08/03/06

    Locatie
    Den Haag

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Probeer de query eens in phpMyAdmin. Dan weet je of het aan je script ligt of dat er toch iets in de database mis is...

  7. #7
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Goeie tip om het inderdaad eens in phpMyAdmin te proberen. Weten we idd direct of het een mysql of php probleem is...

    In phpMyAdmin geen enkel probleem om de query uit te voeren. Duurde 0.02 seconden.

    Ondertussen kwam ik erachter dat mijn wijzigingen in php.ini niks uitmaakten. Zelfs even engine op "off" zetten haalde niks uit. php bleef in dit geval gewoon z'n ding doen. Nochthans steeds netjes apache herstart na elke wijziging. Was ik misschien in de verkeerde php.ini bezig? Heb er nl. 3 gevonden:

    /usr/local/etc/php5/cgi/php.ini
    /usr/local/directadmin/custombuild/php-5.2.6/php.ini-recommended
    /usr/local/directadmin/custombuild/php-5.2.6/php.ini-dist

    In alle 3 even geprobeerd om engine op off te zetten om direct te kunnen zien welke de goeie is; maar bij geen van de 3 enig effect... Iemand suggesties? Want wellicht is het probleem op te lossen door php een beetje meer geheugen te geven.

    Ik heb een custombuild installatie met php in cgi mode (suphp dus).

    En Peter, nee; de max. tijd is het probleem niet. Ik krijg die error 500 onmiddelijk te zien. Niet na een time-out...
    Laatst gewijzigd door Christophe1; 08/04/09 om 00:50. Reden: + antwoord aan Peter

  8. #8
    query met te veel resultaten = error 500
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    die error 500 gaat als je met suphp werkt ook gepaard met een log entry in je error_log
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  9. #9
    query met te veel resultaten = error 500
    moderator
    4.784 Berichten
    Ingeschreven
    04/11/05

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    12 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: 0475284162

    even in je error log kijken naar de exacte melding waardoor het fout loopt. Daar zou je normaal wel wijzer moeten van worden.

  10. #10
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Het ziet ernaar uit dat ik geen error_log meer heb. Staat nochthans in m'n php.ini dat ie effectief daar moet loggen. Nog een teken dat er op wijst dat die php.ini dus effectief niet gebruikt lijkt te worden...

    Nochthans een vrij standaard custombuild server waarbij alles up-to-date is en verder eigenlijk alles prima werkt.

  11. #11
    query met te veel resultaten = error 500
    Professional
    3.115 Berichten
    Ingeschreven
    05/02/05

    Locatie
    Alkmaar

    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    101 Berichten zijn liked


    Naam: Thomas
    Registrar SIDN: JA
    ISPConnect: Lid
    KvK nummer: 76706966

    Anders even kijken in je phpinfo(); de locatie van php.ini staat in het bovenste blok.

    Kijk je overigens ook in de juiste error log? Zie /var/log/httpd/domains/ en niet /var/log/httpd/error_log.

  12. #12
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Shame on me... Ik keek inderdaad in de verkeerde logs. Alweer veel bij geleerd, waarvoor dank!

    Wat zie ik daar;
    ModSecurity: Output filter: Response body too large (over limit of 524288, total not specified)

    En via phpinfo() ook gezien dat de gebruikte php.ini deze is:
    /usr/local/etc/php5/cgi/php.ini

    Wel vreemd dat wanneer ik in die file bv engine = On verander naar engine = Off en vervolgens apache herstart, alles doodleuk blijft draaien?

    Enig idee waar ik die limiet van 524288 (bytes?) kan verhogen?

    Super bedankt trouwens allemaal voor de hulp!
    Laatst gewijzigd door Christophe1; 08/04/09 om 20:34. Reden: typefoutjes

  13. #13
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Nevermind, probleem opgelost!

    Super bedankt allemaal om me op weg te helpen!!

    De oplossing:
    In /etc/modsecurity/modsecurity-rules-selected-by-web4host.net.conf
    op zoek gaan naar SecResponseBodyLimit om de waarde ernaast te verhogen.

    Even apache herstarten en klaar

  14. #14
    query met te veel resultaten = error 500
    geregistreerd gebruiker
    3.709 Berichten
    Ingeschreven
    22/05/05

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    24 Berichten zijn liked


    Naam: Jeroen

    Ik las je topic en mijn 1e vermoeden was modsecurity, goed dat het is opgelost.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics