Likes Likes:  0
Resultaten 1 tot 5 van de 5
  1. #1
    DA sluit apache niet goed af bij dagelijkse Tally
    geregistreerd gebruiker
    30 Berichten
    Ingeschreven
    03/05/04

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    DA sluit apache niet goed af bij dagelijkse Tally

    Bijna elke avond wanneer DirectAdmin de "Tally" doet rond 00:10, kan DA apache niet herstarten. Het probleem is blijkbaar dat apache niet goed afsluit, en het apache process poort 80 in gebruikt blijft houden. Wanneer DA apache probeert te herstarten lukt dit dus niet, omdat poort 80 al in gebruik is...

    Hier is een oud helpdocument wat het probleem omschrijft: http://help.directadmin.com/item.php?id=31
    De gegeven oplossing daar klinkt goed, maar de paths/bestanden die er genoemd worden zijn niet beschikbaar. Ook staan er geen commando's bij voor een Debian OS, alleen redhat/freebsd.

    Uiteraard is het niet te doen om elke avond handmatig het apache process te killen en apache opnieuw te starten, maar onze hosting was zo vriendelijk om min of meer "It's not our problem" te zeggen, dus tja... hopelijk weet iemand hier de oplossing. Het lijkt me dat dit probleem zich vaker voordoet, ik heb het zelf al 2x eerder gezien. Dat werd toen opgelost met de verwijdering van DA, maar dat kan ik in dit geval helaas niet doen.

    Any hulp is welkom, misschien is er een nieuwe manier om hetzelfde te doen wat wordt aangeraden op die oude directadmin helppagina?


    Hieronder nog enkele log entries en console commando's met de errors:
    Code:
    DA System log:
    2009:02:21-00:10:06: Tally All Begin
    2009:02:21-00:10:06: Tally Reseller admin Begin
    2009:02:21-00:10:06: Tally User acweb Begin
    2009:02:21-00:10:12: Tally User acweb Complete
    2009:02:21-00:10:12: Tally User admin Begin
    2009:02:21-00:10:13: Tally User admin Complete
    2009:02:21-00:10:13: Tally Reseller admin Complete
    2009:02:21-00:10:13: Tally All Complete
    Hier hoort dus nog een "httpd restarted" melding onder te staan maar die mist.
    
    DA Errortask log:
    2009:02:21-05:41:11: service httpd didn't start, re-starting it
    2009:02:21-05:41:12: Error restarting service httpd : uid 0 gid 0 : /etc/init.d/httpd restart >>/dev/null 2>>/dev/null
    2009:02:21-05:42:01: service httpd wasn't running, starting it
    2009:02:21-05:42:01: Error starting service httpd : uid 0 gid 0 : /etc/init.d/httpd start >>/dev/null 2>>/dev/null
    2009:02:21-05:42:11: service httpd didn't start, re-starting it
    2009:02:21-05:42:11: Error restarting service httpd : uid 0 gid 0 : /etc/init.d/httpd restart >>/dev/null 2>>/dev/null
    Dit blijft zich continue herhalen enz enz...
    
    
    Console commando's en errors:
    # apachectl restart
    httpd not running, trying to start
    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    
    Zoek processes met poort 80 in gebruik:
    # lsof -i :80
    COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
    h 6617 apache 4u IPv6 527364 TCP *:www (LISTEN)
    
    Kill process:
    # kill -9 6617
    
    Restart apache:
    # apachectl restart
    httpd not running, trying to start
    
    Apache en de website draaien hierna weer, tot de volgende
    Tally waarbij apache weer niet goed afgesloten wordt.

  2. #2
    DA sluit apache niet goed af bij dagelijkse Tally
    Service/Support = Heilig
    845 Berichten
    Ingeschreven
    18/08/07

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    42 Berichten zijn liked


    Naam: Maikel
    Bedrijf: Vertixo B.V.
    URL: www.vertixo.com
    Registrar SIDN: JA
    KvK nummer: 53940628
    TrustCloud: vertixo
    View vertixo's profile on LinkedIn

    Over welke versie van DA hebben we het hier?

  3. #3
    DA sluit apache niet goed af bij dagelijkse Tally
    geregistreerd gebruiker
    178 Berichten
    Ingeschreven
    28/05/08

    Locatie
    Purmerend

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 54885353
    Ondernemingsnummer: nvt

    Ik heb het probleem ook gehad bij 1 van de webservers. Er draait waarschijnlijk nog een https taak. Je kan het beste doen is het stop en start script een kill -9 uitvoeren op apache of https.

  4. #4
    DA sluit apache niet goed af bij dagelijkse Tally
    geregistreerd gebruiker
    42 Berichten
    Ingeschreven
    25/11/05

    Locatie
    Hoorn

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Waarschijnlijk draait er nog een exim proces wat door php is gestart. Dit is een bekend probleem. Een oplossing op dit moment is het volgende:

    http://help.directadmin.com/item.php?id=181

  5. #5
    DA sluit apache niet goed af bij dagelijkse Tally
    geregistreerd gebruiker
    30 Berichten
    Ingeschreven
    03/05/04

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Bedankt voor de hulp en die laatste link lijkt me inderdaad een mogelijke oplossing. Ze hebben vandaag besloten de server te vervangen door een nieuwe VPS, dus hopelijk is daarmee ook dit probleem verdwenen. Maar zo niet dan zal ik die oplossing uitproberen.

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics