Bijna elke avond wanneer DirectAdmin de "Tally" doet rond 00:10, kan DA apache niet herstarten. Het probleem is blijkbaar dat apache niet goed afsluit, en het apache process poort 80 in gebruikt blijft houden. Wanneer DA apache probeert te herstarten lukt dit dus niet, omdat poort 80 al in gebruik is...
Hier is een oud helpdocument wat het probleem omschrijft: http://help.directadmin.com/item.php?id=31
De gegeven oplossing daar klinkt goed, maar de paths/bestanden die er genoemd worden zijn niet beschikbaar. Ook staan er geen commando's bij voor een Debian OS, alleen redhat/freebsd.
Uiteraard is het niet te doen om elke avond handmatig het apache process te killen en apache opnieuw te starten, maar onze hosting was zo vriendelijk om min of meer "It's not our problem" te zeggen, dus tja... hopelijk weet iemand hier de oplossing. Het lijkt me dat dit probleem zich vaker voordoet, ik heb het zelf al 2x eerder gezien. Dat werd toen opgelost met de verwijdering van DA, maar dat kan ik in dit geval helaas niet doen.
Any hulp is welkom, misschien is er een nieuwe manier om hetzelfde te doen wat wordt aangeraden op die oude directadmin helppagina?
Hieronder nog enkele log entries en console commando's met de errors:
Code:DA System log: 2009:02:21-00:10:06: Tally All Begin 2009:02:21-00:10:06: Tally Reseller admin Begin 2009:02:21-00:10:06: Tally User acweb Begin 2009:02:21-00:10:12: Tally User acweb Complete 2009:02:21-00:10:12: Tally User admin Begin 2009:02:21-00:10:13: Tally User admin Complete 2009:02:21-00:10:13: Tally Reseller admin Complete 2009:02:21-00:10:13: Tally All Complete Hier hoort dus nog een "httpd restarted" melding onder te staan maar die mist. DA Errortask log: 2009:02:21-05:41:11: service httpd didn't start, re-starting it 2009:02:21-05:41:12: Error restarting service httpd : uid 0 gid 0 : /etc/init.d/httpd restart >>/dev/null 2>>/dev/null 2009:02:21-05:42:01: service httpd wasn't running, starting it 2009:02:21-05:42:01: Error starting service httpd : uid 0 gid 0 : /etc/init.d/httpd start >>/dev/null 2>>/dev/null 2009:02:21-05:42:11: service httpd didn't start, re-starting it 2009:02:21-05:42:11: Error restarting service httpd : uid 0 gid 0 : /etc/init.d/httpd restart >>/dev/null 2>>/dev/null Dit blijft zich continue herhalen enz enz... Console commando's en errors: # apachectl restart httpd not running, trying to start (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs Zoek processes met poort 80 in gebruik: # lsof -i :80 COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME h 6617 apache 4u IPv6 527364 TCP *:www (LISTEN) Kill process: # kill -9 6617 Restart apache: # apachectl restart httpd not running, trying to start Apache en de website draaien hierna weer, tot de volgende Tally waarbij apache weer niet goed afgesloten wordt.

Likes:


Quote