Likes Likes:  0
Resultaten 1 tot 7 van de 7
  1. #1
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter

    Cronjobs werken meestal wel, maar toch niet altijd

    Hallo iedereen,

    Iemand al het probleem gehad dat de cronjobs meestal wel werken, maar toch niet altijd?

    Zo maak ik elke nacht een automatische backup van 3 resellers:
    - reseller 1 om 2u
    - reseller 2 om 2u30
    - reseller 3 om 3u

    Elke nacht is er wel eentje van die 3 die niet gebackuped werd. Welke het is, is steeds een verrassing. Zit geen systeem in. In de logs wordt hierover niks vermeld. Geen errors.

    Na als test enkele crons te hebben toegevoegd kan ik ook alleen maar vaststellen dat ze de ene keer effectief worden uitgevoerd en de andere keer niet...

    Gaat om een recent geïnstalleerde en steeds up-to-date gehouden server met daarop Debian 4.0 en directadmin custombuild. Draait verder perfect met een load die nooit boven 0.1 komt.

    Mocht iemand een oplossing hebben of weten waar te zoeken?

    Alvast bedankt!

  2. #2
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    Christophe,

    Om hoeveel users / data gaat het met betrekking tot iedere reseller? Interval van 30 min. is relatief weinig, in die zin dat reseller 1 nog niet klaar hoeft te zijn wanneer reseller 2 begint.

    Wat gebeurt er wanneer je de reseller backups vervangt door 1 admin backup?
    Daarnaast, wat staat er in de logs?

  3. #3
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Dank je wel voor het snelle antwoord!

    Reseller 1 heeft ongeveer 60 users en 2.5GB aan data. Deze backup duurt maar maximum 4 minuten.

    Reseller 2 heeft slechts ongeveer 10 users met 500MB aan data. Deze backup duurt amper een minuut.

    Reseller 3 heeft momenteel slechts 2 users met enkel een url forward. Backup duurt dan ook minder dan een minuut.

    Deze keer bv ging het allemaal goed. In de logs vind ik:

    /var/log/syslog:

    Jan 17 02:00:01 da /USR/SBIN/CRON[23421]: (root) CMD (/usr/local/directadmin/dataskq)
    Jan 17 02:00:01 da /USR/SBIN/CRON[23423]: (diradmin) CMD (echo -e "action=backup&id=1&owner=reseller1" >> /usr/local/directadmin/data/task.queue.da; /bin/chmod 600 /usr/local/directadmin/data/task.queue.da)

    /var/log/directadmin/system.log:

    2009:01:17-02:00:01: Running Backup: type=reseller owner=reseller1 id=1

    Net nu een socket write error, 'k weet niet of dit er iets mee te maken heeft. Wellicht niet aangezien deze keer alles goed ging.

    /var/log/directadmin/error.log:
    2009:01:17-02:00:29: Socket write error: Unknown error

    Benieuwd hoe het straks met de andere 2 backups zal gaan. Ik hou je op de hoogte.

    Admin backups heb ik nog niet gemaakt. Ik test het even uit.

    Misschien ook interessant om weten dat een cronjob van een user dezelfde problemen kent. De ene keer gaat alles goed, de andere keer niet...

  4. #4
    Cronjobs werken meestal wel, maar toch niet altijd
    WHT member
    174 Berichten
    Ingeschreven
    20/09/07

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30224720
    Ondernemingsnummer: nvt

    Maak je je backups lokaal of upload je die?
    Dat zou natuurlijk ook nog bovenop je backup time kunnen komen.

    Daarnaast raad ik net als Geert-Jan admin-backup aan. Alles in 1 keer en niet extra backup jobs aanmaken wanneer er een nieuwe reseller bijkomt.

  5. #5
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    384 Berichten
    Ingeschreven
    03/08/03

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24360130
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door INEXPro Bekijk Berichten
    Maak je je backups lokaal of upload je die?
    Dat zou natuurlijk ook nog bovenop je backup time kunnen komen.

    Daarnaast raad ik net als Geert-Jan admin-backup aan. Alles in 1 keer en niet extra backup jobs aanmaken wanneer er een nieuwe reseller bijkomt.
    Opzich zouden die processen toch prima naast elkaar kunnen draaien in het geval dat ééntje toch niet helemaal klaar is?

  6. #6
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Bedankt voor alle suggesties!

    Ik maak de backups lokaal.

    Ondertussen heb ik een aantal dingen geprobeerd:
    - http://help.directadmin.com/item.php?id=107
    - http://help.directadmin.com/item.php?id=173
    - mogelijkheid om cron jobs te gebruiken voor elke reseller even uitgezet en weer aangezet.

    Afgelopen nacht zijn alles cronjobs prima uitgevoerd geweest. Ik hoop dat het voortaan goed blijft gaan...

    Beetje moeilijk om een echte oplossing te vinden omdat ik dus nog steeds het echte probleem niet heb gevonden. Meestal werkt alles eigenlijk gewoon goed. En wanneer het dan es niet lukt, lees ik niks speciaals in de logs. Geen foutmeldingen in elk geval.

  7. #7
    Cronjobs werken meestal wel, maar toch niet altijd
    geregistreerd gebruiker
    57 Berichten
    Ingeschreven
    25/02/08

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 0863643458

    Thread Starter
    Probleem jammer genoeg nog niet opgelost. Bij reseller1 en reseller3 verloopt alles normaal. Bij Reseller2 worden de crons meestal niet uitgevoerd. Soms es wel.

    Ik overweeg om een nieuwe reseller account aan te maken en alle klanten over te brengen naar die nieuwe account.

    Anderzijds zou ik het probleem liever oplossen dan omzeilen. Ik kan me ook niet voorstellen dat ik de énige DA gebruiker ben die ooit met dit probleem is geconfronteerd geweest? Niemand suggesties?

    De dataskq wordt effectief telkens uitgevoerd op de minuut dat de cron job zou moeten uitgevoerd worden, dus daar ligt het alvast niet aan.

    Verder zijn alle rechten opnieuw ingesteld en zie ik geen foutmeldingen in de logs.

    Niet alleen de reseller backups lopen fout, maar ook andere crons van users van deze reseller.

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics