Ik ben een redelijke nieuwe gebruiker van DirectAdmin. Heb sinds enkele dagen een eigen server met debian en DA i.c.m APF. Alles werkt prima behalve de mailserver(dovecot). Deze ontvangt wel mailtjes maar stuurt deze niet door. Ze blijven hangen in het systeem. Nu denk ik dat dit te maken heeft met een probleem in perl. Namelijk als ik DA naar Mail Queue Administration ga zie ik daar 3 pagina's met mailtjes die zijn blijven hangen. Als ik dan een van die mailtjes selecteer en op retry klik krijg ik de volgende foutmelding van DA :
List processed
Details
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Dit duid denk ik op een probleem met de locales van perl. Door wat te googlen kwam ik erachter dat je middels dpkg-reconfigure locales de boel kon fixen. In dpkg-reconfigure locales heb ik alle NL en EN_US pakketen geselecteerd. En vervolgens EN_US als standaard gezet. Dit mag niet baten nog steeds krijg ik dezelfde error. Een andere oplossing die ik kon vinden was het handmatig zetten van de locals middels:
export LANG=EN_US
export LANGUAGE=EN_US
Vervolgens typ ik perl -e 'print "Hallo!\n";' in en daarvan krijg ik een normale tekst terug met Hallo!. Maar helaas de mailserver doet het nog niet en krijg ik de dezelfde foutmelding. Heeft iemand ervaring met dit probleem of eventuele ervaring met de locales van perl ?
Dank in iedergeval voor iedere reactie.

Likes:


Quote