Likes Likes:  0
Resultaten 1 tot 14 van de 14
  1. #1
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter

    Acces denied da_admin

    Hee WHT-ers,

    Als eerste: ik gebruik Debian 4.0

    Gisteren had ik het wachtwoord van da_admin gewijzigd, in de usr/local/directadmin/conf/mysql.conf, maar dat pakt niet helemaal goed uit blijkt.
    Bij de automatische back-up:
    Error connecting to MySQL: Access denied for user 'da_admin'@'localhost' (using password: YES)
    <b>Repair guide: <a target=_blank href='http://help.directadmin.com/item.php?id=45'>http://help.directadmin.com/item.php?id=45</a></b>
    En dat meerdere keren.
    Tevens kan ik niet inloggen met het da_admin account in phpMyAdmin.
    Enfin, ik dacht, er staat een oplossing bij, dat 'roggelen we wiel', maar niet dus.
    Onder Debian loopt dat niet echt goed.
    Ik stop eerst de mysql service en start dan weer MySQL met --skip-grant-tables. (/etc/init.d/mysqld start --skip-grant-tables), maar als ik dan de stap "use mysql" uitvoer (in Debian is dat, als ik het goed heb mysql> USE mysql), krijg ik een error:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    Wat doe ik verkeerd en vooral: hoe los ik het op :-)

    Bedankt vast

  2. #2
    Acces denied da_admin
    geregistreerd gebruiker
    600 Berichten
    Ingeschreven
    15/09/07

    Locatie
    Uden

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Robin Bohnen
    Registrar SIDN: Ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Dat wachtwoord had je niet moeten veranderen
    Dit kan je volgens om het weer op te lossen:

    http://help.directadmin.com/item.php?id=45

    Zit je wel echt in de commandline mysql? Ben je het &'etje niet vergeten?
    Anders werkt use mysql niet, dat is om de juiste database te selecteren.
    Laatst gewijzigd door RobinJB; 14/02/08 om 09:13. Reden: Automerged Dubbelpost

  3. #3
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Dat had ik door inderdaad
    Ja, die stappen werken niet helemaal op Debian, lijkt zo althans, da's het probleem.
    Ik zal straks nog even controleren of ik het wel goed getypt had. Vanaf m'n telefoon ga ik zoiets niet doen.

  4. #4
    Acces denied da_admin
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    in ssh:
    root@server#passwd admin

    zou moeten werken.....

    EDIT:: lees er overheen, PHP_MyADMIN werd gevraagt...
    Laatst gewijzigd door Geert-Jan; 14/02/08 om 11:32. Reden: Automerged Dubbelpost

  5. #5
    Acces denied da_admin
    geregistreerd gebruiker
    442 Berichten
    Ingeschreven
    13/02/08

    Locatie
    rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 24363286
    Ondernemingsnummer: nvt

    al geprobeerd mysql te reloaden met het nieuwe password ?

  6. #6
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door RobinJB Bekijk Berichten
    Dat wachtwoord had je niet moeten veranderen
    Dit kan je volgens om het weer op te lossen:

    http://help.directadmin.com/item.php?id=45

    Zit je wel echt in de commandline mysql? Ben je het &'etje niet vergeten?
    Anders werkt use mysql niet, dat is om de juiste database te selecteren.
    Ik stop 'm eerst:
    /etc/init.d/mysqld stop
    Dan:
    /etc/init.d/mysqld start --skip-grant-tables &
    Dan krijg ik dit te zien:
    [/quote] [1] 9098
    webserver01:/home/admin# Starting mysqld: [ OK ]

    [/quote]
    En dus ook een lege rij, waar ik waarschijnlijk iets in moet voeren.
    Daar voer ik dus "use mysql" in:
    webserver01:/home/admin# Starting mysqld: [ OK ]
    use mysql
    bash: use: command not found
    [1]+ Done /etc/init.d/mysqld start --skip-grant-tables
    webserver01:/home/admin#
    Dat is het dus niet, voer ik dan dus: mysql> USE mysql in dan krijg ik:
    webserver01:/home/admin# Starting mysqld: [ OK ]
    mysql> USE mysql
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    [1]+ Done /etc/init.d/mysqld start --skip-grant-tables
    webserver01:/home/admin#
    Verder als daar kom ik dus al niet eens... Beetje vreemd dit

  7. #7
    Acces denied da_admin
    geregistreerd gebruiker
    442 Berichten
    Ingeschreven
    13/02/08

    Locatie
    rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 24363286
    Ondernemingsnummer: nvt

    indien je nog in mysql kan komen met het oude wachtwoord

    dan zou je toch dit kunnen doen

    bij sql querie ?
    GRANT ALL PRIVILEGES ON *.* TO da_admin@localhost IDENTIFIED BY 'newdapass' WITH GRANT OPTION;
    FLUSH PRIVILEGES;

  8. #8
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door umf Bekijk Berichten
    indien je nog in mysql kan komen met het oude wachtwoord

    dan zou je toch dit kunnen doen

    bij sql querie ?
    GRANT ALL PRIVILEGES ON *.* TO da_admin@localhost IDENTIFIED BY 'newdapass' WITH GRANT OPTION;
    FLUSH PRIVILEGES;
    Tja, ik moet heel eerlijk bekennen dat ik dacht dat het zo gewijzigd was en geen gevolgen zou hebben. Daarom weet ik helaas het oude wachtwoord ook niet. Heel dom om het nergens op te schrijven

  9. #9
    Acces denied da_admin
    geregistreerd gebruiker
    5.783 Berichten
    Ingeschreven
    20/02/05

    Locatie
    Haaksbergen / Amsterdam

    Post Thanks / Like
    Mentioned
    45 Post(s)
    Tagged
    0 Thread(s)
    168 Berichten zijn liked


    Naam: Mark Scholten
    Bedrijf: SinnerG / Stream Service
    Functie: Systeembeheerder
    URL: www.sinnerg.nl
    Registrar SIDN: ja
    KvK nummer: 34255993

    Heb je het oude wachtwoord nog? (Bijv. ergens op papier of in een email of op een andere methode.) Zo ja dan zou je het oude wachtwoord terug kunnen zetten en als dat niet werkt kun je eventueel bellen/contact op een andere methode opnemen en kan ik het eventueel wel even regelen. Oude wachtwoord is namelijk niet gewijzigd voor MySQL zelf (kan eventueel via PHPMyAdmin).
    Tools die handig zjn voor ISPs vind je natuurlijk bij Tools 4 ISP.

  10. #10
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door Mark17 Bekijk Berichten
    Heb je het oude wachtwoord nog? (Bijv. ergens op papier of in een email of op een andere methode.) Zo ja dan zou je het oude wachtwoord terug kunnen zetten en als dat niet werkt kun je eventueel bellen/contact op een andere methode opnemen en kan ik het eventueel wel even regelen. Oude wachtwoord is namelijk niet gewijzigd voor MySQL zelf (kan eventueel via PHPMyAdmin).
    Ben nu ook al druk aan het zoeken of die niet tóch ergens op papier staat. Ik hoop 't maar ;-)

  11. #11
    Acces denied da_admin
    geregistreerd gebruiker
    5.783 Berichten
    Ingeschreven
    20/02/05

    Locatie
    Haaksbergen / Amsterdam

    Post Thanks / Like
    Mentioned
    45 Post(s)
    Tagged
    0 Thread(s)
    168 Berichten zijn liked


    Naam: Mark Scholten
    Bedrijf: SinnerG / Stream Service
    Functie: Systeembeheerder
    URL: www.sinnerg.nl
    Registrar SIDN: ja
    KvK nummer: 34255993

    Citaat Oorspronkelijk geplaatst door Luke B Bekijk Berichten
    Tja, ik moet heel eerlijk bekennen dat ik dacht dat het zo gewijzigd was en geen gevolgen zou hebben. Daarom weet ik helaas het oude wachtwoord ook niet. Heel dom om het nergens op te schrijven
    Je hebt het nog niet eerder gedaan neem ik aan. Dan komt het wachtwoord overeen met het eerste wachtwoord voor DirectAdmin als ik me niet vergis.
    Tools die handig zjn voor ISPs vind je natuurlijk bij Tools 4 ISP.

  12. #12
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Inderdaad, ik heb het nog eerder gedaan.
    En waar ZOU ik die kunnen vinden?

  13. #13
    Acces denied da_admin
    geregistreerd gebruiker
    5.783 Berichten
    Ingeschreven
    20/02/05

    Locatie
    Haaksbergen / Amsterdam

    Post Thanks / Like
    Mentioned
    45 Post(s)
    Tagged
    0 Thread(s)
    168 Berichten zijn liked


    Naam: Mark Scholten
    Bedrijf: SinnerG / Stream Service
    Functie: Systeembeheerder
    URL: www.sinnerg.nl
    Registrar SIDN: ja
    KvK nummer: 34255993

    Citaat Oorspronkelijk geplaatst door Luke B Bekijk Berichten
    Inderdaad, ik heb het nog eerder gedaan.
    En waar ZOU ik die kunnen vinden?
    Het probleem bij Luke is net opgelost. Voor de overige gebruikers:
    Eerste wachtwoord voor da_admin (MySQL user) is gelijk aan het eerste admin wachtwoord bij DirectAdmin. Deze is te vinden in: /var/log/directadmin/install.log
    Code:
    Admin username:   admin
    Admin password:   [hier staat het wachtwoord normaal gesproken]
    Admin email:      [admin email, bijv: admin@server08.streamservice.nl]
    Tools die handig zjn voor ISPs vind je natuurlijk bij Tools 4 ISP.

  14. #14
    Acces denied da_admin
    Telahosting
    581 Berichten
    Ingeschreven
    22/02/07

    Locatie
    Druten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 11069830
    Ondernemingsnummer: nvt

    Thread Starter
    Nog even verdere uitbreiding op bovenstaande oplossing:
    Als je het wachtwoord gevonden hebt ga je phpMyAdmin in.
    Dan ga je naar Privileges (of Rechten), dan klik je op de 'd'.
    Nu selecteer je da_admin en kun je bij Change Password een nieuw wachtwoord ingeven.
    Dat zou het moeten doen!

    Nogmaals bedankt Mark!

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics