Thanks for the report.
I checked our centos 4.4 box and everything is running correctly over the network file system.
I extracted the es4.4 update.tar.gz and can confirm that it did not compress correctly. Why exactly, I can't say for sure, but I've recompressed it, double checked it's contents and it's appears to be fine now. The package is now updated, so for anyone affected (only looks like the 4.4 package), you can run this guide to get the new update.tar.gz:
http://help.directadmin.com/item.php?id=29
Note that tar did not return any errors when the bad package was created, so the problem was likely the network file system not giving all the data it should have. I'll keep an eye out for anything else.
Note, some people who have a 4.4 system are actually using the 4.0 package which is fine, hence you're not affected.
John