Beste WHT-ers,
Bij deze heb ik 3 vragen aan jullie, hopelijk kunnen jullie beiden beantwoorden. Het gaat om een CentOS 4.4 (final) systeem incl. het DirectAdmin controle paneel.
Ten eerste
Ten tweedeMomenteel draai ik een server met mod_ruid2 incl. apache2. Echter is er een fout met de mail(); functie; namelijk de return-path, de gebruikers zouden graag bij return-path hun eigen adres willen kunnen invullen dit is nu door mod_ruid2 niet mogelijk aangezien de gebruikers niet in de 'trusted_users' lijst staan in de exim.conf. Wanneer ik hun hieraan toevoeg kunnen ze wel de return-path wijzigen zonder problemen voor hun mail-scripts.
Hoe is dit op te lossen zodat ik en mod_ruid2 kan blijven draaien en alle gebruikers gewoon de return-path kunnen aanpassen. Dit aangezien ze nu user@hostname krijgen te zien.
Ten derdeDit probleem is hier al eens besproken en toen had ik dit opgelost met een soort van iFrame, dit werkt echter niet perfect en daarom vraag ik jullie voor een betere oplossing. Het gaat om de symlink /webmail voor gebruikers. Deze stuurt men door naar /var/www/html/webmail echter krijgt men dan dus een fout te zien (door mod_ruid2). Hoe is dit het beste op te lossen? Ik heb het nu doorgestuurd via een header(); maar voor resellers die white-label willen is dit niet handig. Aangezien hun klanten naar ons IP-adres worden verstuurd ipv hun eigen IP-adres.
Alvast bedankt!In ProFTPD loopt de tijd 1 uur achter, op het systeem zelf is het wel goed (als ik 'date' intyp) en ook in PHP verwerkt hij de goede tijdzone. Kan ik ergens in de config van ProFTPD de tijd op GMT+1 zetten, ik denk zelf namelijk dat het daaraan ligt (en dat hij nu dus op GMT staat).

Likes:


Quote