Likes Likes:  0
Resultaten 1 tot 8 van de 8
Geen

Onderwerp: Php4 / Php5

  1. #1
    Php4 / Php5
    geregistreerd gebruiker
    47 Berichten
    Ingeschreven
    05/11/06

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Jeffrey Rooijmans
    Bedrijf: JSR IT B.V.
    Functie: CEO
    URL: www.jsr-it.nl
    Registrar SIDN: Ja
    KvK nummer: 53966295
    Ondernemingsnummer: nvt

    Thread Starter

    Php4 / Php5

    Hallo,

    Ik heb de volgende howto uitgevoerd:
    http://www.webhostingtalk.nl/directa...hp5-suphp.html (HOWTO: Centos, apache 2, php4, php5 & suphp)

    Echter krijg ik op het einde, als alles goed gaat bij elke php bestand, een internel server error.

    Het is op een test locatie, dus zo'n super probleem is het niet. Maar ik wil het wel graag werkend hebben.

    Weet iemand een mogelijk probleem?

    EDIT:
    Wanneer ik via een domein een php bestand opvraag, word deze als platte tekst weergegeven :s ...

    Weet iemand een oplossing?

    PHP4.4.4 en PHP 5.1.5


    Met vriendelijke groet,
    J. Rooijmans

  2. #2
    Php4 / Php5
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    wat zijn de rechten van de files ? En welke gebruiker / group staat er bij. Als dit niet gelijk is aan wat er in het vhost configuratie staat krijg je ook die errors.
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  3. #3
    Php4 / Php5
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Geef anders een link van deze bestanden zodat wij het zelf kunnen zien. Wellicht is een oplossing dan sneller gevonden.

  4. #4
    Php4 / Php5
    geregistreerd gebruiker
    47 Berichten
    Ingeschreven
    05/11/06

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Jeffrey Rooijmans
    Bedrijf: JSR IT B.V.
    Functie: CEO
    URL: www.jsr-it.nl
    Registrar SIDN: Ja
    KvK nummer: 53966295
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb het opnieuw geinstalleerd, enkel zonder die handleiding.
    PHP4.4.4 werkt
    enkel php 5 niet. Ik heb php 5.2.0 geinstalleerd, als ik op root niveau php --version doe, zie ik php 5.2.0. Dat werkt dus.

    Dit heb ik in mijn httpd.conf staan:
    ....
    LoadModule php4_module /usr/lib/apache/libphp4.so
    LoadModule php5_module /usr/lib/apache/libphp5.so
    ....
    AddModule mod_php4.c
    AddModule mod_php5.c
    ....
    AddType application/x-httpd-php4 .inc .php .php4 .php3 .phtml
    AddType application/x-httpd-php5 .php5
    AddType application/x-httpd-php-source .phps
    ...

    Zoals ik al zei werkt php 4, php 5 niet.
    http://89.248.161.45/phpinfo.php5
    Is php5, en
    http://89.248.161.45/phpinfo.php
    php 4.

    Iemand een idee wat ik fout doe?

    EDIT:
    Wanneer ik addmodule mod_php5.c erin zet, stopt apache met draaien.
    Iemand enig idee hoe ik dit werkend krijg?
    Laatst gewijzigd door jsrit; 05/01/07 om 15:00.

  5. #5
    Php4 / Php5
    geregistreerd gebruiker
    135 Berichten
    Ingeschreven
    07/10/05

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Kijk eens in logbestanden ofzo, daar staat precies in wat er mis is.

  6. #6
    Php4 / Php5
    geregistreerd gebruiker
    47 Berichten
    Ingeschreven
    05/11/06

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Jeffrey Rooijmans
    Bedrijf: JSR IT B.V.
    Functie: CEO
    URL: www.jsr-it.nl
    Registrar SIDN: Ja
    KvK nummer: 53966295
    Ondernemingsnummer: nvt

    Thread Starter
    Apache error log:
    Code:
    *** glibc detected *** double free or corruption (fasttop): 0x082dab18 ***
    *** glibc detected *** double free or corruption (fasttop): 0x089f4f80 ***
    *** glibc detected *** double free or corruption (fasttop): 0x09431b18 ***
    *** glibc detected *** double free or corruption (fasttop): 0x09fda520 ***
    *** glibc detected *** double free or corruption (fasttop): 0x091dfb18 ***
    ect...

  7. #7
    Php4 / Php5
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    Zal aan mij liggen, maar ik heb het volgens mij nooit over AddModule mod_php5.c gehad hoor. Denk dat je nog maar eens goed door moet lezen.
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  8. #8
    Php4 / Php5
    geregistreerd gebruiker
    47 Berichten
    Ingeschreven
    05/11/06

    Locatie
    Best

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Jeffrey Rooijmans
    Bedrijf: JSR IT B.V.
    Functie: CEO
    URL: www.jsr-it.nl
    Registrar SIDN: Ja
    KvK nummer: 53966295
    Ondernemingsnummer: nvt

    Thread Starter
    Hallo,

    Inderdaad.
    Ik heb nu de howto http://www.directadmin.com/forum/sho...l+php5+fastcgi gevonden.

    Hallo,

    Nu ik het 99% werkend heb gekregen met http://www.directadmin.com/forum/sho...l+php5+fastcgi, heb ik 1 probleem.

    Ik krijg de volgende error als ik een php5 pagina opvraag:
    Code:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@****.nl and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. 
    
    
    --------------------------------------------------------------------------------
    
    Apache/1.3.34 Server at test.****.nl Port 80
    Ik heb verder niks gewijzigd, enkel wat moest.

    Hallo,

    Ik heb het opgelost, simpelweg deed het script niet automatisch de rechten correct zetten, middels opgelost.
    Laatst gewijzigd door jsrit; 05/01/07 om 22:00. Reden: Automerged Doublepost

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics