Doe je debian niet best gewoon via apt-get?Citaat:
Oorspronkelijk geplaatst door tvm
#apt-get update
#apt-get upgrade openssl
Afdrukvoorbeeld
Doe je debian niet best gewoon via apt-get?Citaat:
Oorspronkelijk geplaatst door tvm
#apt-get update
#apt-get upgrade openssl
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Helaas... Of zou dit kunnen omdat OpenSSL bij mij uit de Plesk Base Packages komt? Zo ja, kan ik dan veilig een #apt-get install openssl uitvoeren zonder mijn plesk-installatie te verkrachten (en dat straks ook de plesk updater nog gewoon werkt)?
Ook die opnieuw bouwen ;)Citaat:
Oorspronkelijk geplaatst door blaaat
Voer gewoon de commando's uit vande eerste post. Plesk is niet afhankelijk van openssl.Citaat:
Oorspronkelijk geplaatst door Citruz.
na het rebuilden van apache kom ik bij het opstarten echter de volgende error tegen:
serv01:/usr/local/directadmin/customapache# /etc/init.d/httpd start
Starting httpd: Error: Apache has not been designed to serve pages while
running as root. There are known race conditions that
will allow any local user to read any file on the system.
If you still desire to serve pages as root then
add -DBIG_SECURITY_HOLE to the EXTRA_CFLAGS line in your
src/Configuration file and rebuild the server. It is
strongly suggested that you instead modify the User
directive in your httpd.conf file to list a non-root
user.
serv01:/usr/local/directadmin/customapache#
opgelost,
was een verkeerde instelling in etc/passwd
CentOS heeft een openssl update uitgebracht. (yum update)
Waarom een script plaatsen:P je hoeft naast het certificate verder niets naders te doen. Daarnaast werkte het gebruiken van een te groot certificaat dat geen meervoud van 2 is ook redelijk goed.
Gewoon er dus voor zorgen dat hij extern (*optie in ssl/sshd) controleert op geldigheid en daarna voorals nog door zijn unix/pam gaat in plaats van jeh log maar gelijk in.
Daarentegen wil ik de mensen erop wijzen dat het hier niet alleen om SSH1 gaat maar ook om SSH2. Tenminste als je certificaat dat je maakte de zelfde processing aanging om het cert te verifieren.
Ik ga hier inderdaad niet het certificaat plakken maar google er maar eens op of kijk op milworm ;) daar stond hij heeel mooi vermeld. Misschien een tip voor jullie allemaal en voor wie milworm nog niet kende, moet zich schamen. Daar staan toch wel de meest laatste echte leaks in de hosting branch op vermeld zodat mensen uit de scene vrij makkelijk naar binnen kunnen. En voor diegenen die graag een scriptje wouden... be happy... die zit er bij ;)
8 september al, en je blijft nog steeds op 0.9.7a zitten ;) . let wel op deze is geptached.Citaat:
Oorspronkelijk geplaatst door DhoTjai
8 september al, niks van gemerkt. Ik had op 9 en 10 september yum update gedaan, maar geen openssl te bekennen.
Kijk eens of je de update channel wel gebruikt en niet alleen de base.
Help Help Help !
Ik heb alles gedaan oop rebuild apache en dan httpd restart
maar ik krijg dit error :
Starting httpd: Syntax error on line 81 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server: libssl.so.4: cannot open shared object file: No such file or directory
[FAILED]
ff 'yum update openssl' uitvoeren, dan ben je in ieder geval weer werkend.
Meeste distro's zijn inmiddels weer up-to-date
Sorry je snapt me niet.
Ik heb alles gedaan wat in je 1ste post staat.
En daarna httpd restart maar toen kreeg ik dat error.
Mijn httpd staat nu helaas uit !!
Daarna heb ik build all gedaan en dan krijg ik dit error :
chmod 755 /usr/lib/apache/libphp4.so
cp /etc/httpd/conf/httpd.conf /etc/httpd/conf/httpd.conf.bak
cp /etc/httpd/conf/httpd.conf.new /etc/httpd/conf/httpd.conf
rm /etc/httpd/conf/httpd.conf.new
Installing PHP CLI binary: /usr/local/bin/
Installing PHP CLI man page: /usr/local/man/man1/
Installing PEAR environment: /usr/local/lib/php/
/usr/local/directadmin/customapache/php-4.4.3/sapi/cli/php: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
make[1]: *** [install-pear-packages] Error 127
make: *** [install-pear] Error 2
*** The install has failed, do you want to try to install it again? (y,n):
Trouwens yum update openssl
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Could not find update match for openssl
No Packages marked for Update/Obsoletion
ik zou het erg prettig vinden als je uit je start post haalt dat je als root in kan loggen dmv een bugged cert. Dit wordt nergens beschreven, als je alles leest staat er alleen dat een een prove is geleverd dat de handeling van cert niet correct is. Niet wat er daadwerkelijk gebeurd. Dit is onnodig bang makerij!Citaat:
Oorspronkelijk geplaatst door FransVanNispen
Citaat:
Oorspronkelijk geplaatst door Arto
probeer eerst eens ./build clean