Er is opeens een probleem met Mysql opgetreden.
Ik probeer hem te restarten, reloaden, stop zetten en starten maar krijg failed melding.
MySQL PID file could not be found!
Kan iemand mij hiermee helpen?
Likes: 0
Er is opeens een probleem met Mysql opgetreden.
Ik probeer hem te restarten, reloaden, stop zetten en starten maar krijg failed melding.
MySQL PID file could not be found!
Kan iemand mij hiermee helpen?
wat is er mis met google?
http://www.google.com/search?lr=&ie=...t%20be%20found!
Heb ik al gedaan maar ik kwam er niet uit.
/etc/rc.d/init.d/mysqld restart
/etc/rc.d/init.d/mysqld reload
/etc/rc.d/init.d/mysqld stop
Helpen allemaal niet,
MySQL PID file could not be found! [FAILED]
Laatst gewijzigd door Arto; 02/04/06 om 20:07. Reden: Automerged Doublepost
Kan het kloppen dat je pas de hostname van je server hebt veranderd? Dan moet je even een nieuw pid bestand aanmakenOorspronkelijk geplaatst door Arto
Ik heb niks gedaan, opeens merk ik dat mijn php forum niet opent, ik probeer mysql te restarten maar zoals ik boven ook zeg lukt het niet.
Raar dat dit bestand ook niet op zn plek staat :
/var/lib/mysql/mysql.sock

Mysql start wel gewoon op?
Nee, ik krijg telkens een Failed bij SSH :
MySQL PID file could not be found!
Uhhh schijf vol?

En /etc/..../mysql zap en dan /etc/..../mysql start ?
Aannemende dat dit op elke distributie gelijk werkt. Misschien is Mysql gecrashed en het initscript wil het niet stopped zonder pid en niet starten omdat het nog geregistreerd heeft dat mysql is gestart.
Met zap wordt de status gewoon op stopped gezet.
etc/....?Oorspronkelijk geplaatst door gjtje
[ERROR] Can't start server: Bind on TCP/IP port: Address already in useOorspronkelijk geplaatst door crazycoder
060402 19:30:56 [ERROR] Do you already have another mysqld server running on port: 3306 ?
060402 19:30:56 [ERROR] Aborting
060402 19:30:56 [Note] /usr/sbin/mysqld: Shutdown complete
060402 19:30:56 mysqld ended
060402 19:32:26 mysqld started
060402 19:32:26 [Warning] Asked for 196608 thread stack, but got 126976
060402 19:32:26 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
060402 19:32:26 [ERROR] Do you already have another mysqld server running on port: 3306 ?
060402 19:32:26 [ERROR] Aborting
060402 19:32:26 [Note] /usr/sbin/mysqld: Shutdown complete
060402 19:32:26 mysqld ended
060402 19:35:02 mysqld started
060402 19:35:03 [Warning] Asked for 196608 thread stack, but got 126976
060402 19:35:03 InnoDB: Started; log sequence number 0 43694
/usr/sbin/mysqld: ready for connections.
Version: '4.1.11-standard' socket: '/var/lib/mysql/mysql.sock' port: 3306 MySQL Community Edition - Standard (GPL)
060402 19:35:11 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_posts.MYI' (errno: 145)
060402 19:35:15 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:35:48 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:35:59 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:36:02 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_posts.MYI' (errno: 145)
060402 19:36:17 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_posts.MYI' (errno: 145)
060402 19:36:19 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_posts.MYI' (errno: 145)
060402 19:37:20 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:38:04 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:39:18 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:39:24 [ERROR] /usr/sbin/mysqld: Can't open file: 'ibf_members.MYI' (errno: 145)
060402 19:39:27 mysqld started
060402 19:39:27 [Warning] Asked for 196608 thread stack, but got 126976
060402 19:39:27 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
060402 19:39:27 [ERROR] Do you already have another mysqld server running on port: 3306 ?
060402 19:39:27 [ERROR] Aborting
060402 19:39:27 [Note] /usr/sbin/mysqld: Shutdown complete
060402 19:39:27 mysqld ended
Laatst gewijzigd door Arto; 02/04/06 om 21:11. Reden: Automerged Doublepost
Kijk als er nog een mysql server loopt met behulp van ps. Als dit nog het geval is, stop deze dan eerst (via init script, via kill, via kill -9 indien nodig). Probeer mysql dan terug te starten. Als het niet lukt, start dan met debugging en zoek de fout. Als hij melding geeft van foute tabellen, en het is geen innodb, probeer deze dan te herstellen. Wanneer het niet lukt, zet deze dan aan de kant en zet de correcte terug uit backups.
Wanneer je iets hierboven niet snapt, schaf u een boek aan "basis systeembeheer".
mysql 4397 0.8 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4398 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4399 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4400 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4401 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4402 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4403 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4404 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4405 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
mysql 4406 0.0 0.7 32040 12432 ? S 21:16 0:00 /usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/s
root 4408 0.0 0.0 4100 752 pts/0 R+ 21:16 0:00 ps -aux
[root@server ~]# kill -9 4397
[root@server ~]#
IK kill contstant het service maar hij blijft telkens terug komen als ik "ps -aux"doe
Na het killen heb ik in dit map /var/lib/mysql/ wel het bestand mysql.sock en het pid bestand.
Als ik via ssh /etc/rc.d/init.d/mysqld restart doe krijg ik MySQL PID file could not be found!
En het pid bestand en het sock bestand verdwijnen weer.
Laatst gewijzigd door Arto; 02/04/06 om 22:36.
killall mysqld
killall -9 mysqld
killall -9 mysqld_safe
/sbin/service mysqld start
http://directadmin.com/forum/showthr...d&pagenumber=2
Laatste post. Geen idee of het werkt, maar het lijkt op jouw probleem
Inloggen op shell en reboot geven. Niet elegant, maar voor jou de meest eenvoudige manier..
Let er wel op dat er in ieder geval ook voldoende schijfruimte is..
Dankzij gjtje is het probleem opgelost.
Hij heeft mij in het laate nacht 1 uur kostenloss geholpen via Msn.
Nogmaals hartelijk bedankt.