Likes Likes:  0
Resultaten 1 tot 14 van de 14
Geen
  1. #1
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    2 Berichten
    Ingeschreven
    22/07/12

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked



    Thread Starter

    probleem met sessies VPS CentOS

    Ik heb al een tijdje ( zeker een hele week ) een Unmanaged VPS server.
    Hier draaid CentOS op met directadmin en kom steeds bij beetje er achter hoe het werkt.
    Maar nu loop ik toch echt tegen één ding op.

    Wanneer ik een website heb gemaakt in php en hier staan sessions in dan werken deze totaal niet!.
    Nu heb ik het vermoede dat er iets in php.ini moet verranderen of een chmod moet doen.

    Aangezien er niet al te veel op google etc. te vinden is hoop ik dat jullie mij kunnen helpen.

  2. #2
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    73 Berichten
    Ingeschreven
    04/11/12

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    17 Berichten zijn liked



    Dat komt door je eigen programmeerkunsten denk ik, installeer een joomla of wordpress om te kijken of dat werkt.

  3. #3
    probleem met sessies VPS CentOS
    Web hosting diensten
    4.705 Berichten
    Ingeschreven
    09/02/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    110 Berichten zijn liked


    Bedrijf: DreamHost.nl Web hosting
    Functie: Managing Director
    URL: www.dreamhost.nl
    Registrar SIDN: JA
    KvK nummer: 24269577

    "Ik heb een auto van iemand overgenomen, maar als ik de contactsleutel omdraai slaat de auto niet aan. Wat kan dat zijn?"
    Zonder foutmeldingen of in ieder geval wat meer informatie (bijv. een stuk programmeercode) kunnen we je toch echt niet helpen.
    DreamHost.nl Web hosting - cPanel hosting om bij weg te dromen.

  4. #4
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    82 Berichten
    Ingeschreven
    11/01/11

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    7 Berichten zijn liked


    Bedrijf: RackWerk
    URL: www.rackwerk.net
    Registrar SIDN: Nee
    KvK nummer: 24467011
    Ondernemingsnummer: nvt
    View http://www.linkedin.com/company/rackwerk's profile on LinkedIn

    Ik zie in ieder geval vrij regelmatig bij een standaard installatie voorbij komen dat het session.save_path path in de php.ini staat te wijzen naar een niet schrijfbare map.

  5. #5
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    73 Berichten
    Ingeschreven
    04/11/12

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    17 Berichten zijn liked



    Citaat Oorspronkelijk geplaatst door RackWerk Bekijk Berichten
    Ik zie in ieder geval vrij regelmatig bij een standaard installatie voorbij komen dat het session.save_path path in de php.ini staat te wijzen naar een niet schrijfbare map.
    Ik ben dan wel benieuwd hoe jij dat voor elkaar krijgt bij een standaard installatie, en dan met regelmaat? Lijkt me stug bij een standaard installatie waar niets afwijkt van elkaar.

  6. #6
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    82 Berichten
    Ingeschreven
    11/01/11

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    7 Berichten zijn liked


    Bedrijf: RackWerk
    URL: www.rackwerk.net
    Registrar SIDN: Nee
    KvK nummer: 24467011
    Ondernemingsnummer: nvt
    View http://www.linkedin.com/company/rackwerk's profile on LinkedIn

    Plesk 9/10, op CentOS 5, en mensen die vervolgens php op fastcgi zetten.
    Session_save.path staat vrolijk naar /var/lib/php/sessions welke standaard niet schrijfbaar is voor de ftp users waar het script dan onder draait.

    Er is zelfs een knowledgebase artikel over: http://kb.parallels.com/en/7056

    Nieuwsgierigheid getemd?
    Laatst gewijzigd door RackWerk; 14/12/12 om 20:18.

  7. #7
    probleem met sessies VPS CentOS
    Programmeur / Hoster
    3.952 Berichten
    Ingeschreven
    20/06/06

    Locatie
    Wijlre

    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    647 Berichten zijn liked


    Naam: John Timmer
    Bedrijf: SystemDeveloper.NL
    Functie: Eigenaar
    URL: www.systemdeveloper.nl
    KvK nummer: 14083066
    View johntimmer's profile on LinkedIn

    Citaat Oorspronkelijk geplaatst door RackWerk Bekijk Berichten
    Plesk 9/10, op CentOS 5, en mensen die vervolgens php op fastcgi zetten.
    Session_save.path staat vrolijk naar /var/lib/php/sessions welke standaard niet schrijfbaar is voor de ftp users waar het script dan onder draait.

    Er is zelfs een knowledgebase artikel over: http://kb.parallels.com/en/7056

    Nieuwsgierigheid getemd?
    Maar we hebben het over directadmin en daar staat het default sessions save path op /tmp

  8. #8
    probleem met sessies VPS CentOS
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Met error reporting moet je ook vrij snel kunnen zien of dat het probleem is. Maar zoals gezegd staat het bij DirectAdmin installaties over het algemeen zonder aanpassingen goed.

  9. #9
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    82 Berichten
    Ingeschreven
    11/01/11

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    7 Berichten zijn liked


    Bedrijf: RackWerk
    URL: www.rackwerk.net
    Registrar SIDN: Nee
    KvK nummer: 24467011
    Ondernemingsnummer: nvt
    View http://www.linkedin.com/company/rackwerk's profile on LinkedIn

    Citaat Oorspronkelijk geplaatst door systemdeveloper Bekijk Berichten
    Maar we hebben het over directadmin en daar staat het default sessions save path op /tmp
    Dat kan, ik ben er niet ervaren mee.
    Probeer slechts enkel de topicstarter wat handgrepen te geven waar hij/zij wellicht wat aan heeft...

  10. #10
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    2 Berichten
    Ingeschreven
    22/07/12

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked



    Thread Starter
    Aan me programmeer kunsten zal het niet liggen aangezien het wel werkt op me xampp op me vaste computer, wanneer ik het dus upload naar de server werkt het niet
    Het leuke is dus ook ( daarom kan ik die dus niet mee posten ) dat er GEEN foutmelding gegeven word, echter alleen dat je dus niet ( waar ik het nu voor gebruikt het ) in kunt loggen.

    over de session_save.path had ik ook het één en ander gelezen.
    deze is ook niet ingevuld "no valeu", maar als ik wil gaan zoeken hoe ik deze in moet vullen kan ik dus vrij weinig vinden.

  11. #11
    probleem met sessies VPS CentOS
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Citaat Oorspronkelijk geplaatst door bas2255 Bekijk Berichten
    over de session_save.path had ik ook het één en ander gelezen.
    deze is ook niet ingevuld "no valeu", maar als ik wil gaan zoeken hoe ik deze in moet vullen kan ik dus vrij weinig vinden.
    Zo moeilijk is dat toch niet? Systemdeveloper gaf al aan wat er moet staan.

    In je php.ini moet dus staan: session.save_path = "/tmp"
    Daarna apache herstarten.

  12. #12
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    100 Berichten
    Ingeschreven
    09/08/10

    Locatie
    Zoetermeer

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    13 Berichten zijn liked


    Naam: Mark Kapitein
    Bedrijf: ColoCenter B.V.
    Functie: Operations Manager
    URL: http://colocenter.nl
    Registrar SIDN: nee
    KvK nummer: 27258635
    Ondernemingsnummer: NL812442878B01
    View pub/mark-kapitein/18/145/a61's profile on LinkedIn

    Zoals spyder01 ook zegt.

    Pak eens de error logs erbij van het domein. En post die desnoods hier op het forum. Zonder errors of foutmeldingen kunnen we niet veel betekenen.

  13. #13
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    71 Berichten
    Ingeschreven
    14/12/12

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Bedrijf: Ximple
    KvK nummer: 01181775

    Als ik me niet vergis staat de error_reporting standaard op een laag pitje, of display_errors staat op Off (bij een standaard DA installatie). Een poosje geleden kreeg ik ook een klacht van een klant binnen die bij een andere host ook geen sessions kon zetten. Dit heb ik toen opgelost door de sessies op te laten slaan in een door PHP aangegeven map (zie: http://php.net/manual/en/function.session-save-path.php). Mogelijk lost dit het probleem ook op. Wel even de map de juiste permissies geven, zodat niet iedereen er zomaar in kan schrijven, en de map waarin je het opslaan buiten je public_html folder zetten...;-)

  14. #14
    probleem met sessies VPS CentOS
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door bas2255 Bekijk Berichten
    dat er GEEN foutmelding gegeven word
    Zet bovenaan de desbetreffende pagina eens:

    error_reporting(-1);
    ini_set("display_errors", "on");

    Even er van uitgaande dat je die settings "on-the-fly" mag aanpassen.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics