Likes Likes:  0
Resultaten 1 tot 4 van de 4
Geen
  1. #1
    OpenVZ VPS iptables perikelen
    geregistreerd gebruiker
    75 Berichten
    Ingeschreven
    22/01/09

    Locatie
    Heerlen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    OpenVZ VPS iptables perikelen

    Hallo,

    sinds enkele dagen heb ik een OpenVZ VPS. Ik weet dat bij OpenVZ VPSen het gebruik van iptables beperkt is. Het enige wat ik eigelijk wil bereiken is alle outbound verkeer toelaten, en inbound alles rejecten tenzij expliciet toegestaan. Hiervoor had ik een Xen VPS waarbij ik iptables op de volgende manier geconfigureerd had (dit is niet de hele configuratie, enkel de relevante regels voor deze thread):

    Code:
    -A INPUT -i lo -j ACCEPT
    -A INPUT -d 127.0.0.0/8 -i ! lo -j REJECT --reject-with icmp-port-unreachable
    -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    
    -A INPUT -j REJECT --reject-with icmp-port-unreachable
    -A FORWARD -j REJECT --reject-with icmp-port-unreachable
    -A OUTPUT -j ACCEPT
    Op mijn nieuwe VPS struikelt ip tables over de stateful regel, hetgeen mij doet vermoeden dat mijn hoster op de VPS host de kernel module "ipt_state" niet geladen heeft. Daarom heb ik de stateful regel (r. 3) moeten verwijderen. Echter zodra ik deze configuratie laadt verliest mijn VPS alle outbound connectie mogelijkheden. Heeft iemand hier ervaring mee? Wordt dit veroorzaakt door het verwijderen van de stateful regel? Moeten inbound established connecties toegelaten worden om outbound connecties op te kunnen zetten?

    Bestaat hier een workaround voor of moet ik gewoon proberen mijn hoster zover te krijgen dat de ipt_state module geladen wordt op de VPS host?

    Bij voorbaat dank voor een reactie!

  2. #2
    OpenVZ VPS iptables perikelen
    geregistreerd gebruiker
    3.705 Berichten
    Ingeschreven
    26/11/05

    Locatie
    Duivendrecht

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    27 Berichten zijn liked


    Naam: Gert Jan
    KvK nummer: 34272910

    Als jij niet kan doen wat je wil doen dan moet je daar de host op aanspreken, een heel afwijkende configuratie is het niet.

    ESTABLISHED
    A packet which belongs to an existing connection (i.e., a reply packet, or outgoing packet on a connection which has seen replies).
    Dus ja, je heb het nodig wil je outbound verkeer mogelijk maken, zonder dit per service te specificeren.

  3. #3
    OpenVZ VPS iptables perikelen
    geregistreerd gebruiker
    550 Berichten
    Ingeschreven
    19/09/05

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    49 Berichten zijn liked


    Naam: Aleksandar Skodric
    Bedrijf: Atomia AB
    Functie: Sales Engineer
    URL: atomia.com
    Registrar SIDN: Nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt
    View http://nl.linkedin.com/pub/aleksandar-skodric/21/414/59a/'s profile on LinkedIn

    Je zal contact moeten opnemen met je host.

    Zie: http://wiki.openvz.org/Setting_up_an..._configuration

    Het hangt beetje vanaf hoe je host OpenVZ gebruikt.

    Succes!

    Mvg,
    Aleks

  4. #4
    OpenVZ VPS iptables perikelen
    geregistreerd gebruiker
    75 Berichten
    Ingeschreven
    22/01/09

    Locatie
    Heerlen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Bedankt voor jullie reacties. Ik ga inderdaad even contact opnemen met de host, ik vind het toch wel erg belangrijk om een beetje degelijke firewall op te kunnen zetten.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics