Likes Likes:  0
Resultaten 1 tot 6 van de 6
Geen
  1. #1
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    31/12/08

    Locatie
    Antwerpen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    VPS problemen/Fatal error: Call to undefined function iskeyprop()

    Hey,

    Ik weet niet zeker of ik in het juiste subforum zit.

    Het is een tijdje terug begonnen met het feit dat ik na een reboot niet meer op Plesk geraakte.
    Mailtje naar de provider van de VPS:

    Ik heb daarjuist een reboot gedaan van mijn VPS. Sindsdien zijn de sites down. Plesk control panel is niet meer te openen (continu password error). Als ik password restore probeer, krijg ik “The password recovery is unavailable due to system error #cp1005. Please contact your service provider.”
    Ik geraak er ook niet meer op via remote desktop.
    Kunt u zien wat er aan de hand is?
    en kreeg terug:

    Blijkbaar is uw ntfs filesystem corrupt geraakt van uw server. Is het eventueel een optie om een backup terug te plaatsen van 27/01 rond 3u?
    Hierop positief geantwoord, en even later was alles terug in orde. Echter was een paar uur later het probleem terug. na melding kreeg ik volgend antwoord:

    Klopt, ntfs probleem deed zich opnieuw voor. Ik heb de VPS verhuisd naar een andere partitie om te zien of het probleem zich daar ook voor doet.
    Indien ja, dan vrees ik dat er al problemen waren bij het nemen van de bakcup.
    Best even afwachten wat dit geeft. Normaal draait alles nu weer.
    Inderdaad draaide alles weer. Echter heeft het niet lang geduurd.
    Plots krijg ik volgende error bij het inloggen:
    Code:
    "Fatal error: Call to undefined function iskeyprop() in C:\Parallels\Plesk\admin\auto_prepend\auth.php3 on line 41"
    Mailtje naar de provider:

    Het lijkt me niet mee te zitten… Als ik nu inlog op plesk, krijg ik het volgende:
    Fatal error: Call to undefined function iskeyprop() in C:\Parallels\Plesk\admin\auto_prepend\auth.php3 on line 41
    Gisterenavond werkte het perfect, en sindsdien ben ik er niet meer aan geweest.
    mailtje terug van de provider:

    Meestal wordt dit probleem veroorzaakt door beschadigde files, maar het vervangen van die files lijkt hier geen oplossing te bieden.
    en
    Nog even een update; Parallels vermoed dat het iets te maken heeft met een licentie die niet meer “geregistreerd” staat op uw VPS, terwijl dit wel zou moeten.

    Zodra er een definitieve oplossing is, bevestig ik dit uiteraard nog.
    In samenspraak met de provider backups teruggezet. Dit bracht geen oplossing.

    Dan geprobeerd met een complete reïnstall van de container, geen oplossing.

    Provider heeft navraag gedaan bij parallels. Die zeiden dat er een probleem was met 2 DLL files (libea32.dll en nog 1). Parallels heeft ook een virusscan gedaan op m'n VPS:

    Hello,

    I have investigated the issue closer. I tried to copy files libeay32.dll and ssleay32.dll from %plesk_bin% folder to %systemroot%\syswow64 folder, but got "access denied" message. I've decided to synchronize system files on this CT with HN system files, but it did not affect the issue somehow. It looks like virus infection. I ran virus scanning on the CT and found viruses in system folders (please, check the screenshot attached).
    Please, consider clearing server from viruses. Alos I would recommend you to install antivirus software on the hardware node. The list of supported antiviruses can be found here:
    http://kb.parallels.com/en/2226
    De virusmelding bleek om volgend bestand te gaan. npptools.exe. Ik heb deze bestanden verwijderd, en dit gemeld aan de provider.

    Een paar dagen later kreeg ik volgende mail:

    Zelfs bij een offline copy geeft dit problemen, hoewel de folder het bestand libeay32.dll niet gevonden kan worden in de betreffende folders, is het wel openbaar als je het rechtstreeks aanspreekt en kan het niet overschreven worden wegens "access denied".

    De snelste oplossing is nu vermoedelijk een Plesk back-up nemen, en een nieuwe VPS installeren om daarop die Plesk back-up te restoren. Qua werk vereist dit vermoedelijk een uurtje (waarbij het meestal enkel wachten is op de back-up, en het terugzetten ervan). Geef je je akkoord voor deze uit te voeren werken? Deze worden gefactureerd aan het standaard support tarief van 80eur/werkuur.
    hierop geantwoord:


    Ik heb reeds een volledige restore gedaan van de container. Dit heeft ook niet geholpen.

    Het probleem is vanzelf gekomen. Ik heb tussen de tijd dat het werkte, en de tijd dat dit probleem zich voordeed niets veranderd.

    Als het probleem hardnekkig blijft, zelfs na een volledige reïnstall van de VPS zoals ik heb gedaan, en jullie zelf vermoedens hebben dat er een probleem is met de key, is het toch niet logisch dat ik nu 80 euro moet gaan betalen om dit op te lossen?
    en response gekregen:

    Een restore van Plesk gaat enkel maar de bestanden & configs van de toegevoegde domeinen back-uppen, en niet de systeemfiles. Deze restore zal geen soelaas bieden.

    Het probleem wordt veroorzaakt door 2 files die gewijzigd werden, en die nu niet meer aangepast kunnen worden. Als gevolg hiervan, had de Plesk Key problemen. Hoe en waarom deze files plots werden aangepast is ons ook niet duidelijk, maar het aantreffen van virussen op uw VPS doet ons in deze richting denken. Het uitschakelen van de malafide software brengt geen verschil op de 2 files die terug naar hun originele staat gekopieerd moeten worden, er blijft "iets" actief wat deze files verborgen & actief houdt, waardoor ze niet gewijzigd kunnen worden.

    Nu vroeg ik mij af, worden normaal gezien bij een reïnstall de systemfiles ook niet teruggezet, of ben ik verkeerd?

    Ik heb zelf aan de VPS niets verkeerd gedaan. Ik zou niet weten hoe ik het zelf om zeep zou kunnen geholpen hebben. Daarom heb ik er wat moeite mee dat ik nu 80 euro moet gaan betalen.

    Wat denken jullie? Iemand nog tips hoe ik het zelf kan oplossen?

    Thanks voor de input

  2. #2
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    geregistreerd gebruiker
    699 Berichten
    Ingeschreven
    21/05/03

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Het uurbedrag komt mij bekend voor :-x. Persoonlijk zou ik mijn zaken inpakken en meenemen naar een andere provider. Bij voorkeur eentje die geen Virtuozzo-Windows heeft.

    Heb je wel een backup van al je domeinen? Een Plesk-backup wel te verstaan.

  3. #3
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    31/12/08

    Locatie
    Antwerpen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik kan aan de backups etc nog aan.

    Ik heb bij die provider voor een klant van mij al 2 jaar een colo server waar ik nooit problemen mee heb gehad.

    Ik heb uiteindelijk toegezegd dat ze het mochten fixen. Ze hebben een volledige reinstall gedaan, en alle plesk configuraties teruggezet.

    Het ding heeft 3 dagen perfect gewerkt. De eerste dag ben ik enkel even met remote desktop ingelogd geweest om een AV te installeren (Clamwin).

    Vanmorgend nog op de Plesk geweest, geen probleem. Ik probeer zojuist in te loggen, en krijg terug de Fatal error

    nog maar eens mailen...

  4. #4
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    31/12/08

    Locatie
    Antwerpen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    hmmz, zojuist een AV scan gedaan:

    Scan Started Sun Feb 15 21:39:49 2009
    -------------------------------------------------------------------------------

    C:\WINDOWS\system32\CatRoot2\tmp.edb: Permission denied
    C:\WINDOWS\system32\CatRoot2\F750E6C3-38EE-11D1-85E5-00C04FC295EE\catdb: Permission denied
    C:\WINDOWS\SysWOW64\libeay32.dll: Permission denied
    C:\WINDOWS\SysWOW64\ssleay32.dll: Permission denied
    C:\WINDOWS\Temp\ib65.tmp: Permission denied

    C:\WINDOWS\SysWOW64\msupsv\msupdate.exe: Trojan.Servu-46 FOUND
    ----------- SCAN SUMMARY -----------
    Known viruses: 513301
    Engine version: 0.94.1
    Scanned directories: 14645
    Scanned files: 83281
    Infected files: 1

    Data scanned: 5556.73 MB
    Time: 1942.359 sec (32 m 22 s)
    --------------------------------------
    Completed

  5. #5
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    För Sverige i tiden
    2.859 Berichten
    Ingeschreven
    21/02/06

    Locatie
    Egmond Aan Zee / Stockholm Zweden

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    10 Berichten zijn liked


    KvK nummer: 37128170

    Dat je vps node geïnfecteerd wordt is niet de schuld van je provider, persoonlijk vind ik dat ze erg netjes hebben gehandeld. Die virus komt er niet zomaar op. Je geeft niet aan wat je draait op de vps dus een oorzaak kan ik zo niet bedenken.

  6. #6
    VPS problemen/Fatal error: Call to undefined function iskeyprop()
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    31/12/08

    Locatie
    Antwerpen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door swedendedicated Bekijk Berichten
    Dat je vps node geïnfecteerd wordt is niet de schuld van je provider, persoonlijk vind ik dat ze erg netjes hebben gehandeld. Die virus komt er niet zomaar op. Je geeft niet aan wat je draait op de vps dus een oorzaak kan ik zo niet bedenken.
    Het ding is dat ik niets van software draai op de VPS. Enigste stukje software was de AV.
    Voor de rest wordt enkel Plesk gebruikt. Geen scripts, speciale configs etc. Gewoon standaard plesk.

    Ik zie echt niet hoe de VPS geïnfecteerd kan geraken...

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics