-
Hi Geert-jan, heb je ook zo'n super Howto for Debian ?
:/usr/local/directadmin/custombuild# php -v
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.2.10 (cli) (built: Jul 4 2009 10:18:43)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies
:/usr/local/directadmin/custombuild# cat /proc/version
Linux version 2.6.18-6-xen-686 (Debian 2.6.18.dfsg.1-26etch2) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Sat Feb 20 01:44:14 UTC 2010
Debian met CP : DirectAdmin
Heb al van alles geprobeerd, maar zonder soelaas.
-
misschien heb je hier iets aan .... [ame="http://www.directadmin.com/forum/showthread.php?t=26260"]Enable Soap - DirectAdmin Forums[/ame]
-
Dan heb je echt wat verkeerd gecompiled Marco waardoor je deze melding krijgt. Build ging zonder fouten?
-
Hi Nathan,
Die had ik al gevolgd inderdaad.
Ik zal even uit de doeken doen welke stappen ik volg.
:/usr/local/directadmin/custombuild# ./build used_configs
Apache configuration file: /usr/local/directadmin/custombuild/configure/ap2/configure.apache
suPHP configuration file: /usr/local/directadmin/custombuild/configure/suphp/configure.suphp
PHP4 configuration file: /usr/local/directadmin/custombuild/configure/suphp/configure.php4
PHP5 configuration file: /usr/local/directadmin/custombuild/configure/ap2/configure.php5
ProFTPD configuration file: /usr/local/directadmin/custombuild/configure/proftpd/configure.proftpd
Vervolgens pak ik in dit geval configure.php5
Ik voeg aan de config de regel voor SOAP toe.
"--enable-soap" \
"--enable-mbstring"
Voor de mbstring heb ik soap toegevoegd.
:/usr/local/directadmin/custombuild# ./build php n
File already exists: php-4.4.9.tar.gz
MD5 Checksum on php-4.4.9.tar.gz passed.
File already exists: php-4.4.9-mail-header.patch
MD5 Checksum on php-4.4.9-mail-header.patch passed.
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' -
./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
Hier geeft hij de fout, echter hoe op te lossen. :)
/usr/local/directadmin/custombuild# echo '' | php | grep "soap"
PHP Warning: PHP Startup: Unable to load dynamic library './php_soap.so' - ./php_soap.so: cannot open shared object file: No such file or directory in Unknown on line 0
:/usr/local/directadmin/custombuild#
cat /proc/version
Linux version 2.6.18-6-xen-686 (Debian 2.6.18.dfsg.1-26etch2) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Sat Feb 20 01:44:14 UTC 2010
-- update: voor het geval, dat ik het was vergeten, had op wht.nl ook dit gelezen en toegepast.
Maar zoals je ziet, is het wel geïnstalleerd.
:/usr/local/directadmin/custombuild# apt-get install php-soap
Reading package lists... Done
Building dependency tree... Done
php-soap is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
-
Bestaat php_soap.so wel ergens op je systeem?
-
:/usr/local/directadmin/custombuild# locate php_soap.so
:/usr/local/directadmin/custombuild#
Nee dus. ;) maar het vreemde is dat hij wel aangeeft dat het is geïnstalleerd.
:/usr/local/directadmin/custombuild# apt-get install php-soap
Reading package lists... Done
Building dependency tree... Done
php-soap is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
-
Code:
cat /usr/local/directadmin/custombuild/options.conf