Likes Likes:  0
Resultaten 1 tot 2 van de 2
Geen
  1. #1
    Martin Maèok
    Re: Is predictable spam filtering a vulnerability? (silently dropping messages)
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Is predictable spam filtering a vulnerability? (silently dropping messages)

    On Thu, Jun 17, 2004 at 07:28:45AM -0400, David F. Skoll wrote:

    > A spam filter MUST respond with a 500 SMTP failure code if it
    > rejects a message.


    What is your opinion based on?
    Let me guess (correct me if I'm wrong, please).


    I'm assuming you mean RFC 2821 (SMTP) -- by issuing "250 OK" to
    a message, SMTP server is accepting responsibility for delivering or
    relaying the message. In this meaning, it should not silently discard
    the message. (The question could be, is delivering to a special folder
    -- be it /dev/null or ~/mail/junk -- considered dropping or not ? ...)

    On the other hand (RFC 2821): "a relay SMTP SHOULD assume that the
    message content it has received is valid and, assuming that the
    envelope permits doing so, relay it without inspecting that content."


    SMTP filter (i.e. spam or AV filter) is not SMTP server (or relay) but
    it is SMTP (application level) firewall (RFC 3234 - Middleboxes:
    Taxonomy and Issues). In this mean, it can implement any "safe" subset
    of SMTP and is allowed to break RFC 2821 for valid reasons (RFC 2979
    - Firewall Requirements).

    For me, not generating bounce message to spam/viral message is
    a reason valid enough to "break" RFC 2821. Not doing so, we all end up
    filtering delivery failures of messages that we have not really sent
    (as I already have to do today :-/ ).


    IHMO 1: If your filter decides the message is not worth a delivery
    it's not worth a bounce too.

    IMHO 2: If your filter does not do the job of filtering messages well
    and bounces back, it is just distributing his work to others
    and deserves to be repaired/changed or blacklisted (firewalled
    out by others).

    IMHO 3: If user Joe gets 10 delivery failures of messages that he has
    not sent and one delivery failure of message that he has
    actually sent, it is worse than if he gets nothing.


    Martin Maèok
    IT Security Consultant

  2. #2
    Valdis.Kletnieks@vt.edu
    Re: Is predictable spam filtering a vulnerability? (silently dropping messages)
    Gast
    n/a Berichten
    Berichten zijn liked



    Thread Starter

    Re: Is predictable spam filtering a vulnerability? (silently dropping messages)

    --==_Exmh_1318661500P
    Content-Type: text/plain; charset=iso-8859-1
    Content-Transfer-Encoding: quoted-printable

    On Tue, 22 Jun 2004 16:20:02 +0200, Martin =3D?iso-8859-2?Q?Ma=3DE8ok?=3D=
    <martin.macok@underground.cz> said:

    > IHMO 1: If your filter decides the message is not worth a delivery
    > it's not worth a bounce too.


    Not true, because...

    > IMHO 3: If user Joe gets 10 delivery failures of messages that he has
    > not sent and one delivery failure of message that he has
    > actually sent, it is worse than if he gets nothing.


    It's not worse. That bounce message for the mail you actually sent may b=
    e very
    critical.... Consider the following scenarios:

    1) You've been working on fixing a problem for 16 hours, and decide to ca=
    ll it
    quits and get some sleep, so you mail your boss and co-workers with a sta=
    tus
    update.

    2) You make some trivial error (perhaps you type "steve. bill" rather tha=
    n
    "steve, bill".

    3) The mail of course has issues.

    With a bounce:

    4) You get the bounce, say "D'Oh!", fix the problem, resend, and go home =
    and
    get some sleep. Steve and Bill know the status, and finish fixing it and
    everything is fine.

    Without a bounce:

    4) You go home, and the next morning the boss rips into you for not keepi=
    ng
    everybody posted. Steve and Bill didn't see your note, and they've tried=
    to
    clean up after you, and only making things worse because they didn't know=
    about
    the stuff you told them in the note that bounced....


    --==_Exmh_1318661500P
    Content-Type: application/pgp-signature

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)
    Comment: Exmh version 2.5 07/13/2001

    iD8DBQFA2n91cC3lWbTT17ARArJoAKDvgjcF4xnk5coSbacCUA F0uT5EvQCfYBIs
    R8fvSSLP4D3MdZo+IM0Dqwk=
    =8/mS
    -----END PGP SIGNATURE-----

    --==_Exmh_1318661500P--

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics