Likes Likes:  0
Resultaten 1 tot 13 van de 13
php

Onderwerp: Php 7.4

  1. #1
    Php 7.4
    geregistreerd gebruiker
    4 Berichten
    Ingeschreven
    22/12/21

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Eric

    Thread Starter

    Php 7.4

    Beste forum leden

    In mijn whmcs heb ik de volgende warning:

    PHP Version
    Your PHP version 7.4.27 is supported by WHMCS.

    The PHP 7.4 branch no longer receives regular bug fixes and will only receive critical security updates until it reaches its end of life. Please see our documentation for more information.

    Hoe krijg ik deze meldinge opgelost?

    Met vriendelijke groet

    Cloudje

  2. #2
    Php 7.4
    moderator
    5.976 Berichten
    Ingeschreven
    21/05/03

    Locatie
    NPT - BELGIUM

    Post Thanks / Like
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    481 Berichten zijn liked


    Naam: Dennis de Houx
    Bedrijf: All In One
    Functie: Zaakvoerder
    URL: www.all-in-one.be
    Ondernemingsnummer: 0867670047

    Citaat Oorspronkelijk geplaatst door Cloudje Bekijk Berichten
    Hoe krijg ik deze meldinge opgelost?
    Wat dacht je van php 8.0 of php 8.1 te installeren, nu op zich heb je nog tot 28 Nov 2022 security updates voor php 7.4 dus heb je nog 11 maanden om te upgraden.
    Dennis de Houx - All In One ~ Official ISPsystem partner

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  3. #3
    Php 7.4
    geregistreerd gebruiker
    1.049 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Citaat Oorspronkelijk geplaatst door The-BosS Bekijk Berichten
    Wat dacht je van php 8.0 of php 8.1 te installeren, nu op zich heb je nog tot 28 Nov 2022 security updates voor php 7.4 dus heb je nog 11 maanden om te upgraden.
    Ondersteunen zij PHP 8 dan?

    https://docs.whmcs.com/PHP_Version_Support_Matrix

  4. #4
    Php 7.4
    geregistreerd gebruiker
    4 Berichten
    Ingeschreven
    22/12/21

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Eric

    Thread Starter
    Citaat Oorspronkelijk geplaatst door xaban Bekijk Berichten
    Ondersteunen zij PHP 8 dan?]
    vraag ik mij ook af, whmcs al gevraagd zij zeggen er komt vanzelf wel een update ervoor.
    Normaal heb ik alle meldingen weg.

    Citaat Oorspronkelijk geplaatst door The-BosS Bekijk Berichten
    Wat dacht je van php 8.0 of php 8.1 te installeren.
    bedankt voor je snelle reactie, ik gebruik de nieuwste whmcs versie: 8.3.2.
    Als ik dan kijk naar de php staat deze op: 7.4.27

  5. #5
    Php 7.4
    moderator
    5.976 Berichten
    Ingeschreven
    21/05/03

    Locatie
    NPT - BELGIUM

    Post Thanks / Like
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    481 Berichten zijn liked


    Naam: Dennis de Houx
    Bedrijf: All In One
    Functie: Zaakvoerder
    URL: www.all-in-one.be
    Ondernemingsnummer: 0867670047

    Citaat Oorspronkelijk geplaatst door Cloudje Bekijk Berichten
    vraag ik mij ook af, whmcs al gevraagd zij zeggen er komt vanzelf wel een update ervoor.
    Je zou toch verwachten dat ze na meer dan een jaar na de officiele release van php 8 toch wel een versie hebben die het support, er bestaan alfa, beta en rc release net om software vendors de tijd te geven om alles te updaten. Maar zoals ik dus al aanhaalde heb je nog 11 maanden de tijd om te upgraden voor php 7.4 EOL is en dan maar hopen dat ze geen versie uitbrengen die enkel php 8.0 support want dan loop je terug achterop .

    Op zich schuiven ze schuld door naar ioncube die geen php 8 support heeft (alhoewel die ondertussen ook wel een beta loader hebben voor php 8), maar het is nu niet dat enkel ioncube bestaat om hun source te encoden en ze al lang een andere oplossing hadden kunnen verzinnen. Toch zeker voor een product wat redelijk wat geld kost.
    Dennis de Houx - All In One ~ Official ISPsystem partner

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!



  6. #6
    Php 7.4
    geregistreerd gebruiker
    560 Berichten
    Ingeschreven
    10/06/06

    Locatie
    Emmeloord

    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    21 Berichten zijn liked


    Naam: Arie

    PHP voert de druk ook wel op moet ik zeggen. We zitten eerst 10 jaar op PHP 5 en nu moet je zowat ieder jaar een nummer verder. Genoeg libraries die je dan weer na mag lopen.

  7. #7
    Php 7.4
    moderator
    5.976 Berichten
    Ingeschreven
    21/05/03

    Locatie
    NPT - BELGIUM

    Post Thanks / Like
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    481 Berichten zijn liked


    Naam: Dennis de Houx
    Bedrijf: All In One
    Functie: Zaakvoerder
    URL: www.all-in-one.be
    Ondernemingsnummer: 0867670047

    Citaat Oorspronkelijk geplaatst door Arieh Bekijk Berichten
    PHP voert de druk ook wel op moet ik zeggen. We zitten eerst 10 jaar op PHP 5 en nu moet je zowat ieder jaar een nummer verder. Genoeg libraries die je dan weer na mag lopen.
    Welke druk, php 7.0 is van december 2015 dat is 6 jaar op versie 7.x met elke jaar een nieuwe release die 2 jaar support heeft + nog een extra jaar security patches. Er zijn volledige operating systems die elke 6 maand een update krijgen

    Trouwens bij whmcs beweren ze dat ze php 8 ready zijn, maar dat het komt omdat ioncube nog geen php 8 support. En zoals ik in me vorig bericht aanhaalde wat houdt hen tegen om een andere encoder te gebruiken die wel php 8 compatibel is als je eigen source toch al php 8 ready is.
    Dennis de Houx - All In One ~ Official ISPsystem partner

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  8. #8
    Php 7.4
    geregistreerd gebruiker
    6 Berichten
    Ingeschreven
    28/05/16

    Locatie
    Horst

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Paul Hermans
    Bedrijf: FOXXL Hosting B.V.
    Functie: Eigenaar
    URL: foxxl.hosting
    Registrar SIDN: JA
    KvK nummer: 82388776
    View paulhermanseu's profile on LinkedIn

    Het wordt tijd dat ze bij PHP met LTS versies gaan werken, Long-Term Support: https://en.wikipedia.org/wiki/Long-term_support

    We moeten nu steeds klanten blijven pushen om hun PHP versie te verhogen, het zou fijn zijn als klanten met een website waar weinig aan gebeurt dat die lange tijd op dezelfde PHP-versie kunnen blijven hangen.

    Zend ziet er wel brood in: https://www.zend.com/services/php-long-term-support

  9. #9
    Php 7.4
    geregistreerd gebruiker
    560 Berichten
    Ingeschreven
    10/06/06

    Locatie
    Emmeloord

    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    21 Berichten zijn liked


    Naam: Arie

    En zo ook CloudLinux https://www.cloudlinux.com/features/#hardened-php

    Nu kun je wel zeggen ja je hebt de tijd om voor te bereiden, maar je bent een applicatie die gewoon prima draait zinloos aan het aanpassen. Er worden php functies aangepast, weggehaald, toegevoegd, dat heeft voor veel applicaties geen enkele meerwaarde. En dat alles om maar security updates te krijgen. Niet gek dat er dan dit soort alternatieven zijn.

  10. #10
    Php 7.4
    moderator
    5.976 Berichten
    Ingeschreven
    21/05/03

    Locatie
    NPT - BELGIUM

    Post Thanks / Like
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    481 Berichten zijn liked


    Naam: Dennis de Houx
    Bedrijf: All In One
    Functie: Zaakvoerder
    URL: www.all-in-one.be
    Ondernemingsnummer: 0867670047

    Klopt allemaal van die hardend en lts versies, maar je kunt jezelf ook de vraag stellen waarom je software leverancier geen enkele moeite zou doen om binnen de 2 jaar (want ja zoveel tijd heb je zonder de alfa, beta, rc etc mee te rekenen) zijn source aan te passen om gebruik te maken van de nieuwe php release. Zeker als we hebben over main releases, want van bvb php 7 naar php 8 is er enorm veel resource winst te behalen. En dat is toch ook iets als leverancier en gebruiker dat je wil hebben. We hebben het hier nog steeds over een groot bedrijf die veel geld verdient met zijn software en niet over een one man band die een opensource projectje runt. En als we het dan toch over foss hebben hoe komt het dan dat de meest gebruikte frameworks al php 8 ready waren voor php 8 uitkwam , dan kun je wel stellen dat er bij whmcs zakelijk iets verkeerd zit.

    En wat je volgens mij ook niet wilt hebben is zoals met python het geval was/is dat er nu nog steeds developers zijn die python 2.7 gebruiken wat ook EOL is en al uit kwam op 2010 maar een lifetime cycle had van 10 jaar (en zijn laatste update van 2018 was), bij de nieuwe 3.x releases is dit ook 5 jaar geworden (net om vluggere deployment/adaptation te hebben).

    Begrijp met niet verkeerd, ik heb totaal niks tegen LTS versies, maar als het gaat om een cms, boekhouding of klantenbeheer software mag je toch wel verwachten dat deze up-to-date zijn en mee gaan met hun tijd. LTS versies zijn een godsgeschenk voor zaken die absoluut geen downtime mogen hebben of zo min mogelijk, maar dat neemt niet weg dat deze ook ooit geupdate moeten worden.
    Dennis de Houx - All In One ~ Official ISPsystem partner

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  11. #11
    Php 7.4
    geregistreerd gebruiker
    6 Berichten
    Ingeschreven
    28/05/16

    Locatie
    Horst

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Paul Hermans
    Bedrijf: FOXXL Hosting B.V.
    Functie: Eigenaar
    URL: foxxl.hosting
    Registrar SIDN: JA
    KvK nummer: 82388776
    View paulhermanseu's profile on LinkedIn

    Ja wat betreft whmcs, en Hostfact heeft hetzelfde probleem, ligt het probleem bij ioncube:https://forum.ioncube.com/viewtopic.php?t=4592

    Zie hier: https://www.hostfact.nl/blog/hostfac...en-php8-ready/


    Ik snap dat je niet zomaar wil omschakelen naar een andere encoder als je daar jarenlang een tevreden gebruiker van bent geweest. Ook zou een switch van encoder betekenen dat al je gebruikers (wij dus) die nieuwe encoder moeten installeren op de server. Die optie zullen ze allemaal inmiddels wel onderzocht hebben verwacht ik, ze wachten nu zo lang mogelijk op ioncube.

    Maar ik denk wel dat ioncube bij veel van hun klanten punten heeft verspeeld.

  12. #12
    Php 7.4
    geregistreerd gebruiker
    4 Berichten
    Ingeschreven
    22/12/21

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Eric

    Thread Starter
    Tja we wachten maar af, had whmcs ook kunnen zeggen weet je wat we wachten nog even met deze melding....

    Ik ga oftopic wegens prive omstandigheden, zal het later nog is inzien.

    Fijne dagen allemaal

  13. #13
    Php 7.4
    geregistreerd gebruiker
    4 Berichten
    Ingeschreven
    22/12/21

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Eric

    Thread Starter
    Door prive omstandigheden kan ik langere tijd of niet veel reageren, maar ik heb van whmcs een reactie gehad over php 8

    We kunnen PHP 8 pas ondersteunen als er ionCube-laders voor beschikbaar zijn. Om te weten wanneer WHMCS PHP 8 ondersteunt, raad ik aan om onze blog op https://blog.whmcs.com in de gaten te houden .

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2021 Webhostingtalk.nl.
Web Statistics