Likes Likes:  0
Resultaten 1 tot 8 van de 8
Geen
  1. #1
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    520 Berichten
    Ingeschreven
    26/01/04

    Locatie
    Doetinchem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 08120871
    Ondernemingsnummer: nvt

    Thread Starter

    Problemen met ProSupport / Plesk

    Even een klein vraagje waar ik nu echt even de oplossing zoek voor ben.

    Wij maken voor onszelf gebruik van een plesk / windows systeem, (plesk 7.5 win2003)
    Voor mail en support afhandeling gebruiken we prosupport (propanelsystems.com red.)
    Dit heeft prima gewerkt, echter gedurende afgelopen 5 dagen komen we het ene probleem na het andere tegen.

    Nu zijn we eindelijk zover dat alles werkt, zelfs het reageren.
    Echter komt er een nare (php, cgi?) foutmelding tevoorschijn.

    Dit is de volgende:

    Warning: Invalid argument supplied for foreach() in D:\vhosts\alphaxs.nl\httpdocs\helpdesk\includes\cl asses\PEAR_Mail.php on line 129

    Warning: Cannot modify header information - headers already sent by (output started at D:\vhosts\alphaxs.nl\httpdocs\helpdesk\includes\cl asses\PEAR_Mail.php:129) in D:\vhosts\alphaxs.nl\httpdocs\helpdesk\includes\cl asses\AdminTicketsCore.php on line 281

    Warning: Cannot modify header information - headers already sent by (output started at D:\vhosts\alphaxs.nl\httpdocs\helpdesk\includes\cl asses\PEAR_Mail.php:129) in D:\vhosts\alphaxs.nl\httpdocs\helpdesk\includes\cl asses\AdminTicketsCore.php on line 283



    De rechten lijken goed te staan.

    Deze error verschijnt alleen wanneer een reactie op een bericht ge "submit" word. De mail word gewoon verzonden en de reatcie gewoon toegevoegd.

    in principe werkt het dus wel, echter zie ik het liever gewoon helemaal goed werken.

    Mocht iemand dit bekend voorkomen of een ingeving of idee hebben, laat dan even wat horen.

    Alles is welkom, en al helemaal de oplossing tot dit probleem.

    Bijvoorbaat dank.



  2. #2
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    92 Berichten
    Ingeschreven
    07/01/05

    Locatie
    Groningen/Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    De laatste twee warnings kans je oplossen door output_buffering in php.ini aan te zetten. Wellicht heeft de eerste error er ook wat mee te maken, geen idee?

    Tevens lijkt het erop dat de eerste error de volgende twee veroorzaakt. Doordat er al een error 'ge-output' is kunnen de headers, zonder output_buffering, niet meer aangepast worden.

    Is het systeem toevalig geupdate of iets dergelijks?

  3. #3
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    520 Berichten
    Ingeschreven
    26/01/04

    Locatie
    Doetinchem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 08120871
    Ondernemingsnummer: nvt

    Thread Starter
    Nee, net volledig op nieuw geinstalleerd (voor een keertje of 15 deze week :S)

    Ik ga het eens proberen en laat zo de uitslag weten.
    Ben er al wel achter dat het er sterkt op lijkt dat het met het verzenden van de e-mail naar de ge-adresseerde(n) te maken heeft. (niet zozeer door de naam van de script pagina, maar omdat het juist op die pagina's fout gaat.)

  4. #4
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    92 Berichten
    Ingeschreven
    07/01/05

    Locatie
    Groningen/Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Ik zit nou ff in een versie van PEAR_mail te kijken, daar staat rond regel 129:

    foreach ($headers as $key => $value) {

    Als headers dan leeg is geeft hij bovenstaande error. Wat je kan doen is een check inbouwen of $headers leeg is of niet:

    if(!isset($headers)) $headers = array();

    Als je dit op regel 128 zou zetten zouden er in ieder geval geen fouten meer mogen zijn, geen mooie oplossing maar wellicht werkt het?

  5. #5
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    520 Berichten
    Ingeschreven
    26/01/04

    Locatie
    Doetinchem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 08120871
    Ondernemingsnummer: nvt

    Thread Starter
    @scr33x0r:

    if(!isset($headers)) $headers = array();

    Leuk bedracht Maar helaas.. :S dat deed m dus niet.
    Output buffering daarintegen deed wel wat het moest doen, maar aan de andere kant is dat ook geen nette oplossing.

    Echter vooralsnog is de error weg en kunnen we nu wel gewoon doorwerken, zonder de back functie te moeten gebruiken in de browser.

    Echter wat ik dan nog steeds niet snap, ik heb de oude configuratie erbij gepakt, van dezelfde machine zelfde php.ini bestand en daarin stond output buffering toch absoluut uit, en daar draaide dit script toen feilloos op.

    Ik ben er al wel achter dat het een leuk en mooi systeem is als het eenmaal werkt.
    echter zonder enige kennis van zaken, is het een onmogelijk iets om aan te beginnen.
    Het werkt heel variabel op verschillende systemen, en er is een flinke dosis eigen kennis nodig om het werkend te krijgen. (prosupport / propanelsystems).

    Daarnaast is de support van propanelsystems dus gewoonweg niets.
    Tickets staan nu al 68 dagen open :S.
    Erg matig dus.

    Maar goed vooralsnog kwam je dus met de juiste oplossing om in elk geval aan de slag te kunnen.

    Mocht iemand anders er zich nog in verdiept hebben en een andere mogelijke verbetering of oplossing weten hoor ik m graag.

    @ scr33x0r.. THANX

  6. #6
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    92 Berichten
    Ingeschreven
    07/01/05

    Locatie
    Groningen/Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    No Problem, je webpage is leeg op dit moment? Lijkt me niet de bedoeling?

  7. #7
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    520 Berichten
    Ingeschreven
    26/01/04

    Locatie
    Doetinchem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 08120871
    Ondernemingsnummer: nvt

    Thread Starter
    Nee, dat is ook niet de bedoeling.

    We zijn nu eindelijk op het moment n zover gekomen dat we de site weer kunnen gaan terug zetten.

    Helaas, gaat dus toch iets niet goed.

    Uitgaande mail wordt dus niet verzonden. Daar zit dus ook het / een probleem.
    Met output_buffering aan gaat de mail in zijn geheel niet weg, met dezelfde functie uit, gaat er enkel iets niet goed met het verzenden van de externe mail.
    Laatst gewijzigd door AlphaXS; 04/08/06 om 21:05. Reden: Automerged Doublepost

  8. #8
    Problemen met ProSupport / Plesk
    geregistreerd gebruiker
    112 Berichten
    Ingeschreven
    23/12/05

    Locatie
    Leidschendam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 27195798
    Ondernemingsnummer: nvt

    het zou kunnen dat $headers een string is naar het idee van php en geen array
    je zou dus een check kunnen bouwen:
    if(!is_array($headers)) $headers = array($headers);

    heb hier geen versie van PEAR_Mail.php bij de hand, dus kan niet garanderen dat dat de oplossing is

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics