je kan ook nog met rewite engine aan de gang, maar aangezien je zowel op mijn reactie als die van dennis niet inhoudelijk meer hebt gereageerd haak ik af om nog verder mee te helpen.
Succes met je probleem.
met alle respect.. maar als aangegeven in de wiki...
deny / allow / deny is helemaal niet aan de orde... dus ook je deny from all niet...
als je order allow deny gebruik... dan test de server dus eerst er er uberhaubt een match is met de allow regels... zo niet dat word de request niet eens behandeld... indien het wel zo is... (zoals in jouw ranges)... dan kun je nog de deny gebruiken op specifieke uitzonderingen te plaatsen...
dus order allow deny
alow 10.0.0.0 /8
deny 10.0.0.1
zou resulteren in het feit dat alle reekens behalve 10.* worden geblokeerd. EN dat 10.0.0.1 ook wordt geblockt..
ergo - jouw gewenste oplossing..
Ik kan natuurlijk een tweede ipblocker installeren.
Die kan dus alles wat allowed is, alsnog blokkeren.
Die scripts zijn er in overvloede, heeft iemand een aanrader?
Yvette
Sorry, maar lees je nu de oplossingen gewoon niet? Als je vraagt om hulp maar hier niets mee doet, wat is dan het punt van je vraag?
@Mikey
Ik heb je hele reactie over het hoofd gezien. Sorry daarvoor. Zie hem nu pas.
Wat betreft de Deny All. Dat staat in de htaccess file wel correct natuurlijk.
Jouw oplossingen werken niet, kan ook niet als je logisch nadenkt.
Over de Rewrite engine wil ik graag meer weten, als je nog zin hebt om te helpen.
Yvette
Het komt door een heel simpele reden:
Wanneer je bijvoorbeeld 3 reacties krijgt, dan ontvang je daar maar 1 notificatie van. Klik je op de link in die emailnotificatie, dan krijg je alleen de laatste reactie te zien. Probeer het zelf maar. Ik heb gewoon niet in de gaten gehad dat er meer reacties waren, foutje, niet meer, niet minder.
Geen enkele reden om je zo op te winden...
Yvette
Yvette, lees even de berichten van Mikey en mij opnieuw of neem de documentatie goed door.
Je doet namelijk een paar aannames die niet kloppen. Wij doen de moeite om precies uit te leggen hoe het werkt en kopiëren de relevante tekst uit de documentatie voor je. Vervolgens lees je over onze beide posts heen en na het lezen misinterpreteer je alsnog de werking van de door ons gegeven code, terwijl de uitleg er duidelijk bij staat.
Lees dus echt even de Apache documentatie over mod_access. Ik zal het nog 1x proberen uit te leggen:
Hieronder dus met volgorde van verwerking, de derde regel heb ik erbij gezet, zodat je begrijpt wat er gebeurt.Citaat:
Allow,Deny
First, all Allow directives are evaluated; at least one must match, or the request is rejected. Next, all Deny directives are evaluated. If any matches, the request is rejected. Last, any requests which do not match an Allow or a Deny directive are denied by default.
Het is erg storend dat je over onze oplossingen heenleest en dat komt erg ondankbaar over. Indien je vragen hebt of iets niet begrijpt, dan willen we het best uitleggen en indien je uit kunt leggen, waarom je specifieke ranges toegestaan wilt geven, met enkele uitzonderingen, dan kunnen we wellicht meedenken en eventueel een betere oplossing aanraden. Indien het om een aparte server gaat met belangrijke gegevens, dan heeft een firewall sowieso de voorkeur.Code:order allow, deny
1 allow from 24.132.0.0/17
1 allow from 24.132.128.0/17
1 allow from 31.3.8.0/21
1 allow from 31.3.96.0/21
1 allow from 31.3.104.0/2
2 deny from 24.132.128.2
3 any requests which do not match an Allow or a Deny directive are denied by default
Ok,
Als ik mensen gekwetst heb door hun oplossing niet goed te begrijpen, dan spijt me dat. Dat was niet de bedoeling. Excuses daarvoor. Ik ben nu eenmaal niet zo thuis in deze materie.
@Mikey / Dennis
Als ik het goed begrijp, hoef ik niet eerst alles te blokkeren, want hij blokkeert automatisch wat niet ge-allowed wordt?
Ok, gaan we proberen. Ik laat het jullie weten.
Yvette
Voorals nog lijkt het erop dat het werkt.
Ik houd je op de hoogte als daar verandering in komt.
Bedankt tot zover en nogmaals excuses, Yvette