Likes: 0
Je zou het gewoon zelf kunnen lezen:
# Finally copy automysqlbackup.sh to anywhere on your server and make sure
# to set executable permission. You can also copy the script to
# /etc/cron.daily to have it execute automatically every night or simply
# place a symlink in /etc/cron.daily to the file if you wish to keep it
# somwhere else.
vervang de sterretjes net als 'root' voor de user/pass. Geen spasies tussen -u<username> en -p<pass>/usr/local/bin/mysqldump -lv -uroot -p***** -A > /backup/file.sql
Hij vraagt nergens om als je het zo intypt. Wij draaien het in Crontab ook zo
Skynet ICT B.V. - The cause of the problem is: the printer thinks its a router.
/usr/bin/mysqldump -lv -uusername -ppassword -A > /Mysql_Backups/dbackup.sql
Zo werkt ie bij mij, nu ff nog een crontab aanmaken.
Omdat het bestandsnaam het zelfde is wordt ie bestand telkens ververst toch?
Jep, dus maak er een paar aan met verschillende filenames bv ?
Klarned Managed hosting Hosting, optimalisatie & debugging door WP Core developers![]()
Nou ik heb net in Direct Admin een cron aangemaakt.
Zoals je dit kunt zien op het fototje.
Maar ik bekijk het map op het server, dus die path die ik in het cron heb ingevoerd maar ik zie helemaas geen sql bestand.
Ondaks dat de tijd in het Cron is verlopen.
Enige idee waarom?
http://img114.imageshack.us/img114/3029/cronfl6.jpg

Voldoende schrijfrechten op de directory waarin je het .sql bestand plaatst?
Normaal worden cron error logs naar de mailbox van de user die de cron uitvoert gestuurd, of zichtbaar vanuit een optie in je controlpanel.
Je kan de cron output ook naar een logbestand sturen door bv. volgende achteraan je lijn toe te voegen: >> /home/admin/cronerror.log
Ja die map heeft gewoon zoals elke map het recht 0755
Ik voer het als root dus moet geen probleem zijn.
Nu heb ik dit cron geplaats na jou text :
/usr/bin/mysqldump -lv -u**** -p******* -A > /Mysql_Backups/diyar.sql>> /home/admin/cronerror.log
Nu komt er in map /Mysql_Backups een bestand van diyar.sql met 0 MB
En in map /home/admin het bestand cronerror.log met 93 MB
En 93 MB is mijn Database
Dus er is iets fouts.

Foutje van mijn kant: moest natuurlijk achteraan 2>/home/admin/cronerror.log zijn (dus 2> en niet >>). Zo zouden errors in die logfile moeten komen.
Nu, met >>, heb je gewoon alle output doorgestuurd naar cronerror.log, vandaar dat de database daarin terecht kwam.
Is me echter nog niet duidelijk waarom /usr/bin/mysqldump -lv -u**** -p******* -A > /Mysql_Backups/diyar.sql niet lukt.