Likes Likes:  0
Resultaten 1 tot 15 van de 20
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen

Onderwerp: Kernel fout?

  1. #1
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter

    Kernel fout?

    Beste WHT-ers,

    Heb hier nu een server welke geregeld de server zo gooit dat enkel pingen mogelijk is. Verder lijkt de gehele server dood te zijn. Nu heb ik de logs nagekeken en vindt ik nare kernel panic fouten. Ik denk dat een kernel update dit probleem kan verhelpen maar om het zeker te weten vraag ik het hier nog even.

    Hier de logfile van het tijdstip dat de server het begeeft:
    Sep 6 00:16:09 server kernel: Unable to handle kernel NULL pointer dereference at virtual address 00000020
    Sep 6 00:16:09 server kernel: printing eip:
    Sep 6 00:16:09 server kernel: c018cd64
    Sep 6 00:16:09 server kernel: *pde = 00000000
    Sep 6 00:16:09 server kernel: Oops: 0000 [#1]
    Sep 6 00:16:09 server kernel: Modules linked in: md5 ipv6 parport_pc lp parport ipt_TOS iptable_mangle ip_conntrack_ftp ip_conntrack_irc ipt_REJECT ipt_LOG ipt_limit iptable_filter ipt_multiport ipt_state ip_conntrack ip_tables autofs4 i2c_isa i2c_dev i2c_core sunrpc loop button battery ac ohci_hcd ehci_hcd k8_edac edac_mc snd_azx snd_hda_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc 3c59x mii forcedeth floppy dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod sata_nv libata sd_mod scsi_mod
    Sep 6 00:16:09 server kernel: CPU: 0
    Sep 6 00:16:09 server kernel: EIP: 0060:[<c018cd64>] Not tainted VLI
    Sep 6 00:16:09 server kernel: EFLAGS: 00210246 (2.6.9-55.0.2.EL)
    Sep 6 00:16:09 server kernel: EIP is at dnotify_flush+0xb/0x111
    Sep 6 00:16:09 server kernel: eax: 00000000 ebx: efd16c00 ecx: efd16c00 edx: ee78e040
    Sep 6 00:16:09 server kernel: esi: 00000000 edi: efd16c00 ebp: e9000f70 esp: e9000f64
    Sep 6 00:16:09 server kernel: ds: 007b es: 007b ss: 0068
    Sep 6 00:16:09 server kernel: Process httpd (pid: 5538, threadinfo=e9000000 task=ee6487c0)
    Sep 6 00:16:09 server kernel: Stack: efd16c00 00000000 ee78e040 00000006 c016ba5f ee78e040 0000ffff 000002c0
    Sep 6 00:16:09 server kernel: c0126338 ee122540 ee6487c0 ee122570 00000000 c0127318 00000001 00000000
    Sep 6 00:16:09 server kernel: 00000000 002c96f0 e9000000 c012776b 00000000 00000000 00000000 c031af83
    Sep 6 00:16:09 server kernel: Call Trace:
    Sep 6 00:16:09 server kernel: [<c016ba5f>] filp_close+0x49/0x5f
    Sep 6 00:16:09 server kernel: [<c0126338>] put_files_struct+0x56/0xbf
    Sep 6 00:16:09 server kernel: [<c0127318>] do_exit+0x2ec/0x5a7
    Sep 6 00:16:09 server kernel: [<c012776b>] sys_exit_group+0x0/0xd
    Sep 6 00:16:09 server kernel: [<c031af83>] syscall_call+0x7/0xb
    Sep 6 00:16:09 server kernel: Code: 98 01 00 00 89 c3 85 d2 74 0e 8b 42 04 8b 12 25 ff ff ff 7f 09 c1 eb ee 89 8b 94 01 00 00 5b c3 55 89 e5 57 89 c7 56 53 8b 40 08 <8b> 58 20 0f b7 43 20 25 00 f0 00 00 3d 00 40 00 00 0f 85 e7 00
    Sep 6 00:16:09 server kernel: <0>Fatal exception: panic in 5 seconds
    Als ik overigens met yum de kernel probeer te updaten dan geeft hij de volgende melding:
    [root@www01 html]# yum install kernel
    Setting up Install Process
    Setting up repositories
    update 100% |=========================| 951 B 00:00
    base 100% |=========================| 1.1 kB 00:00
    addons 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 95 kB 00:00
    update : ################################################## 304/304
    Added 4 new packages, deleted 0 old in 0.71 seconds
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Nothing to do
    Lijkt me dat hij niets gedaan heeft, of doe ik iets verkeerd? Zie mensen ook eerst yum remove kernel doen en dan install, slim om remote te doen?
    Laatst gewijzigd door ErikKosters; 06/09/07 om 00:55.

  2. #2
    Kernel fout?
    geregistreerd gebruiker
    6 Berichten
    Ingeschreven
    24/06/07

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Het zou kunnen dat de update het probleem niet raakt. Hij heeft immers maar 4 packages aangevuld. (nl niets gedelete).
    Een schone install zou dan mijn eerste optie zijn.

  3. #3
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Ik zie ook de volgende melding in de serverlog:
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs 16 17 18 19) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNEA] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNEB] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNEC] (IRQs 16 17 18 19) *11
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LNED] (IRQs 16 17 18 19) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LUB0] (IRQs 20 21 22 23) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LUB2] (IRQs 20 21 22 23) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LMAC] (IRQs 20 21 22 23) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LAZA] (IRQs 20 21 22 23) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LACI] (IRQs 20 21 22 23) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LMC9] (IRQs 20 21 22 23) *0, disabled.
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LSMB] (IRQs 20 21 22 23) *5
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LPMU] (IRQs 20 21 22 23) *10
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LSA0] (IRQs 20 21 22 23) *11
    Sep 6 07:51:27 server kernel: ACPI: PCI Interrupt Link [LSA1] (IRQs 20 21 22 23) *0, disabled.
    Sep 6 07:51:28 server kernel: ACPI: PCI Interrupt Link [LATA] (IRQs 20 21 22 23) *0, disabled.
    Dit zou betekenen dat er een IRQ conflict is, weet iemand of dit te beheren is vanuit Linux?

  4. #4
    Kernel fout?
    :-)
    528 Berichten
    Ingeschreven
    17/06/05

    Locatie
    Roosendaal

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 20121430
    Ondernemingsnummer: nvt

    IRQbalance, heb je dat geinstalled?

  5. #5
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Ja dat heb ik, wordt automatisch geinstalleerd zie ik. Overigens draai ik CentOS 4.4 Final op deze server.

  6. #6
    Kernel fout?
    a.k.a. Opa-Bullcat-
    1.182 Berichten
    Ingeschreven
    08/04/05

    Locatie
    Haarlem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34223894
    Ondernemingsnummer: nvt

    Met Yum update zou die van Centos 4.4 final 4.5 final moeten maken, tenminste hier wel dus !

  7. #7
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Oke heb het nu geupdate naar CentOS release 4.5 (Final). We zullen het even moeten afwachten.

  8. #8
    Kernel fout?
    geregistreerd gebruiker
    267 Berichten
    Ingeschreven
    16/03/07

    Locatie
    Brugge

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: nvt

    Heb je al een memtest en dergelijke gedaan?

  9. #9
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Hoe wil ik die remote gaan uitvoeren. Overigens is de server nog online (fingers crossed).

  10. #10
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Het is enkele dagen goed gegaan, maar hij is weeral gecrashed. De log heb ik hier staan: http://files.ek-hosting.nl/log.txt. De eerste regels is van de secundaire DNS welke via DirectAdmin loopt.

    Ik denk zelf dat het misschien beter is opnieuw te installeren met andere hardeschijf of dergelijke. Wat is jullie idee?
    Laatst gewijzigd door ErikKosters; 12/09/07 om 08:29.

  11. #11
    Kernel fout?
    moderator
    4.784 Berichten
    Ingeschreven
    04/11/05

    Locatie
    Gent

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    12 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: 0475284162

    Herinstalleren zonder dat je de oorzaak weet (of toch ongeveer) is vrij nutteloos in mijn ogen. Als het bvb memory is, dan gaat een reinstall niet helpen.

    De log die je post is enkel van de server restart. Zie ook hier even: http://www.webhostingtalk.com/showthread.php?t=593337, en kijk als je gelijkaardige sympthonen hebt.

  12. #12
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    Het komt redelijk overeen, ik krijg deze errors in mijn error_log:

    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    host: isc_socket_create: not enough free resources
    host: isc_socket_create: not enough free resources
    host: isc_socket_create: not enough free resources
    host: isc_socket_create: not enough free resources
    socket.c:2117: REQUIRE(maxfd <= (int)1024) failed.
    Ze geven daar aan om de kernel te updaten, maar ik gebruik al een recente versie (2.6.9-55.0.2.EL). Ook vindt ik op enkele fora dat ze PAM van SSH hebben disabled, hoe kijken jullie hier tegenaan?
    Laatst gewijzigd door ErikKosters; 12/09/07 om 09:05.

  13. #13
    Kernel fout?
    geregistreerd gebruiker
    3.705 Berichten
    Ingeschreven
    26/11/05

    Locatie
    Duivendrecht

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    27 Berichten zijn liked


    Naam: Gert Jan
    KvK nummer: 34272910

    Doe irqbalance eens uitzetten, dat heb je helemaal niet nodig.

  14. #14
    Kernel fout?
    EK-Hosting
    2.899 Berichten
    Ingeschreven
    07/06/05

    Locatie
    Hardenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Erik Kosters
    Bedrijf: EK-Hosting
    Functie: Eigenaar
    URL: ek-hosting.nl
    KvK nummer: 05078937

    Thread Starter
    irqbalance staat al uit

    Heb ook even de hardeschijven bekeken via hdparm, daar komt het volgende uit:

    [root@server ~]# hdparm -Tt /dev/sda
    /dev/sda:
    Timing cached reads: 1824 MB in 2.00 seconds = 911.23 MB/sec
    Timing buffered disk reads: 136 MB in 3.02 seconds = 45.00 MB/sec

    [root@server ~]# hdparm /dev/sda
    /dev/sda:
    HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
    IO_support = 0 (default 16-bit)
    readonly = 0 (off)
    readahead = 256 (on)
    geometry = 10011/255/63, sectors = 82348277760, start = 0
    Laatst gewijzigd door ErikKosters; 12/09/07 om 09:37. Reden: Automerged Dubbelpost

  15. #15
    Kernel fout?
    Unregistered user
    400 Berichten
    Ingeschreven
    27/12/04

    Locatie
    Geertruidenberg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Naam: Kees
    Bedrijf: Monshouwer InterNet Diensten
    URL: www.monshouwer.eu
    Registrar SIDN: ja
    KvK nummer: 18075928
    Ondernemingsnummer: nvt


Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics