Likes Likes:  0
Resultaten 1 tot 2 van de 2
Geen
  1. #1
    PowerDNS op Windows icm MySQL backend
    uhh?
    905 Berichten
    Ingeschreven
    18/12/04

    Locatie
    Leivere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 12060688
    Ondernemingsnummer: nvt

    Thread Starter

    PowerDNS op Windows icm MySQL backend

    Ik heb PowerDNS geinstalleerd op een Windows machines. Deze moet gaan communiceren met MySQL. Als ik het volgens de handleiding doe:

    Code:
    This chapter shows you how to configure the Generic MySQL backend, which we like a lot. But feel free to use any of the myriad other backends. This backend is called 'gmysql', and needs to be configured in pdns.conf. Add the following lines, adjusted for your local setup: 
    
    	launch=gmysql
    	gmysql-host=127.0.0.1
    	gmysql-user=root
    	gmysql-dbname=pdnstest
    Code:
    Now start PDNS using the monitor command: 
    
    	# /etc/init.d/pdns monitor
    	(...)
    	15:31:30 About to create 3 backend threads
    	15:31:30 [gMySQLbackend] Failed to connect to database: Error: Unknown database 'pdnstest'
    	15:31:30 [gMySQLbackend] Failed to connect to database: Error: Unknown database 'pdnstest'
    	15:31:30 [gMySQLbackend] Failed to connect to database: Error: Unknown database 'pdnstest'
    Ik krijg echter een andere output:

    Code:
    This is module godbcbackend reporting
    This is module gsqlite reporting
    This version doesn't support dynamic loading (yet).
    dnsbackend unable to load module in gmysql
    Iemand ideeën?

    Joepie de poepie, heb het zelf na een paar uur prutsen opgelost. Van de handleiding klopt iig geen **** meer van.

    Heb het nu opgelost door van de ODBC backend gebruik te maken. Config:

    Code:
    # Backends to launch at startup:
    launch=godbc
    godbc-datasource=PowerDNS
    godbc-username=***
    godbc-password=***
    #godbc-table=pdns
    Dus niet odbc-user + odbc-pass gebruiken zoals in de handleiding staat!

    Help! Ik zit weer vast. Ik wil dat de masterserver (Windows 2k3 + BIND) automatisch een notify stuurt naar de slave server (Windows 2k3 + PowerDNS).

    De slave server krijgt inderdaad een notify maar geeft de volgende melding:
    Code:
    Received NOTIFY for testing2.nl from 80.84.***.** for wich we are not authoritative.
    Ik heb de masterserver wel toegevoegd:
    Code:
    +--------------+-----------------+----------+
    | ip           | nameserver      | account  |
    +--------------+-----------------+----------+
    | 80.84.***.** | ns3.domain.com | NULL |
    +--------------+-----------------+----------+
    De slave server is ook ingesteld als slave. Kan het er iets mee te maken hebben dat ik gebruik maak van de odbc backend?
    Laatst gewijzigd door TiMMiEJ; 30/05/07 om 10:36. Reden: Automerged Dubbelpost

  2. #2
    PowerDNS op Windows icm MySQL backend
    uhh?
    905 Berichten
    Ingeschreven
    18/12/04

    Locatie
    Leivere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 12060688
    Ondernemingsnummer: nvt

    Thread Starter
    Niemand ?

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics