Likes Likes:  0
Resultaten 1 tot 8 van de 8
Geen

Onderwerp: Ddos of niet?

  1. #1
    Ddos of niet?
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Question Ddos of niet?

    Access_log:
    ::1 - - [26/May/2007:20:38:42 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:01 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:31 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:32 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:35 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:36 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:37 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:38 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:39:39 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:40:15 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:40:16 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:40:39 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:41:03 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:41:32 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:42:05 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:46 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:47 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:48 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:51 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:52 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:43:53 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:45:09 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:14 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:15 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:16 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:17 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:18 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:19 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:20 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:29 +0200] "GET /" 400 462
    ::1 - - [26/May/2007:20:54:32 +0200] "GET /" 400 462
    ...

    error_log bevat lijnen als:
    [Sat May 26 19:15:06 2007] [error] [client 85.17.159.16] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind

    Het probleem is het volgende:
    Alle sites draaien nog, maar onze api kan niet meer aangeroepen worden opeens.
    Inloggen op de hoofdsite gaat (zonder via api), de api aanroepen vanuit api.php op de hoofdsite werkt ook.
    Als we echter via de volgende code de api aanroepen, dan krijgen we steeds een lege $result terug:
    $url = "http://www.hoofdsite.com/api.php?".
    "type=login&login=".urlencode($login)."&pass=".url encode($pass);
    $result = @file_get_contents($url);


    Nu kan niemand dus nergens meer inloggen!
    Ramp!


    Iemand enige ervaring hiermee waarom dit opeens nu niet meer werkt?

    BEDANKT!

  2. #2
    Ddos of niet?
    moderator
    5.444 Berichten
    Ingeschreven
    12/09/05

    Locatie
    Zuid Holland

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    110 Berichten zijn liked


    Naam: Stijn
    KvK nummer: 14074337

    Haha, dat is niet bepaald Ddos gezien de tijdstippen.

  3. #3
    Ddos of niet?
    Banned
    224 Berichten
    Ingeschreven
    19/12/06

    Locatie
    bankje in het park

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt


  4. #4
    Ddos of niet?
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Maar wat is het dan?
    Waarom werkt opeens die file_get_contents niet meer.
    Het heeft gewerkt tot deze middag, daarna opeens geen $result meer :|


    Warning: file_get_contents() [function.file-get-contents]: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/site/fileget.php on line 10

    Warning: file_get_contents(http://www.site.com/api.php?test=1&t...asje&pass=test) [function.file-get-contents]: failed to open stream: Connection timed out in /var/www/site/fileget.php on line 10


    Wat betekend deze error?
    Dit is via een test bestand dat het aanroept.
    Laatst gewijzigd door klasje.be; 26/05/07 om 21:41.

  5. #5
    Ddos of niet?
    moderator
    5.444 Berichten
    Ingeschreven
    12/09/05

    Locatie
    Zuid Holland

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    110 Berichten zijn liked


    Naam: Stijn
    KvK nummer: 14074337

    Config foutje in je PHP? File weg?

  6. #6
    Ddos of niet?
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Het bestand bestaat, en de config is al meer dan een maand niet aangepast zie ik aan de datum...

  7. #7
    Ddos of niet?
    Gebruiker
    133 Berichten
    Ingeschreven
    02/12/03

    Locatie
    Venlo

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    ::1 is volgens mij localhost. Als je gebruik maakt van apc of xcache kan het helpen om apache opnieuw op te starten.

    Voor de rest is het erg moeilijk om zo een oorzaak aan te geven.

  8. #8
    Ddos of niet?
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Herstarten was geen oplossing.

    Na uren google en docs te doorzoeken kwam ik op de volgende oplossing die werkte:

    the problem was solved by adding the following line to my /etc/hosts:
    194.97.55.147 mx.freenet.de

    In dit geval gewoon mijn ip en site in de hosts zetten.
    Raar, dit heeft ALTIJD gewerkt tot nu toe, en zomaar opeens krijgt dat kuren...
    Was helemaal niets veranderd aan de server.

    Het staat al sinds 23 May 2001 in de php.net bugtracker...
    Nog altijd dus...


    Bedankt iedereen!


    (Zelfs bij google lukt het nu nog steeds niet:
    $content=file_get_contents("http://www.google.com",FALSE,NULL,0,20);
    echo $content;
    Is de standaard vb code van php.net, maar toch werkt het niet...
    Het moet opeens in de hosts staan...)



    OPLOSSING:
    /etc/resolv.conf stond 1 oude nameserver in.
    Deze veranderd en de problemen zijn opgelost!
    Laatst gewijzigd door klasje.be; 26/05/07 om 22:05.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics