Likes Likes:  0
Resultaten 1 tot 15 van de 18
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen
  1. #1
    Server.CreateObject Failed
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Server.CreateObject Failed

    Hallo,

    Een 'klant' heeft een website in klassiek ASP. Deze werkt lekker, totdat hij een FileSystemObject aanroept. Deze melding krijgt-ie:

    Server object error 'ASP 0177 : 800401f3'

    Server.CreateObject Failed

    /directory.asp, line 3

    800401f3
    Directory.asp bevat deze code:

    Code:
    <%
    Dim objFSO, strPath, objFolder, Folder
    Set objFSO = Server.CreateObject ("Scripting.FileSystemObject")
    strPath = Server.MapPath("../")
    Set objFolder = objFSO.GetFolder(strPath)
    
    response.write strPath & "<br />"
    For Each Folder in objFolder.SubFolders
    	response.write Folder.Name &  ": " & Folder.Size/(1024*1024) & " MB<br />"
    Next
    %>
    De server draait op IIS6/W2K3. Via Google ben ik bij deze tip gekomen:
    regsvr32 scrrun.dll

    Dll is geregistreerd, IIS gerestart maar geen soelaas. Andere ASP pages binnen die site doen het wel.

    Wat kan dit zijn?

  2. #2
    Server.CreateObject Failed
    Stockholm IT Productions
    1.405 Berichten
    Ingeschreven
    23/11/05

    Locatie
    Stockholm

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: SE860513303501
    Ondernemingsnummer: SE860513303501

    Om welk component gaat het?

  3. #3
    Server.CreateObject Failed
    geregistreerd gebruiker
    5 Berichten
    Ingeschreven
    07/02/07

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Ik ben de betreffende 'klant' en heb zo'n 8 jaar ervaring met IIS e.d., maar kwam hier zelf dus ook niet uit.
    Beide configuraties (oud & nieuw) zijn Windows 2003 Server machines.
    Oude site draaide bij een andere provider, nu overgezet naar de server die Glenn beheert.

    DLL is dus geregistreerd, dus het Scripting.FileSystemObject zou gewoon aangemaakt moeten kunnen worden.

    Hoe kunnen we achterhalen waarom IIS dit deze class niet kan instantieren en hoe dit op te lossen
    Laatst gewijzigd door JJvG; 07/02/07 om 21:11.

  4. #4
    Server.CreateObject Failed
    Stockholm IT Productions
    1.405 Berichten
    Ingeschreven
    23/11/05

    Locatie
    Stockholm

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: SE860513303501
    Ondernemingsnummer: SE860513303501

    Zou het kunnen dat het een nieuwe versie van het component is? En dat FileSystemObject daar een andere benaming heeft of iets dergelijks?

    Krijg je dezelfde error ook als je alleen maar de server.createobject doet, zonder andere code?

  5. #5
    Server.CreateObject Failed
    leaseweb
    245 Berichten
    Ingeschreven
    09/09/05

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Draait IIS onder de standaard gebruiker of een andere gebruiker? Deze melding krijg je vaak wanneer de rechten niet goed staan op het component.

  6. #6
    Server.CreateObject Failed
    geregistreerd gebruiker
    5 Berichten
    Ingeschreven
    07/02/07

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door martysmarty Bekijk Berichten
    Zou het kunnen dat het een nieuwe versie van het component is? En dat FileSystemObject daar een andere benaming heeft of iets dergelijks?

    Krijg je dezelfde error ook als je alleen maar de server.createobject doet, zonder andere code?
    Ja, helaas wel. Ik heb even een aparte pagina gemaakt met 1 regel:
    Set objFSO = Server.CreateObject("Scripting.FileSystemObject")

    Deze geeft dezelfde melding....

  7. #7
    Server.CreateObject Failed
    geregistreerd gebruiker
    36 Berichten
    Ingeschreven
    19/07/06

    Locatie
    Barchem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Misschien iets met de rechten op die DLL ?

  8. #8
    Server.CreateObject Failed
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door MDV Bekijk Berichten
    Misschien iets met de rechten op die DLL ?
    De desbetreffende DLL heeft geen specifieke rechten voor IUSR, dat heb ik nu wél gegeven. Het lijkt me echter vreemd dat dit zou moeten, aangezien overige ASP dll's ook geen specifieke IUSR rechten hebben terwijl die wel gewoon werken.

    Overigens heb ik nog geen reboot geprobeerd na al die wijzigingen, dat zal ik vanavond doen. Uit ervaring weet ik dat dat nog wel eens wilt helpen.

  9. #9
    Server.CreateObject Failed
    geregistreerd gebruiker
    5 Berichten
    Ingeschreven
    07/02/07

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Nog een paar sites waar ik meer op vond met tips (ook voor de andere lezers met hetzelfde probleem):

    ttp://classicasp.aspfaq.com/components/why-do-i-get-800401f3/800a01ad-errors.html
    en
    ttp://classicasp.aspfaq.com/components/why-do-i-get-server-createobject-access-error.html
    Mogelijk dat het script wel werkt als ik niet Server.CreateObject doe, maar CreateObject (zonder Server.) Kan het nu echter niet testen, omdat ik aan het werk ben.
    Laatst gewijzigd door JJvG; 08/02/07 om 10:56. Reden: mag geen http:// neerzetten, dus vandaar ttp://

  10. #10
    Server.CreateObject Failed
    geregistreerd gebruiker
    3.705 Berichten
    Ingeschreven
    26/11/05

    Locatie
    Duivendrecht

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    27 Berichten zijn liked


    Naam: Gert Jan
    KvK nummer: 34272910

    Toegang tot FSO wordt dichtgezet met IIS Lockdown.

    http://www.microsoft.com/technet/sec.../locktool.mspx

  11. #11
    Server.CreateObject Failed
    geregistreerd gebruiker
    5 Berichten
    Ingeschreven
    07/02/07

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door JJvG Bekijk Berichten
    Mogelijk dat het script wel werkt als ik niet Server.CreateObject doe, maar CreateObject (zonder Server.) Kan het nu echter niet testen, omdat ik aan het werk ben.
    Inmiddels bovenstaande scenario ook getest, maar helaas, het enige dat verandert, is de foutmelding:

    Microsoft VBScript runtime error '800a01ad'
    ActiveX component can't create object: 'Scripting.FileSystemObject'

  12. #12
    Server.CreateObject Failed
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door gjtje Bekijk Berichten
    Toegang tot FSO wordt dichtgezet met IIS Lockdown.

    http://www.microsoft.com/technet/sec.../locktool.mspx
    Reboot wil niet helpen. Locktool is alleen voor IIS5.0 en 4.0. Het betreft hier IIS6.

  13. #13
    Server.CreateObject Failed
    geregistreerd gebruiker
    5 Berichten
    Ingeschreven
    07/02/07

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Nog twee mogelijkheden gevonden, die misschien kunnen helpen bij het opsporen van een oplossing hiervoor. Er is een tooltje genaamd DCOMCNFG.EXE , waarmee je (als ik het goed begreep) je componenten kunt configureren en autoriseren. Staan nergens in je control-panel, maar bestaat wel in de system32 directory.

    Andere mogelijke oorzaak is verschil in filesysteem (NTFS vs FAT). Hierbij moet de IIS-user dus ook rechten krijgen op je system32 directory, ander mag het nog de DLL niet initieren (alleen lezen, zou waarschijnlijk voldoende moeten zijn).
    Bron (in het frans!):
    aspfr.com/infomsg_FILESYSTEMOBJECT-FSO-PROBLEME-SECURITE_281742.aspx
    Laatst gewijzigd door JJvG; 09/02/07 om 10:58. Reden: URL is http://www.aspfr.com/infomsg_FILESYSTEMOBJECT-FSO-PROBLEME-SECURITE_281742.aspx, maar dat mag ik hierboven niet posten

  14. #14
    Server.CreateObject Failed
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Heb IUSR toegevoegd aan de administrators-groep en ik krijg geen errors meer, maar keurig een dir output. Zit 'm dus in de security. Ben er echter nog niet achter wat er precies voor rechten nodig zijn. Ik zou wel heel system32 readable kunnen maken, maar dat lijkt mij niet echt safe.

    Beide schijven hebben NTFS filesystem.

  15. #15
    Server.CreateObject Failed
    geregistreerd gebruiker
    3.705 Berichten
    Ingeschreven
    26/11/05

    Locatie
    Duivendrecht

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    27 Berichten zijn liked


    Naam: Gert Jan
    KvK nummer: 34272910

    't Is 1 dll in de system32 folder, ik ben het tegen gekomen op google.

Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics