Likes Likes:  0
Resultaten 1 tot 9 van de 9
Geen

Onderwerp: Apache Errors

  1. #1
    Apache Errors
    geregistreerd gebruiker
    714 Berichten
    Ingeschreven
    03/10/05

    Locatie
    Breda

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: -
    KvK nummer: -
    Ondernemingsnummer: -

    Thread Starter

    Apache Errors

    Ik heb enige tijd geleden hier topic geplaats dat mijn server vastloopt, namelijk veel httpd connecties en hoge CPU load.
    Nu heb ik vandaag Apache geupdated naar 2.0.59
    Alles ging goed, server was duidelijk wat sneller.
    Maar nu dus 04:32 s'morgens zit ie weer vast.
    Als ik httpd restart doe werkt ie goed maar na 2 minutjes weer vast, alleen direct admin werkt.

    Ik merk dit in het error file :


    [Sun Oct 08 04:30:03 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

    [Sun Oct 08 04:29:33 2006] [notice] Apache/2.0.59 (Unix) mod_perl/1.99_17-dev Perl/v5.8.5 mod_ssl/2.0.59 OpenSSL/0.9.7a PHP/4.4.4
    FrontPage/5.0.2.2634 configured -- resuming normal operations

    [Sun Oct 08 04:29:44 2006] [error] server reached MaxClients setting, consider raising the MaxClients setting

    [Sun Oct 08 04:30:01 2006] [notice] caught SIGTERM, shutting down


    Heeft iemand een enige idee wat het probleem is?

  2. #2
    Apache Errors
    geregistreerd gebruiker
    3.705 Berichten
    Ingeschreven
    26/11/05

    Locatie
    Duivendrecht

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    27 Berichten zijn liked


    Naam: Gert Jan
    KvK nummer: 34272910

    Ik denk dat je maxclients waarde wordt bereikt, misschien dat je dit moet ophogen.

    Of te wel, de httpd.conf wijzigen.

  3. #3
    Apache Errors
    Programmeur / Hoster
    3.952 Berichten
    Ingeschreven
    20/06/06

    Locatie
    Wijlre

    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    647 Berichten zijn liked


    Naam: John Timmer
    Bedrijf: SystemDeveloper.NL
    Functie: Eigenaar
    URL: www.systemdeveloper.nl
    KvK nummer: 14083066
    View johntimmer's profile on LinkedIn

    Zolang je de maxclienst maar niet zo hoog zet dat alles gaat swappen want dan kun je de server net zo goed uitzetten

    Kijk eerst hoeveel geheugen er beschikbaar is voor apache. Kijk dan hoeveel geheugen wordt gebruikt door client httpd processsen. Deel dit op elkaar en je hebt het MaxClients getal. Kost even tijd voordat je dit naar wens hebt.

    Heb je meer connecties dan het macxlients getal, dan kun je dit ophogen totdat je merkt dat de server gaat swappen ( vmstat ).

    Zo moet je er wel ongeveer komen na een beetje knutselen.
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks

  4. #4
    Apache Errors
    geregistreerd gebruiker
    191 Berichten
    Ingeschreven
    11/12/05

    Locatie
    Venray

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Misschien kun je ook eens in je modules snijden.... heb je ze allemaal nodig?
    Ook je systeem tunen (memory, harddisk) kan wonderen doen.

    Wat bedoelk je met dat ie vast zit (en directadmin wel werkt)? Heb je rond de tijd van vastlopen geen logs?
    Welke distro? Loopt ie tegen het swappen aan? Type pc, hoeveel geheugen?

  5. #5
    Apache Errors
    geregistreerd gebruiker
    714 Berichten
    Ingeschreven
    03/10/05

    Locatie
    Breda

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: -
    KvK nummer: -
    Ondernemingsnummer: -

    Thread Starter
    Het is een CentOs 4.3
    512 RAM
    Met Apache 2.0.59

    httpd.conf :

    <IfModule prefork.c>
    StartServers 5
    MinSpareServers 5
    MaxSpareServers 10
    MaxClients 150
    MaxRequestsPerChild 0
    </IfModule>



    Het is absoluut geen server waar veel klanten op staan, of aantal klanten die veel load veroorzaken.
    Dit vastlopen gebeurt al 2 dagen rond een uur of 04:00
    Chek : http://85.17.42.13/mrtg/processes.html

    Als alles vastloopt werkt mijn httpd niet, wat wel werkt is Direct Admin, dus ik kan wel via http://www.mijndomein.nl:2222 direct admin binnen komen en alles bekijken.
    Daar zie ik bij Service Monitor dat httpd erg veel connecties heeft.
    IK doe een restart en alles opgelost maar mischien nog niet eens 1 minuut en het begint weer.

    Nogmaals, tijdens dit vastlopen heb ik alleen dit logs :

    [Sun Oct 08 05:04:10 2006] [error] server reached MaxClients setting, consider raising the MaxClients setting

    [Sun Oct 08 05:04:10 2006] [notice] SIGHUP received. Attempting to restart

    [Sun Oct 08 05:03:59 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

    [Sun Oct 08 05:05:06 2006] [error] server reached MaxClients setting, consider raising the MaxClients setting


    Ik heb mijn serverprovider hierover gemaild, die vragen een akoord van mij om het server te onderzoeken.
    Als het een hardware is dan kost het mij niks, maar als het geen hardware is moet ik wel 150,- p.u dokken

    IK heb op dit moment geen enige idee wat ik moet doen.

  6. #6
    Apache Errors
    geregistreerd gebruiker
    191 Berichten
    Ingeschreven
    11/12/05

    Locatie
    Venray

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Kam cron eens uit... zit er rond 04;00u iets raars. Anders zet van 03;50-04;30u de firewall eens dicht voor http. Installeer mod-security en mod-dosevasive.

    Paar ideeen...

  7. #7
    Apache Errors
    geregistreerd gebruiker
    714 Berichten
    Ingeschreven
    03/10/05

    Locatie
    Breda

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: -
    KvK nummer: -
    Ondernemingsnummer: -

    Thread Starter
    Mod dos evasive helpt niet, had ik al gedaan!

  8. #8
    Apache Errors
    geregistreerd gebruiker
    58 Berichten
    Ingeschreven
    30/08/06

    Locatie
    Ede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 09090351
    Ondernemingsnummer: nvt

    Je hebt een boel gelijktijdige HTTP connects, da's duidelijk. Zoek eens uit waar dat vandaan komt. Toch een site die drukker is dan je denkt? Scripts die traag zijn waardoor connecties lang open blijven staan? Iemand die gewoon expres connecties openhoudt om je server onderuit te halen?

    Check 's met netstat wat het allemaal voor connecties zijn.

  9. #9
    Apache Errors
    geregistreerd gebruiker
    191 Berichten
    Ingeschreven
    11/12/05

    Locatie
    Venray

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Ik gaf nog andere tips om dat soort problemen beter te analyseren.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics