PDA

Bekijk Volledige Versie : Mailto incl subject ?



Rob / kabel-inter.net
21/05/04, 12:55
Hi,

Als ik onder een hyperlink een mailto: aanmaak, zou ook gelijk het subject
ingevuld willen zien.
Hoe moet ik dit doen ?

TIA, Rob

Slaatje
21/05/04, 12:55
http://wdt.silent-aurora.net/html05.php


Rob / kabel-inter.net heeft geschreven in bericht
<40adddaa$1@news.kabel-inter.net>...
>Hi,
>
>Als ik onder een hyperlink een mailto: aanmaak, zou ook gelijk het subject
>ingevuld willen zien.
>Hoe moet ik dit doen ?
>
>TIA, Rob
>
>

Patrick
21/05/04, 13:05
Rob / kabel-inter.net wrote:

> Als ik onder een hyperlink een mailto: aanmaak, zou ook gelijk het subject
> ingevuld willen zien.
> Hoe moet ik dit doen ?

Zoeken met Google op "html mailto subject" leverde me binnen 3 seconden
een voorbeeld op:

<A HREF="mailto:manish@simplygraphix.com?subject=Feedback for
webdevelopersnotes.com&body=The Tips and Tricks section is
great">Send me an email</A>

En daarnaast heeft dit niets met server-side te maken, de volgende keer
kun je voor dit soort vragen in nl.internet.www.ontwerp terecht.

Groeten,

Patrick

Warden Dave
21/05/04, 13:15
"Patrick" <user@domain.invalid> wrote:
> Rob / kabel-inter.net wrote:

[mailto:]
> <A HREF="mailto:manish@simplygraphix.com?subject=Feedback for
> webdevelopersnotes.com&body=The Tips and Tricks section is
> great">Send me an email</A>
>
> En daarnaast heeft dit niets met server-side te maken, de volgende keer
> kun je voor dit soort vragen in nl.internet.www.ontwerp terecht.

Samen met Slaatje presenteer geef je hier intussen wel ondeugedelijke
antwoorden (sommige karakters zullen in een URLs geencodeerd moeten
worden). In NIWO, de nieuwsgroep voor gevorderden, zou men zeker en
vast verwezen hebben naar o.a. :
http://www.zvon.org/tmRFC/RFC2368/Output/index.html

WD

Rob / kabel-inter.net
21/05/04, 13:35
"Rob / kabel-inter.net" <usenet001@kabel-inter.net> schreef in bericht
news:40adddaa$1@news.kabel-inter.net...
> Hi,
>
> Als ik onder een hyperlink een mailto: aanmaak, zou ook gelijk het
subject
> ingevuld willen zien.
> Hoe moet ik dit doen ?

Mijn dank is groot.

CU, Rob

Patrick
21/05/04, 14:05
Warden Dave wrote:

> Samen met Slaatje presenteer geef je hier intussen wel ondeugedelijke
> antwoorden (sommige karakters zullen in een URLs geencodeerd moeten
> worden).

Overdrijven is ook een kunst (evenals typen zie ik), maar de spaties
zullen inderdaad door een %20 vervangen moeten worden.

Groeten,

Patrick

Warden Dave
21/05/04, 14:45
"Patrick" <user@domain.invalid> wrote:
> Warden Dave wrote:

> > Samen met Slaatje presenteer geef je hier intussen wel ondeugedelijke
> > antwoorden (sommige karakters zullen in een URLs geencodeerd moeten
> > worden).

> Overdrijven is ook een kunst (evenals typen zie ik), maar de spaties
> zullen inderdaad door een %20 vervangen moeten worden.

Ik ben blij dat je uiteindelijk ziet waar het om gaat! (Wat heeft een vragensteller
in godsnaam aan een "binnen 3 seconden" gevonden antwoord dat niet klopt?
Ook jij mag je, voor je 'de volgende keer' antwoord geeft, gerust afvragen of het
niet goed zou zijn dat je prestaties met Google minstens geevenaard worden
door je kennis van het onderwerp.)

WD

Patrick
21/05/04, 15:25
Warden Dave wrote:
> Ik ben blij dat je uiteindelijk ziet waar het om gaat! (Wat heeft een vragensteller
> in godsnaam aan een "binnen 3 seconden" gevonden antwoord dat niet klopt?

Het ging me er om dat hij eerst eens zelf zou hebben kunnen zoeken. Op
de eerste pagina met resultaten stonden overigens ook voldoende
voorbeelden met encoded strings. Inderdaad heb ik bij het voorbeeld dat
ik gaf even niet daarop gelet. Maar om net te doen alsof ik de plank
compleet mis sla, is nogal overdreven.

> Ook jij mag je, voor je 'de volgende keer' antwoord geeft, gerust afvragen of het
> niet goed zou zijn dat je prestaties met Google minstens geevenaard worden
> door je kennis van het onderwerp.)

Knap dat je op basis van een posting meent uitspraken over mijn kennis
van HTML te kunnen doen. Heb je vaker dat je te snel over anderen oordeelt?

Groeten,

Patrick

Warden Dave
21/05/04, 15:55
"Patrick" <user@domain.invalid> wrote:
> Warden Dave wrote:

>> Ik ben blij dat je uiteindelijk ziet waar het om gaat! (Wat heeft een vragensteller
>> in godsnaam aan een "binnen 3 seconden" gevonden antwoord dat niet klopt?

> Het ging me er om dat hij eerst eens zelf zou hebben kunnen zoeken. Op
> de eerste pagina met resultaten stonden overigens ook voldoende
> voorbeelden met encoded strings. Inderdaad heb ik bij het voorbeeld dat
> ik gaf even niet daarop gelet. Maar om net te doen alsof ik de plank
> compleet mis sla, is nogal overdreven.

Het enige dat werd opgemerkt is dat de 'gevonden' antwoorden _niet_ correct waren.

>> Ook jij mag je, voor je 'de volgende keer' antwoord geeft, gerust afvragen of het
>> niet goed zou zijn dat je prestaties met Google minstens geevenaard worden
>> door je kennis van het onderwerp.)

> Knap dat je op basis van een posting meent uitspraken over mijn kennis
> van HTML te kunnen doen. Heb je vaker dat je te snel over anderen oordeelt?

?

[Als een oordeel over jou gelijk _zou_ zijn aan een oordeel over je "kennis van
HTML" (?), en een oordeel over die "kennis van HTML" _zou_ gelijk zijn aan
een oordeel over het onderhavige onderwerp 'URL Character Encoding', dan ja,
ja dan...]

WD

Patrick
21/05/04, 17:05
Warden Dave wrote:
> Het enige dat werd opgemerkt is dat de 'gevonden' antwoorden _niet_ correct waren.

En ik merkte op dat de antwoorden, met een kleine toevoeging, correct
zijn. Maar als je het heel zwart-wit wilt bekijken, heb je *helemaal*
gelijk.

> [Als een oordeel over jou gelijk _zou_ zijn aan een oordeel over je "kennis van
> HTML" (?), en een oordeel over die "kennis van HTML" _zou_ gelijk zijn aan
> een oordeel over het onderhavige onderwerp 'URL Character Encoding', dan ja,
> ja dan...]

....dan wat?

Overigens had je 'het onderwerp' niet nader gespecificeerd, dus ik nam
maar aan dat je het over mijn kennis van HTML had. Blijkbaar had je het
specifiek over URL Character Encoding, maar ook daarover weet je niet
hoe het zit met mijn kennis.

Maar goed, ik vind de discussie enigszins onzinnig worden en wil het van
mijn kant hier bij laten. Je toevoeging over het encoden was wat mij
betreft een terechte, alleen de nogal belerende toon van je reactie
stoorde me.

Groeten,

Patrick

Warden Dave
21/05/04, 17:25
"Patrick" <user@domain.invalid> wrote:
> Warden Dave wrote:

> Maar goed, ik vind de discussie enigszins onzinnig worden en wil het van
> mijn kant hier bij laten. Je toevoeging over het encoden was wat mij
> betreft een terechte, alleen de nogal belerende toon van je reactie
> stoorde me.

Precies! Voor iemand die belerend aankomt met "En daarnaast..." en "de
volgende keer..." is het uiteraard pijnlijk op een echt ter zake doende 'fout'
te worden gewezen... (Ik 'moet' ter afsluiting zeggen: je hebt lange tenen &
pit, en dat mag ik wel!)

WD

John Bokma
21/05/04, 18:45
Warden Dave wrote:

> Samen met Slaatje presenteer geef je hier intussen wel ondeugedelijke
> antwoorden (sommige karakters zullen in een URLs geencodeerd moeten
> worden). In NIWO, de nieuwsgroep voor gevorderden, zou men zeker en
> vast verwezen hebben naar o.a. :
> http://www.zvon.org/tmRFC/RFC2368/Output/index.html

Neuh, de echte gevorderde hackt daar

http://www.zvon.org/tmRFC/RFC2368/Output/

van :-D.

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

Warden Dave
21/05/04, 18:55
"John Bokma" <postmaster@castleamber.com> wrote:
> Warden Dave wrote:

>> In NIWO, de nieuwsgroep voor gevorderden, zou men zeker en vast
>> verwezen hebben naar o.a. :
>> http://www.zvon.org/tmRFC/RFC2368/Output/index.html

> Neuh, de echte gevorderde hackt daar
> http://www.zvon.org/tmRFC/RFC2368/Output/
> van :-D.

Toch heb ik het vermoeden dat je aldaar de enige (klaarblijkelijk) 'gevorderde'
zou zijn die de moeite voor deze _enorme_ vooruitgang zou nemen, John! :)

WD

John Bokma
21/05/04, 23:25
Warden Dave wrote:

> "John Bokma" <postmaster@castleamber.com> wrote:
>
>>Warden Dave wrote:
>
>
>>>In NIWO, de nieuwsgroep voor gevorderden, zou men zeker en vast
>>>verwezen hebben naar o.a. :
>>> http://www.zvon.org/tmRFC/RFC2368/Output/index.html
>
>
>>Neuh, de echte gevorderde hackt daar
>>http://www.zvon.org/tmRFC/RFC2368/Output/
>>van :-D.
>
>
> Toch heb ik het vermoeden dat je aldaar de enige (klaarblijkelijk) 'gevorderde'
> zou zijn die de moeite voor deze _enorme_ vooruitgang zou nemen, John! :)

Nee hoor, er zit nl nogal wat nadelen aan het linken op je pagina naar
index.html. Het is inderdaad heel slim (vooruitgang) om consequent
index.html *niet* te gebruiken.

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

John Bokma
21/05/04, 23:35
Patrick wrote:

> Overdrijven is ook een kunst (evenals typen zie ik), maar de spaties
> zullen inderdaad door een %20 vervangen moeten worden.

Of een + (vind ikzelf leesbaarder)

Erg belangrijk is ook om de & te vervangen door &amp; En er zijn meer
"gevaarlijke" tekens.

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

Warden Dave
21/05/04, 23:35
"John Bokma" <postmaster@castleamber.com> wrote:
> Warden Dave wrote:

>>>> http://www.zvon.org/tmRFC/RFC2368/Output/index.html
>>>Neuh, de echte gevorderde hackt daar
>>>http://www.zvon.org/tmRFC/RFC2368/Output/
>>>van :-D.

>> Toch heb ik het vermoeden dat je aldaar de enige (klaarblijkelijk) 'gevorderde'
>> zou zijn die de moeite voor deze _enorme_ vooruitgang zou nemen, John! :)

> Nee hoor, er zit nl nogal wat nadelen aan het linken op je pagina naar
> index.html.

Dat hangt er maar vanaf...

Maar goed, dit is usenet, niet 'je pagina'.

WD

Warden Dave
22/05/04, 00:15
"John Bokma" <postmaster@castleamber.com> wrote:
> Patrick wrote:

>> Overdrijven is ook een kunst (evenals typen zie ik), maar de spaties
>> zullen inderdaad door een %20 vervangen moeten worden.

> Of een + (vind ikzelf leesbaarder)

Toch moet dat afgeraden worden. Het mag dan wel zo zijn dat in RFC1630
(http://www.zvon.org/tmRFC/RFC1630/Output/) geschreven stond:

"Within the query string, the plus sign is reserved as shorthand
notation for a space. Therefore, real plus signs must be encoded.
This method was used to make query URIs easier to pass in systems
which did not allow spaces."

....in RFC1738 wordt een 'plus sign' niet meer als reserverd aangemerkt.
(http://www.zvon.org/tmRFC/RFC1738/Output/)

Je zou nu toch echt aan '20%' de voorkeur moeten geven. [Daarbij is gebleken dat
'+' niet altijd en overal goed (meer) werkt.]

> Erg belangrijk is ook om de & te vervangen door &amp; En er zijn meer
> "gevaarlijke" tekens.

Dat had dus allemaal toch echt gelezen kunnen worden op gegeven adres (ook dat
'%20'), waar je zelf nog eens 'index.html' af mag halen:
http://www.zvon.org/tmRFC/RFC2368/Output/index.html


WD

John Bokma
22/05/04, 03:05
Warden Dave wrote:
> "John Bokma" <postmaster@castleamber.com> wrote:
>
>>Warden Dave wrote:
>
>
>>>>> http://www.zvon.org/tmRFC/RFC2368/Output/index.html
>>>>
>>>>Neuh, de echte gevorderde hackt daar
>>>>http://www.zvon.org/tmRFC/RFC2368/Output/
>>>>van :-D.
>
>
>>>Toch heb ik het vermoeden dat je aldaar de enige (klaarblijkelijk) 'gevorderde'
>>>zou zijn die de moeite voor deze _enorme_ vooruitgang zou nemen, John! :)
>
>
>>Nee hoor, er zit nl nogal wat nadelen aan het linken op je pagina naar
>>index.html.
>
> Dat hangt er maar vanaf...

Ja ja ja, sure.

> Maar goed, dit is usenet, niet 'je pagina'.

index.html is meestal overbodig, dus waarom zo een lange URL maken als
dat niet nodig is?

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

Warden Dave
22/05/04, 08:55
"John Bokma" <postmaster@castleamber.com> wrote:
> Warden Dave wrote:

> index.html is meestal overbodig, dus waarom zo een lange URL maken als
> dat niet nodig is?

Omdat ik 't ding niet "maak" maar gewoon van 'elders' in m'n bericht plak.
Buitengewoon interessant en belangrijk, niet?

WD

John Bokma
23/05/04, 01:35
Warden Dave wrote:

> "John Bokma" <postmaster@castleamber.com> wrote:
>
>>Warden Dave wrote:
>
>>index.html is meestal overbodig, dus waarom zo een lange URL maken als
>>dat niet nodig is?
>
> Omdat ik 't ding niet "maak" maar gewoon van 'elders' in m'n bericht plak.
> Buitengewoon interessant en belangrijk, niet?

Yup. Heel erg. Weet je ook waarom .../ de voorkeur geniet boven
..../index.html?

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

Warden Dave
23/05/04, 02:25
"John Bokma" <postmaster@castleamber.com> wrote:
> Warden Dave wrote:

> Yup. Heel erg. Weet je ook waarom .../ de voorkeur geniet boven
> .../index.html?

Ja, omdat jij - zoals bekend - een onverbeterlijke zwamneus bent die gaat
vertellen dat Zvon binnenkort met "DirectoryIndex john_bokma_weet.alles"
verder wil, en dat feest mogen we in geen enkele opzicht missen.

WD

John Bokma
23/05/04, 03:25
Warden Dave wrote:

> "John Bokma" <postmaster@castleamber.com> wrote:
>
>>Warden Dave wrote:
>
>
>>Yup. Heel erg. Weet je ook waarom .../ de voorkeur geniet boven
>>.../index.html?
>
> Ja, omdat jij - zoals bekend - een onverbeterlijke zwamneus bent die gaat
> vertellen dat Zvon binnenkort met "DirectoryIndex john_bokma_weet.alles"
> verder wil, en dat feest mogen we in geen enkele opzicht missen.

Het schoolmeestertje is op de vingers getikt :-D.

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/

Warden Dave
23/05/04, 03:45
"John Bokma" <postmaster@castleamber.com> wrote:

> Het schoolmeestertje is op de vingers getikt :-D.

Tuurljk, John. En nu weet iedereen ook dat jij een genie bent.

WD

John Bokma
23/05/04, 08:25
Warden Dave wrote:

> "John Bokma" <postmaster@castleamber.com> wrote:
>
>>Het schoolmeestertje is op de vingers getikt :-D.
>
> Tuurljk, John. En nu weet iedereen ook dat jij een genie bent.

Een genie en een zwamneus :-D. Je wordt met de dag creatiever :-P

--
John MexIT: http://johnbokma.com/mexit/
personal page: http://johnbokma.com/
Experienced Perl programmer available: http://castleamber.com/