PDA

Bekijk Volledige Versie : Websites op VPS soms (0-30 sec onbereikbaar)



groningenflip
19/02/12, 18:58
Sinds kort krijg ik van klanten te horen dat ze de website of mail soms niet kunnen ophalen hele korte tijd (0-30sec) (zelf ook ondervonden)
De server geeft aan dat die geen hoge load heeft en heeft een jaar zonder deze problemen gedraaid.

De server heb ik inmiddelds herstart en heb via SSH de load bekeken maar blijft laag en directadmin geeft zelden een melding dat het CPU verbruik hoog is.
Ik heb een MTR laten lopen sinds vrijdagavond maar hier word mij niet duidelijk of het netwerk het probleem veroorzaakt of de server zelf.

Yourwebhoster
19/02/12, 20:04
Sinds kort krijg ik van klanten te horen dat ze de website of mail soms niet kunnen ophalen hele korte tijd (0-30sec) (zelf ook ondervonden)
De server geeft aan dat die geen hoge load heeft en heeft een jaar zonder deze problemen gedraaid.

De server heb ik inmiddelds herstart en heb via SSH de load bekeken maar blijft laag en directadmin geeft zelden een melding dat het CPU verbruik hoog is.
Ik heb een MTR laten lopen sinds vrijdagavond maar hier word mij niet duidelijk of het netwerk het probleem veroorzaakt of de server zelf.
Is de mtr vanaf de VPS of naar de VPS? In ieder geval gaat het vanaf de VPS al verkeerd lijkt. Dit kan meerdere factoren hebben, een firewall kan bijvoorbeeld de ping tegenhouden maardat lijkt mij niet van toepassing omdat je aangeeft dat websites ook onbereikbaar zijn.

Wat ook kan is dat een VPS node te veel verbindingen krijgt (en de ip conntrack tabel vol zit) waardoor nieuwe verbindingen geweigerd worden en je geen verbinding kan krijgen.

groningenflip
19/02/12, 21:27
Test is vanaf thuis server naar vps toe.
Heb het probleem ook bij een ander vps die ik draai die valt onder een andere node werd mij verteld. (wel zelfde aanbieder)

Bart L
19/02/12, 21:40
Hoeveel users staan erop? (Lees hoe lang duur een apache reload).

patrickekkel
19/02/12, 21:54
Heb je ondertussen al contact gehad met jou hoster ?

Bart L
19/02/12, 22:18
Dat is een goeie Patrick, in ging er vanuit dat dat al lang was gebeurd.

groningenflip
19/02/12, 23:52
Uiteraard heb ik contact opgenomen, dat is de reden dat ik weet dat de vps die ik heb niet op dezelfde node draait.
5 users staan op het 1 vps specs 1 gb ram geheugen. (kleine websites/weinig bezoekers 200 p/dag)

Maar de MTR geeft een loss van 17% wat wil dat zeggen?

Yourwebhoster
20/02/12, 09:30
Uiteraard heb ik contact opgenomen, dat is de reden dat ik weet dat de vps die ik heb niet op dezelfde node draait.
5 users staan op het 1 vps specs 1 gb ram geheugen. (kleine websites/weinig bezoekers 200 p/dag)

Maar de MTR geeft een loss van 17% wat wil dat zeggen?
Dezelfde node als wat? Een andere VPS?

mbt de 17% loss, soms zal een router een ping negeren voor andere prioriteiten. Het is een hop met loss, je ziet dat de destination IP (onderste) hier geen last van heeft en 1% loss die je vanaf het begin van de mtr al hebt.

dennis0162
20/02/12, 09:55
Welke virtualisatie techniek gebruikt je provider? Bij OpenVZ zal de Een-na-laatste hop de server zelf zijn.

Als die 1% loss over de periode van Vrijdag t/m Zondag valt is dat vrij weinig.
Voor de zekerheid zou je Smokeping ook nog even kunnen installeren.

Ik denk dat je probleem ergens anders zit.
Zet er een monitoring op Apache & Ping bijvoorbeeld, dan weet je of het alleen je Apache is die er mee stopt of heel je VPS.

dreamhost_nl
20/02/12, 10:17
Wij hebben ooit eens zoiets gehad en toen bleek het te zitten, op een colo server dat dan weer wel, in de resolv.conf, waarin een DNS server was opgenomen die geen (correcte) waarde meer retourneerde. De server leek op zo'n moment even te bevriezen. Kan nooit kwaad om dit even na te gaan.

vDong
20/02/12, 12:02
Naast de resolvers controleren zou ik ook even iotop installeren en kijken wat die voor informatie geeft.

redbeenl
20/02/12, 14:28
Als het een virtueel platform is zou het ook aan de achterliggende opslag kunnen liggen. Dit zou je kunnen zien met de IO Wait in top, of met de servicetime in iostat -x. Zolang je VPS weinig te doen heeft, maar de achterliggende disk op de fysieke server wel druk zijn, kan de load op de VPS laag lijken maar deze wel tijdelijk niet goed reageren.

Ook vind ik dat er nogal wat variatie in de latency zit (tussen 14ms en 650ms).

systemdeveloper
20/02/12, 15:03
kan ook een klapperende NIC op de node zijn. Recentelijk iets gelijkwaardigs gehad op een dedicated... soms een paar seconden gewoon weg, niks in de logs e.d.... uiteindelijk de nic vervangen en probleem was opgelost.

groningenflip
21/02/12, 12:11
bedankt voor de informatie, ik laat het hier weten als ik meer weet.

cfmweb
21/02/12, 23:46
Hier staat eventueel ook nog wel iets http://help.directadmin.com/item.php?id=9